aboutsummaryrefslogtreecommitdiff
path: root/x11/i3status
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-01-30 08:08:46 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-01-30 08:08:46 +0000
commit7f7beef06c4c45c254279836034a47103a843ca7 (patch)
treeab4fe2b818c411aeafa6ec3c9f9efde1c0e32ec7 /x11/i3status
parent73635691ae10fe24ffaa0d5c40d6b2cf496a53db (diff)
downloadports-7f7beef06c4c45c254279836034a47103a843ca7.tar.gz
ports-7f7beef06c4c45c254279836034a47103a843ca7.zip
Fix the deciKelvin to Celsius conversion
Notes
Notes: svn path=/head/; revision=432819
Diffstat (limited to 'x11/i3status')
-rw-r--r--x11/i3status/Makefile1
-rw-r--r--x11/i3status/files/patch-src_print__cpu__temperature.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11/i3status/Makefile b/x11/i3status/Makefile
index f61f083733d0..9f5ed7d31267 100644
--- a/x11/i3status/Makefile
+++ b/x11/i3status/Makefile
@@ -2,6 +2,7 @@
PORTNAME= i3status
PORTVERSION= 2.11
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://i3wm.org/i3status/
diff --git a/x11/i3status/files/patch-src_print__cpu__temperature.c b/x11/i3status/files/patch-src_print__cpu__temperature.c
new file mode 100644
index 000000000000..03c1ca72886a
--- /dev/null
+++ b/x11/i3status/files/patch-src_print__cpu__temperature.c
@@ -0,0 +1,11 @@
+--- src/print_cpu_temperature.c.orig 2017-01-30 07:58:44 UTC
++++ src/print_cpu_temperature.c
+@@ -13,7 +13,7 @@
+ #include <err.h>
+ #include <sys/types.h>
+ #include <sys/sysctl.h>
+-#define TZ_ZEROC 2732
++#define TZ_ZEROC 2731
+ #define TZ_KELVTOC(x) (((x)-TZ_ZEROC) / 10), abs(((x)-TZ_ZEROC) % 10)
+ #define TZ_AVG(x) ((x)-TZ_ZEROC) / 10
+ #endif