aboutsummaryrefslogtreecommitdiff
path: root/x11/i3status
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-12-29 18:26:29 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-12-29 18:26:29 +0000
commitb9c8fa669488067e63e232d394930ef2e7f05b76 (patch)
treeb280d23917a5b9e6d8e3bc66fbde2a0cfb3b5a62 /x11/i3status
parent6e1fd0834dd4688e6d0eb7326c25d8bde7bfd382 (diff)
downloadports-b9c8fa669488067e63e232d394930ef2e7f05b76.tar.gz
ports-b9c8fa669488067e63e232d394930ef2e7f05b76.zip
- update to 2.6
- add an experimental support for "mute"
Notes
Notes: svn path=/head/; revision=309626
Diffstat (limited to 'x11/i3status')
-rw-r--r--x11/i3status/Makefile11
-rw-r--r--x11/i3status/distinfo4
-rw-r--r--x11/i3status/files/patch-src__print_volume.c26
3 files changed, 31 insertions, 10 deletions
diff --git a/x11/i3status/Makefile b/x11/i3status/Makefile
index 0878179b8a13..810459978530 100644
--- a/x11/i3status/Makefile
+++ b/x11/i3status/Makefile
@@ -1,12 +1,7 @@
-# New ports collection makefile for: i3status
-# Date created: 2011-12-08
-# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= i3status
-PORTVERSION= 2.5.1
+PORTVERSION= 2.6
CATEGORIES= x11
MASTER_SITES= http://i3wm.org/i3status/
@@ -15,8 +10,8 @@ COMMENT= Small program for generating a status bar
LICENSE= BSD
-LIB_DEPENDS= confuse.0:${PORTSDIR}/devel/libconfuse \
- yajl.2:${PORTSDIR}/devel/yajl
+LIB_DEPENDS= confuse:${PORTSDIR}/devel/libconfuse \
+ yajl:${PORTSDIR}/devel/yajl
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/x11/i3status/distinfo b/x11/i3status/distinfo
index 4bf2c023a18f..1b8297261b1c 100644
--- a/x11/i3status/distinfo
+++ b/x11/i3status/distinfo
@@ -1,2 +1,2 @@
-SHA256 (i3status-2.5.1.tar.bz2) = 7734efdf79a77617023f1e6d80080251eab3a05defb67313283568511d3e58f2
-SIZE (i3status-2.5.1.tar.bz2) = 30956
+SHA256 (i3status-2.6.tar.bz2) = e7e710cc271887bcd22757269e1b00a5618fb53abdb3455140116b3d38797bce
+SIZE (i3status-2.6.tar.bz2) = 34896
diff --git a/x11/i3status/files/patch-src__print_volume.c b/x11/i3status/files/patch-src__print_volume.c
new file mode 100644
index 000000000000..0158eb0cdcb2
--- /dev/null
+++ b/x11/i3status/files/patch-src__print_volume.c
@@ -0,0 +1,26 @@
+--- ./src/print_volume.c.orig 2012-10-03 13:44:44.000000000 +0200
++++ ./src/print_volume.c 2012-12-29 01:14:29.384748264 +0100
+@@ -175,8 +175,9 @@
+ }
+ #endif
+ #if defined(__FreeBSD__) || defined(__OpenBSD__)
+- char mixerpath[] = "/dev/mixer";
++ char mixerpath[] = "/dev/mixer";
+ int mixfd, vol, devmask = 0;
++ int pbval = 1;
+
+ if ((mixfd = open(mixerpath, O_RDWR)) < 0)
+ return;
+@@ -185,6 +186,12 @@
+ if (ioctl(mixfd, MIXER_READ(0),&vol) == -1)
+ return;
+
++ if ((vol & 0x7f) == 0 && (vol >> 8) & 0x7f == 0)
++ pbval = 0;
++
++ if (!pbval)
++ START_COLOR("color_bad");
++
+ const char *walk = fmt;
+ for (; *walk != '\0'; walk++) {
+ if (*walk != '%') {