aboutsummaryrefslogtreecommitdiff
path: root/x11/imwheel
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-20 16:23:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-20 16:23:28 +0000
commit7ae7b018ccf7760013f368fcb83aad9ecd8982a8 (patch)
treee83ee6693050a76e305a95a376451aa583df151e /x11/imwheel
parenta35ba13770957a577275c3575d979457605f2aff (diff)
downloadports-7ae7b018ccf7760013f368fcb83aad9ecd8982a8.tar.gz
ports-7ae7b018ccf7760013f368fcb83aad9ecd8982a8.zip
With the power of USES=dos2unix, get rid of most patches and files
with CRLF. While there, run make makepatch, rename patches to use the new scheme, and various fixes. With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=417166
Diffstat (limited to 'x11/imwheel')
-rw-r--r--x11/imwheel/Makefile3
-rw-r--r--x11/imwheel/files/patch-Makefile.in4
-rw-r--r--x11/imwheel/files/patch-getopt_Makefile.in (renamed from x11/imwheel/files/patch-getopt__Makefile.in)7
-rw-r--r--x11/imwheel/files/patch-getopt_getopt.c (renamed from x11/imwheel/files/patch-getopt__getopt.c)32
-rw-r--r--x11/imwheel/files/patch-imwheel.119
-rw-r--r--x11/imwheel/files/patch-imwheelrc10
-rw-r--r--x11/imwheel/files/patch-util.c15
7 files changed, 44 insertions, 46 deletions
diff --git a/x11/imwheel/Makefile b/x11/imwheel/Makefile
index 566ab35a2ef3..f47b2a5a1393 100644
--- a/x11/imwheel/Makefile
+++ b/x11/imwheel/Makefile
@@ -15,7 +15,8 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USE_XORG= x11 xpm xtst xext xmu
-USES= gmake
+USES= dos2unix gmake
+DOS2UNIX_FILES= getopt/getopt.c
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gpm
diff --git a/x11/imwheel/files/patch-Makefile.in b/x11/imwheel/files/patch-Makefile.in
index ea5f4bb8d54b..a6bd1d2cb2f0 100644
--- a/x11/imwheel/files/patch-Makefile.in
+++ b/x11/imwheel/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig 2004-08-29 18:36:33.000000000 +0800
-+++ Makefile.in 2014-01-09 21:48:23.000000000 +0800
+--- Makefile.in.orig 2004-08-29 10:36:33 UTC
++++ Makefile.in
@@ -215,7 +215,7 @@ imwheel_LDADD = @GETOPT_LIBS@ -L$(top_bu
imwheel_DEPENDENCIES = imwheel.o util.o cfg.o jax/libjax.a
man_MANS = imwheel.1
diff --git a/x11/imwheel/files/patch-getopt__Makefile.in b/x11/imwheel/files/patch-getopt_Makefile.in
index b1e87ba485c8..9254a81feb1a 100644
--- a/x11/imwheel/files/patch-getopt__Makefile.in
+++ b/x11/imwheel/files/patch-getopt_Makefile.in
@@ -1,6 +1,6 @@
---- getopt/Makefile.in.orig Sun Aug 29 06:33:21 2004
-+++ getopt/Makefile.in Sun Nov 7 08:57:49 2004
-@@ -161,7 +161,7 @@
+--- getopt/Makefile.in.orig 2004-08-29 10:33:21 UTC
++++ getopt/Makefile.in
+@@ -161,7 +161,7 @@ subdirs = @subdirs@
suid = @suid@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@@ -9,4 +9,3 @@
noinst_LIBRARIES = libgetopt.a
libgetopt_a_SOURCES = getopt.c getopt1.c getopt.h
EXTRA_DIST = Makefile.unix
-
diff --git a/x11/imwheel/files/patch-getopt__getopt.c b/x11/imwheel/files/patch-getopt_getopt.c
index 47198b724f93..aa8b79e8ca3d 100644
--- a/x11/imwheel/files/patch-getopt__getopt.c
+++ b/x11/imwheel/files/patch-getopt_getopt.c
@@ -1,16 +1,16 @@
---- getopt/getopt.c.orig Tue Apr 6 05:22:57 1999
-+++ getopt/getopt.c Fri Jun 29 01:22:22 2001
-@@ -166,11 +166,12 @@
- /* Value of POSIXLY_CORRECT environment variable. */
- static char *posixly_correct;
-
--#ifdef __GNU_LIBRARY__
-+#if defined(__GNU_LIBRARY__) || defined(__FreeBSD__)
- /* We want to avoid inclusion of string.h with non-GNU libraries
- because there are many ways it can cause trouble.
- On some systems, it contains special magic macros that don't work
- in GCC. */
-+#include <stdlib.h>
- #include <string.h>
- #define my_index strchr
- #else
+--- getopt/getopt.c.orig 2016-06-20 12:59:05 UTC
++++ getopt/getopt.c
+@@ -166,11 +166,12 @@ static enum
+ /* Value of POSIXLY_CORRECT environment variable. */
+ static char *posixly_correct;
+
+-#ifdef __GNU_LIBRARY__
++#if defined(__GNU_LIBRARY__) || defined(__FreeBSD__)
+ /* We want to avoid inclusion of string.h with non-GNU libraries
+ because there are many ways it can cause trouble.
+ On some systems, it contains special magic macros that don't work
+ in GCC. */
++#include <stdlib.h>
+ #include <string.h>
+ #define my_index strchr
+ #else
diff --git a/x11/imwheel/files/patch-imwheel.1 b/x11/imwheel/files/patch-imwheel.1
index b8dad75d9412..b757dd4fc66d 100644
--- a/x11/imwheel/files/patch-imwheel.1
+++ b/x11/imwheel/files/patch-imwheel.1
@@ -1,6 +1,6 @@
---- imwheel.1.orig Sun Nov 7 08:47:14 2004
-+++ imwheel.1 Sun Nov 7 08:49:03 2004
-@@ -329,7 +329,7 @@
+--- imwheel.1.orig 2004-06-10 01:41:49 UTC
++++ imwheel.1
+@@ -329,7 +329,7 @@ sum = 0
.fi
.RE
.SH "IMWHEELRC"
@@ -9,13 +9,12 @@
which is used for everybody. The other is $HOME/.imwheelrc, used only for one
user. One is supplied and should have been installed automatically in /etc/X11/imwheel/
if not also in the installing users $HOME as well. All whitespace is ignored
-@@ -671,7 +671,7 @@
+@@ -671,7 +671,7 @@ Jonathan Atkins <jcatki@jonatkins.org>
$HOME/.imwheelrc
- The users configuration file.
-
+ The users configuration file.
+
-/etc/X11/imwheel/imwheelrc
+%%PREFIX%%/etc/imwheelrc
- The global location for the configuration
- file, it is always loaded. Overided by
- the users configuration file.
-
+ The global location for the configuration
+ file, it is always loaded. Overided by
+ the users configuration file.
diff --git a/x11/imwheel/files/patch-imwheelrc b/x11/imwheel/files/patch-imwheelrc
index 8aa449a9517e..ee374d695796 100644
--- a/x11/imwheel/files/patch-imwheelrc
+++ b/x11/imwheel/files/patch-imwheelrc
@@ -1,6 +1,6 @@
---- imwheelrc.orig Wed Feb 23 15:14:20 2000
-+++ imwheelrc Wed Feb 23 15:25:12 2000
-@@ -34,6 +34,10 @@
+--- imwheelrc.orig 2004-06-10 01:41:49 UTC
++++ imwheelrc
+@@ -96,6 +96,10 @@ Control_L, Down, C
None, Down, KP_Subtract
None, Up, KP_Add
@@ -11,7 +11,7 @@
"^Xman"
None, Down, F
Shift_L, Down, 3
-@@ -52,14 +56,14 @@
+@@ -138,14 +142,14 @@ None, Up, Shift_L|Page_Up
None, Down, Shift_L|Page_Down
"^rxvt"
@@ -31,4 +31,4 @@
+None, Right, Control_L|E
#Shift_L, Down, Shift_L|1
- "^Netscape"
+ "^VMware"
diff --git a/x11/imwheel/files/patch-util.c b/x11/imwheel/files/patch-util.c
index 7bac7521304c..fa67129dda90 100644
--- a/x11/imwheel/files/patch-util.c
+++ b/x11/imwheel/files/patch-util.c
@@ -1,12 +1,11 @@
---- util.c.orig Sun Aug 29 06:21:46 2004
-+++ util.c Sun Nov 7 09:10:33 2004
-@@ -735,7 +735,7 @@
-
+--- util.c.orig 2004-08-29 10:21:46 UTC
++++ util.c
+@@ -735,7 +735,7 @@ int file_allowed(char *fname)
+
struct WinAction *getRC()
{
- char fname[2][1024]={"","/etc/X11/imwheel/imwheelrc"}, line[1024], *p, *q, winid[1024];
+ char fname[2][1024]={"","/usr/X11R6/etc/imwheelrc"}, line[1024], *p, *q, winid[1024];
- int fi,i;
- struct WinAction *newwa=NULL;
- FILE *f=NULL;
-
+ int fi,i;
+ struct WinAction *newwa=NULL;
+ FILE *f=NULL;