aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-baseapps
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-09-24 20:41:38 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-09-24 20:41:38 +0000
commitae879c4c060c22deb5f17085a300dce7f4a601c4 (patch)
tree9cc85c5413df407568c25685bc707affe9bd8482 /x11/kde4-baseapps
parentd2a633163bdfc580cbac1dc15090629ce2095da0 (diff)
downloadports-ae879c4c060c22deb5f17085a300dce7f4a601c4.tar.gz
ports-ae879c4c060c22deb5f17085a300dce7f4a601c4.zip
Notes
Diffstat (limited to 'x11/kde4-baseapps')
-rw-r--r--x11/kde4-baseapps/Makefile7
-rw-r--r--x11/kde4-baseapps/files/patch-apps__kinfocenter__base__CMakeLists.txt11
-rw-r--r--x11/kde4-baseapps/files/patch-apps__kinfocenter__base__info_fbsd.cpp57
-rw-r--r--x11/kde4-baseapps/files/patch-apps__kinfocenter__info__CMakeLists.txt11
4 files changed, 83 insertions, 3 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index c8079617e60b..fd3215bc754e 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -18,8 +19,7 @@ COMMENT= Basic applications for the KDE system
LIB_DEPENDS= searchclient:${PORTSDIR}/deskutils/strigi \
soprano.4:${PORTSDIR}/textproc/soprano \
- qimageblitz.4:${PORTSDIR}/x11/qimageblitz \
- pci.2:${PORTSDIR}/devel/libpci
+ qimageblitz.4:${PORTSDIR}/x11/qimageblitz
LATEST_LINK= ${PORTNAME}4
@@ -35,7 +35,8 @@ KDE4_BUILDENV= yes
MAKE_JOBS_SAFE= yes
CMAKE_ARGS+= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib" \
- -DWITH_RAW1394:BOOL=OFF
+ -DWITH_RAW1394:BOOL=OFF \
+ -DWITH_PCIUTILS:BOOL=OFF
MAN1= kappfinder.1 \
kbookmarkmerger.1 \
diff --git a/x11/kde4-baseapps/files/patch-apps__kinfocenter__base__CMakeLists.txt b/x11/kde4-baseapps/files/patch-apps__kinfocenter__base__CMakeLists.txt
new file mode 100644
index 000000000000..72b28620dcec
--- /dev/null
+++ b/x11/kde4-baseapps/files/patch-apps__kinfocenter__base__CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./apps/kinfocenter/base/CMakeLists.txt.orig 2008-04-18 11:21:39.000000000 +0400
++++ ./apps/kinfocenter/base/CMakeLists.txt 2009-09-04 00:32:17.000000000 +0400
+@@ -2,7 +2,7 @@
+ # TODO: HAVE_LIBDEVINFO_H (for Solaris 7 and later)
+ # to be set if both -ldevinfo and libdevinfo.h exist
+
+-check_include_files(devinfo.h HAVE_DEVINFO_H) # info_fbsd.cpp
++check_include_files("sys/types.h;devinfo.h" HAVE_DEVINFO_H) # info_fbsd.cpp
+ check_include_files(fstab.h HAVE_FSTAB_H) # info_linux.cpp
+ check_include_files(linux/raw.h HAVE_LINUX_RAW_H) # info_linux.cpp
+ check_include_files(mntent.h HAVE_MNTENT_H) # info_linux.cpp
diff --git a/x11/kde4-baseapps/files/patch-apps__kinfocenter__base__info_fbsd.cpp b/x11/kde4-baseapps/files/patch-apps__kinfocenter__base__info_fbsd.cpp
new file mode 100644
index 000000000000..026806449c4e
--- /dev/null
+++ b/x11/kde4-baseapps/files/patch-apps__kinfocenter__base__info_fbsd.cpp
@@ -0,0 +1,57 @@
+--- ./apps/kinfocenter/base/info_fbsd.cpp.orig 2009-04-15 14:25:24.000000000 +0400
++++ ./apps/kinfocenter/base/info_fbsd.cpp 2009-09-22 21:33:38.000000000 +0400
+@@ -211,28 +211,17 @@
+ FILE *pipe;
+ QFile *pcicontrol;
+ QString s, cmd;
++ QTextStream *t;
+ QTreeWidgetItem *olditem= NULL;
+
+ pcicontrol = new QFile("/usr/sbin/pciconf");
+
+ if (!pcicontrol->exists()) {
++ QStringList list;
++ list << i18n("Could not find any programs with which to query your system's PCI information");
++ new QTreeWidgetItem(tree, list);
+ delete pcicontrol;
+- pcicontrol = new QFile("/usr/X11R6/bin/scanpci");
+- if (!pcicontrol->exists()) {
+- delete pcicontrol;
+- pcicontrol = new QFile("/usr/X11R6/bin/pcitweak");
+- if (!pcicontrol->exists()) {
+- QStringList list;
+- list << i18n("Could not find any programs with which to query your system's PCI information");
+- new QTreeWidgetItem(tree, list);
+- delete pcicontrol;
+- return true;
+- } else {
+- cmd = "/usr/X11R6/bin/pcitweak -l 2>&1";
+- }
+- } else {
+- cmd = "/usr/X11R6/bin/scanpci";
+- }
++ return true;
+ } else {
+ cmd = "/usr/sbin/pciconf -l -v 2>&1";
+ }
+@@ -247,8 +236,19 @@
+ /* This prints out a list of all the pci devies, perhaps eventually we could
+ parse it as opposed to schlepping it into a listbox */
+
++ t = new QTextStream(pipe, QIODevice::ReadOnly);
++
++ while (true) {
++ s = t->readLine();
++ if (s.isEmpty() )
++ break;
++ QStringList list;
++ list << s;
++ new QTreeWidgetItem(tree, list);
++ }
++
++ delete t;
+ pclose(pipe);
+- GetInfo_ReadfromPipe(tree, cmd.toLatin1(), true);
+ }
+
+ if (!tree->topLevelItemCount()) {
diff --git a/x11/kde4-baseapps/files/patch-apps__kinfocenter__info__CMakeLists.txt b/x11/kde4-baseapps/files/patch-apps__kinfocenter__info__CMakeLists.txt
new file mode 100644
index 000000000000..c3b3c28f59fe
--- /dev/null
+++ b/x11/kde4-baseapps/files/patch-apps__kinfocenter__info__CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./apps/kinfocenter/info/CMakeLists.txt.orig 2008-04-23 19:51:22.000000000 +0400
++++ ./apps/kinfocenter/info/CMakeLists.txt 2009-09-04 00:42:28.000000000 +0400
+@@ -12,7 +12,7 @@
+
+ kde4_add_plugin(kcm_info ${kcm_info_PART_SRCS})
+
+-target_link_libraries(kcm_info ${KDE4_KDEUI_LIBS} ${QT_QTGUI_LIBRARY} ${X11_X11_LIB})
++target_link_libraries(kcm_info ${KDE4_KDEUI_LIBS} ${QT_QTGUI_LIBRARY} ${X11_X11_LIB} devinfo)
+
+
+ install(TARGETS kcm_info DESTINATION ${PLUGIN_INSTALL_DIR} )