aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4-baseapps
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-03-25 10:33:51 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-03-25 10:33:51 +0000
commitc1f3de0f55e58790d19f686e510418e212aee85c (patch)
tree9c83366b7e53439af8a08cb4d55853e9209564e1 /x11/kde4-baseapps
parentccbd618ebd63ebf72b64b3b6679b6ee11976f839 (diff)
downloadports-c1f3de0f55e58790d19f686e510418e212aee85c.tar.gz
ports-c1f3de0f55e58790d19f686e510418e212aee85c.zip
Notes
Diffstat (limited to 'x11/kde4-baseapps')
-rw-r--r--x11/kde4-baseapps/Makefile1
-rw-r--r--x11/kde4-baseapps/distinfo4
-rw-r--r--x11/kde4-baseapps/files/patch-dolphin__src__panels__terminal__terminalpanel.cpp31
-rw-r--r--x11/kde4-baseapps/files/patch-konqueror__src__CMakeLists.txt11
-rw-r--r--x11/kde4-baseapps/pkg-plist6
5 files changed, 49 insertions, 4 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index b9c677e8a87b..53a0c3a31df4 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -16,7 +16,6 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Basic applications for the KDE system
-BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
LIB_DEPENDS= searchclient:${PORTSDIR}/deskutils/strigi \
soprano.4:${PORTSDIR}/textproc/soprano \
qimageblitz.4:${PORTSDIR}/x11/qimageblitz \
diff --git a/x11/kde4-baseapps/distinfo b/x11/kde4-baseapps/distinfo
index 2345f8a2fb54..b9ea034bc610 100644
--- a/x11/kde4-baseapps/distinfo
+++ b/x11/kde4-baseapps/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kdebase-4.5.5.tar.bz2) = c66ef93efeb75762fbb1a07395bb03f64c0b9cf353bc3969fc327056b209b31f
-SIZE (KDE/kdebase-4.5.5.tar.bz2) = 2643134
+SHA256 (KDE/kdebase-4.6.1.tar.bz2) = ab216a1c0fb0b4713f2b3f77d1783b0f64ba44982dcc57d05c40c5ce7668204f
+SIZE (KDE/kdebase-4.6.1.tar.bz2) = 2681575
diff --git a/x11/kde4-baseapps/files/patch-dolphin__src__panels__terminal__terminalpanel.cpp b/x11/kde4-baseapps/files/patch-dolphin__src__panels__terminal__terminalpanel.cpp
new file mode 100644
index 000000000000..04ddd15939e3
--- /dev/null
+++ b/x11/kde4-baseapps/files/patch-dolphin__src__panels__terminal__terminalpanel.cpp
@@ -0,0 +1,31 @@
+--- dolphin/src/panels/terminal/terminalpanel.cpp~ 2011-02-26 00:33:12.000000000 +0200
++++ dolphin/src/panels/terminal/terminalpanel.cpp 2011-03-14 17:41:58.000000000 +0200
+@@ -19,6 +19,8 @@
+
+ #include "terminalpanel.h"
+
++#include <signal.h>
++
+ #include <kpluginloader.h>
+ #include <kpluginfactory.h>
+ #include <kde_terminal_interface_v2.h>
+@@ -111,16 +113,12 @@
+
+ void TerminalPanel::sendCdToTerminal(const QString& dir)
+ {
+- if (!m_clearTerminal) {
++ if (!m_clearTerminal)
+ // The TerminalV2 interface does not provide a way to delete the
+ // current line before sending a new input. This is mandatory,
+ // otherwise sending a 'cd x' to a existing 'rm -rf *' might
+- // result in data loss. As workaround Ctrl+C is send.
+- QString cancel;
+- cancel.append(QChar(3));
+- cancel.append(QChar('c'));
+- m_terminal->sendInput(cancel);
+- }
++ // result in data loss. As workaround SIGINT is send.
++ ::kill(m_terminal->terminalProcessId(), SIGINT);
+
+ m_terminal->sendInput("cd " + KShell::quoteArg(dir) + '\n');
+
diff --git a/x11/kde4-baseapps/files/patch-konqueror__src__CMakeLists.txt b/x11/kde4-baseapps/files/patch-konqueror__src__CMakeLists.txt
new file mode 100644
index 000000000000..13a1cb556339
--- /dev/null
+++ b/x11/kde4-baseapps/files/patch-konqueror__src__CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./konqueror/src/CMakeLists.txt.orig 2011-02-25 22:55:12.000000000 +0100
++++ ./konqueror/src/CMakeLists.txt 2011-03-04 12:09:23.643348069 +0100
+@@ -33,7 +33,7 @@
+ kde4_add_library(konquerorprivate SHARED ${konquerorprivate_SRCS})
+ target_link_libraries(konquerorprivate konq ${KDE4_KPARTS_LIBS} ${ZLIB_LIBRARY})
+ set_target_properties(konquerorprivate PROPERTIES VERSION ${GENERIC_LIB_VERSION} SOVERSION ${GENERIC_LIB_SOVERSION} )
+-install(TARGETS konquerorprivate ${INSTALL_TARGETS_DEFAULT_ARGS} LIBRARY NAMELINK_SKIP)
++install(TARGETS konquerorprivate ${INSTALL_TARGETS_DEFAULT_ARGS})
+
+ ########### konqueror ###############
+ if (WIN32)
diff --git a/x11/kde4-baseapps/pkg-plist b/x11/kde4-baseapps/pkg-plist
index 96cffcc4eaf6..12fb85f8c61b 100644
--- a/x11/kde4-baseapps/pkg-plist
+++ b/x11/kde4-baseapps/pkg-plist
@@ -43,6 +43,7 @@ lib/kde4/kcm_useraccount.so
lib/kde4/kded_favicons.so
lib/kde4/kded_konqy_preloader.so
lib/kde4/khtmlkttsdplugin.so
+lib/kde4/kio_filenamesearch.so
lib/kde4/konq_aboutpage.so
lib/kde4/konq_shellcmdplugin.so
lib/kde4/konq_sidebar.so
@@ -92,7 +93,6 @@ share/applications/kde4/konqbrowser.desktop
share/applications/kde4/konquerorsu.desktop
share/applications/kde4/konsole.desktop
share/applications/kde4/kwrite.desktop
-share/apps/dolphin/dolphinsearchcommands.desktop
share/apps/dolphin/dolphinui.rc
share/apps/dolphinpart/dolphinpart.rc
share/apps/dolphinpart/kpartplugins/kshellcmdplugin.desktop
@@ -240,6 +240,8 @@ share/doc/HTML/en/konqueror/dirtree.png
share/doc/HTML/en/konqueror/dragdrop.png
share/doc/HTML/en/konqueror/faq.docbook
share/doc/HTML/en/konqueror/filemanager.docbook
+share/doc/HTML/en/konqueror/format-font-size-less.png
+share/doc/HTML/en/konqueror/format-font-size-more.png
share/doc/HTML/en/konqueror/index.cache.bz2
share/doc/HTML/en/konqueror/index.docbook
share/doc/HTML/en/konqueror/introduction.docbook
@@ -253,6 +255,7 @@ share/doc/HTML/en/konqueror/save-settings.docbook
share/doc/HTML/en/konqueror/shortcut1.png
share/doc/HTML/en/konqueror/shortcut2.png
share/doc/HTML/en/konqueror/sidebar.docbook
+share/doc/HTML/en/konqueror/viewproperties-dialog.png
share/doc/HTML/en/konsole/common
share/doc/HTML/en/konsole/index.cache.bz2
share/doc/HTML/en/konsole/index.docbook
@@ -278,6 +281,7 @@ share/kde4/services/cookies.desktop
share/kde4/services/dolphinpart.desktop
share/kde4/services/ebrowsing.desktop
share/kde4/services/filebehavior.desktop
+share/kde4/services/filenamesearch.protocol
share/kde4/services/kcm_useraccount.desktop
share/kde4/services/kcmdolphingeneral.desktop
share/kde4/services/kcmdolphinnavigation.desktop