aboutsummaryrefslogtreecommitdiff
path: root/x11/kdebase4
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2006-06-14 18:53:15 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2006-06-14 18:53:15 +0000
commit3b7843e6f84a55db753dbe036bab217a23a18c4f (patch)
tree98d8de981315082182b70cf3512212a3ff21b542 /x11/kdebase4
parent700ccde3f79d61c4cd462fe8d26ad86bad4c65c3 (diff)
downloadports-3b7843e6f84a55db753dbe036bab217a23a18c4f.tar.gz
ports-3b7843e6f84a55db753dbe036bab217a23a18c4f.zip
Notes
Diffstat (limited to 'x11/kdebase4')
-rw-r--r--x11/kdebase4/Makefile2
-rw-r--r--x11/kdebase4/files/patch-kdm-config.def11
-rw-r--r--x11/kdebase4/files/patch-kioslave_media_mediamanager-fstabbackend.cpp46
-rw-r--r--x11/kdebase4/files/patch-kioslave_media_mediamanager-fstabbackend.h19
-rw-r--r--x11/kdebase4/files/patch-kpager-windowdrag.cpp11
-rw-r--r--x11/kdebase4/files/patch-post-3.5.0-kdebase-kdm21
6 files changed, 96 insertions, 14 deletions
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index 71c72b08db2f..04eb6f152145 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdebase4/files/patch-kdm-config.def b/x11/kdebase4/files/patch-kdm-config.def
new file mode 100644
index 000000000000..5d1b849cc1d7
--- /dev/null
+++ b/x11/kdebase4/files/patch-kdm-config.def
@@ -0,0 +1,11 @@
+--- kdm/config.def.orig Wed Jun 14 17:51:42 2006
++++ kdm/config.def Wed Jun 14 17:51:57 2006
+@@ -36,7 +36,7 @@
+ # define HALT_CMD "/usr/sbin/shutdown -h now"
+ # define REBOOT_CMD "/usr/sbin/shutdown -r now"
+ #elif defined(BSD)
+-# define HALT_CMD "/sbin/shutdown -h now"
++# define HALT_CMD "/sbin/shutdown -p now"
+ # define REBOOT_CMD "/sbin/shutdown -r now"
+ #elif defined(__SVR4)
+ # define HALT_CMD "/usr/sbin/halt"
diff --git a/x11/kdebase4/files/patch-kioslave_media_mediamanager-fstabbackend.cpp b/x11/kdebase4/files/patch-kioslave_media_mediamanager-fstabbackend.cpp
index 210698a0b31a..5861ae9e7bff 100644
--- a/x11/kdebase4/files/patch-kioslave_media_mediamanager-fstabbackend.cpp
+++ b/x11/kdebase4/files/patch-kioslave_media_mediamanager-fstabbackend.cpp
@@ -1,5 +1,5 @@
---- kioslave/media/mediamanager/fstabbackend.cpp Mon May 22 20:12:42 2006
-+++ kioslave/media/mediamanager/fstabbackend.cpp Fri Mar 17 11:17:33 2006
+--- kioslave/media/mediamanager/fstabbackend.cpp 2006/03/23 09:19:38 521680
++++ kioslave/media/mediamanager/fstabbackend.cpp 2006/06/14 09:11:46 551306
@@ -144,7 +144,7 @@
void FstabBackend::handleMtabChange(bool allowNotification)
@@ -9,26 +9,46 @@
KMountPoint::List mtab = KMountPoint::currentMountPoints();
KMountPoint::List::iterator it = mtab.begin();
-@@ -158,14 +158,6 @@
-
- if ( ::inExclusionPattern(*it, m_networkSharesOnly) ) continue;
-
-- /* Did we know this already before ? If yes, then
-- nothing has changed, do not stat the mount point. Avoids
-- hang if network shares are stalling */
-- QString mtabEntry = dev + "*" + mp + "*" + fs;
+@@ -162,18 +162,19 @@
+ nothing has changed, do not stat the mount point. Avoids
+ hang if network shares are stalling */
+ QString mtabEntry = dev + "*" + mp + "*" + fs;
- bool isOldEntry = m_mtabEntries.contains(mtabEntry);
- new_mtabEntries+=mtabEntry;
- if (isOldEntry) continue;
--
++ if(m_mtabEntries.contains(mtabEntry)) {
++ new_mtabIds += m_mtabEntries[mtabEntry];
++ continue;
++ }
+
QString id = generateId(dev, mp);
new_mtabIds+=id;
++ m_mtabEntries[mtabEntry] = id;
+
+ if ( !m_mtabIds.contains(id) && m_fstabIds.contains(id) )
+ {
+ QString mime, icon, label;
+ guess(dev, mp, fs, true, mime, icon, label);
+-
+ m_mediaList.changeMediumState(id, true, false,
+ mime, icon, label);
+ }
+@@ -211,6 +212,10 @@
+ QString mp = medium->mountPoint();
+ QString fs = medium->fsType();
+
++
++ QString mtabEntry = dev + "*" + mp + "*" + fs;
++ m_mtabEntries.remove(mtabEntry);
++
+ QString mime, icon, label;
+ guess(dev, mp, fs, false, mime, icon, label);
-@@ -226,7 +218,6 @@
+@@ -226,7 +231,6 @@
}
m_mtabIds = new_mtabIds;
- m_mtabEntries = new_mtabEntries;
}
- void FstabBackend::handleFstabChange(bool allowNotification) \ No newline at end of file
+ void FstabBackend::handleFstabChange(bool allowNotification)
diff --git a/x11/kdebase4/files/patch-kioslave_media_mediamanager-fstabbackend.h b/x11/kdebase4/files/patch-kioslave_media_mediamanager-fstabbackend.h
new file mode 100644
index 000000000000..5a6ac43ebad8
--- /dev/null
+++ b/x11/kdebase4/files/patch-kioslave_media_mediamanager-fstabbackend.h
@@ -0,0 +1,19 @@
+--- kioslave/media/mediamanager/fstabbackend.h 2006/03/23 09:19:38 521680
++++ kioslave/media/mediamanager/fstabbackend.h 2006/06/14 09:11:46 551306
+@@ -23,6 +23,7 @@
+
+ #include <qobject.h>
+ #include <qstringlist.h>
++#include <qmap.h>
+
+ #ifdef Q_OS_FREEBSD
+ #include <qtimer.h>
+@@ -53,7 +54,7 @@
+
+ bool m_networkSharesOnly;
+ QStringList m_mtabIds;
+- QStringList m_mtabEntries;
++ QMap<QString, QString> m_mtabEntries;
+ QStringList m_fstabIds;
+ #ifdef Q_OS_FREEBSD
+ QTimer m_mtabTimer;
diff --git a/x11/kdebase4/files/patch-kpager-windowdrag.cpp b/x11/kdebase4/files/patch-kpager-windowdrag.cpp
new file mode 100644
index 000000000000..c09bb7c8f3af
--- /dev/null
+++ b/x11/kdebase4/files/patch-kpager-windowdrag.cpp
@@ -0,0 +1,11 @@
+--- kpager/windowdrag.cpp 2006/05/23 12:51:36 544025
++++ kpager/windowdrag.cpp 2006/06/05 19:55:59 548525
+@@ -31,7 +31,7 @@
+ QString tmp;
+ tmp.sprintf("%d %d %d %d", static_cast<int>(w), deltax, deltay, origdesk);
+ QByteArray data(tmp.length()+1);
+- data.assign(tmp.latin1(),tmp.length()+1);
++ data.duplicate(tmp.latin1(),tmp.length()+1);
+
+ setEncodedData(data);
+ }
diff --git a/x11/kdebase4/files/patch-post-3.5.0-kdebase-kdm b/x11/kdebase4/files/patch-post-3.5.0-kdebase-kdm
new file mode 100644
index 000000000000..129a10594be4
--- /dev/null
+++ b/x11/kdebase4/files/patch-post-3.5.0-kdebase-kdm
@@ -0,0 +1,21 @@
+Index: kdm/backend/client.c
+===================================================================
+--- kdm/backend/client.c (revision 547560)
++++ kdm/backend/client.c (working copy)
+@@ -1537,16 +1542,6 @@ ReadDmrc()
+
+ if (!StrApp( &fname, p->pw_dir, "/.dmrc", (char *)0 ))
+ return GE_Error;
+- if ((curdmrc = iniLoad( fname ))) {
+- free( fname );
+- return GE_Ok;
+- }
+-
+- if (errno != EACCES) {
+- free( fname );
+- return GE_NoFile;
+- }
+-
+ if (pipe( pfd ))
+ return GE_Error;
+ if ((pid = Fork()) < 0) {