aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs3
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-10-29 23:48:18 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-10-29 23:48:18 +0000
commitc13a5bcfcd39a60b06331e0e456f81187f336764 (patch)
tree24d87d150c14833a85f8fac72b8a8e53d186d7c8 /x11/kdelibs3
parent16387cc66d68e7df0f3953c17282a1ba85fc5eb5 (diff)
downloadports-c13a5bcfcd39a60b06331e0e456f81187f336764.tar.gz
ports-c13a5bcfcd39a60b06331e0e456f81187f336764.zip
Notes
Diffstat (limited to 'x11/kdelibs3')
-rw-r--r--x11/kdelibs3/Makefile8
-rw-r--r--x11/kdelibs3/distinfo6
-rw-r--r--x11/kdelibs3/files/patch-kdecore-kstartupinfo.cpp42
-rw-r--r--x11/kdelibs3/files/patch-kdeprint_cups_cupsdconf2_cups-util.c606
-rw-r--r--x11/kdelibs3/files/patch-kdeprint_management_smbview.cpp11
-rw-r--r--x11/kdelibs3/files/patch-kdeui-kactionclasses.cpp13
-rw-r--r--x11/kdelibs3/files/patch-kinit-start_kdeinit_wrapper.c11
-rw-r--r--x11/kdelibs3/files/patch-kioslave_http-http.cc39
-rw-r--r--x11/kdelibs3/files/patch-post-3.5.7-kdelibs-kdecore-2.diff34
-rw-r--r--x11/kdelibs3/pkg-plist5
10 files changed, 116 insertions, 659 deletions
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index a2074e82c132..d3b9f148dbe5 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 3
+PORTREVISION= 0
CATEGORIES= x11 kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -79,10 +79,6 @@ FONTENCOD= ${X11BASE}/lib/X11/fonts/encodings/encodings.dir
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
.endif # !exists(/usr/bin/bzip2)
-.if !exists(/usr/bin/pgrep)
-RUN_DEPENDS+= pgrep:${PORTSDIR}/sysutils/pkill
-.endif # !exists(/usr/bin/pgrep)
-
.if ${X_WINDOW_SYSTEM:L} != xorg
BUILD_DEPENDS+= mkfontdir:${X_CLIENTS_PORT}
RUN_DEPENDS+= iceauth:${X_CLIENTS_PORT}
@@ -103,6 +99,8 @@ pre-configure:
-e "s,/etc/security/,${LOCALBASE}/etc/,g" \
-e "s,'fileshare','network',g" \
${WRKSRC}/kio/misc/fileshareset
+ ${REINPLACE_CMD} -e "s,LIB_QT),LIB_QT) $$\(LIBPTHREAD\) $$\(USE_THREADS\),g" \
+ ${WRKSRC}/dcop/dcopidl/Makefile.in ${WRKSRC}/dcop/dcopidl2cpp/Makefile.in
${MV} ${WRKSRC}/kded/applications.menu ${WRKSRC}/kded/kde-applications.menu
post-configure:
diff --git a/x11/kdelibs3/distinfo b/x11/kdelibs3/distinfo
index 6a0bc34dc3fa..96d54b9e3d7a 100644
--- a/x11/kdelibs3/distinfo
+++ b/x11/kdelibs3/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/kdelibs-3.5.7.tar.bz2) = 50ed644f2ec91963570fe2b155652957
-SHA256 (KDE/kdelibs-3.5.7.tar.bz2) = 05bc5d0d18b787d964f7c45cc078b047d450d3ddc28b1bde839a26a2eda2c5d9
-SIZE (KDE/kdelibs-3.5.7.tar.bz2) = 15576038
+MD5 (KDE/kdelibs-3.5.8.tar.bz2) = acaa37e79e840d10dca326277a20863c
+SHA256 (KDE/kdelibs-3.5.8.tar.bz2) = 779f563fdf0385b973f2238f04d82b5729aefe1c949e4d29482b6bb170aa3fe6
+SIZE (KDE/kdelibs-3.5.8.tar.bz2) = 15557343
diff --git a/x11/kdelibs3/files/patch-kdecore-kstartupinfo.cpp b/x11/kdelibs3/files/patch-kdecore-kstartupinfo.cpp
new file mode 100644
index 000000000000..62be701bb371
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kdecore-kstartupinfo.cpp
@@ -0,0 +1,42 @@
+--- kdecore/kstartupinfo.cpp 2007/10/08 11:32:36 722993
++++ kdecore/kstartupinfo.cpp 2007/10/12 12:13:00 724472
+@@ -545,7 +545,7 @@
+
+ void KStartupInfo::setNewStartupId( QWidget* window, const QCString& startup_id )
+ {
+- long activate = true;
++ bool activate = true;
+ kapp->setStartupId( startup_id );
+ if( window != NULL )
+ {
+@@ -937,7 +937,7 @@
+ #ifdef Q_WS_X11
+ extern Time qt_x_user_time;
+ #else
+- long qt_x_user_time = 0;
++ unsigned long qt_x_user_time = 0;
+ #endif
+ QCString id = QString( "%1;%2;%3;%4_TIME%5" ).arg( hostname ).arg( tm.tv_sec )
+ .arg( tm.tv_usec ).arg( getpid()).arg( qt_x_user_time ).utf8();
+@@ -1078,7 +1078,9 @@
+ if( pos >= 0 )
+ {
+ bool ok;
+- long time = d->id.mid( pos + 5 ).toLong( &ok );
++ unsigned long time = d->id.mid( pos + 5 ).toULong( &ok );
++ if( !ok && d->id[ pos + 5 ] == '-' ) // try if it's as a negative signed number perhaps
++ time = d->id.mid( pos + 5 ).toLong( &ok );
+ if( ok )
+ return time;
+ }
+@@ -1093,7 +1095,9 @@
+ if( pos2 >= 0 )
+ {
+ bool ok;
+- long time = d->id.mid( pos2 + 1, pos1 - pos2 - 1 ).toLong( &ok );
++ unsigned long time = d->id.mid( pos2 + 1, pos1 - pos2 - 1 ).toULong( &ok );
++ if( !ok && d->id[ pos + 5 ] == '-' ) // try if it's as a negative signed number perhaps
++ time = d->id.mid( pos2 + 1, pos1 - pos2 - 1 ).toLong( &ok );
+ if( ok )
+ return time;
+ }
diff --git a/x11/kdelibs3/files/patch-kdeprint_cups_cupsdconf2_cups-util.c b/x11/kdelibs3/files/patch-kdeprint_cups_cupsdconf2_cups-util.c
deleted file mode 100644
index 4aaef3b9e766..000000000000
--- a/x11/kdelibs3/files/patch-kdeprint_cups_cupsdconf2_cups-util.c
+++ /dev/null
@@ -1,606 +0,0 @@
- --- kdeprint/cups/cupsdconf2/cups-util.c-orig 2007-10-02 21:36:37.442645546 -0500
- +++ kdeprint/cups/cupsdconf2/cups-util.c 2007-10-02 21:42:08.991708625 -0500
- @@ -6,489 +6,118 @@
- #include <sys/stat.h>
- #include <unistd.h>
-
- -#define CUPS_SERVERROOT "/etc/cups"
- -static http_t *cups_server;
- static ipp_status_t last_error;
- -static char authstring[HTTP_MAX_VALUE];
- -static char pwdstring[33];
- -static int cups_local_auth(http_t *http);
-
- -const char * /* O - Filename for PPD file */
- +const char* cupsGetConf(void);
- +int cupsPutConf(const char*);
- +
- +const char * /* O - Filename for PPD file */
- cupsGetConf(void)
- {
- - int fd; /* PPD file */
- - int bytes; /* Number of bytes read */
- - char buffer[8192]; /* Buffer for file */
- - char resource[HTTP_MAX_URI]; /* Resource name */
- - const char *password; /* Password string */
- - char realm[HTTP_MAX_VALUE], /* realm="xyz" string */
- - nonce[HTTP_MAX_VALUE], /* nonce="xyz" string */
- - plain[255], /* Plaintext username:password */
- - encode[512]; /* Encoded username:password */
- - http_status_t status; /* HTTP status from server */
- - char prompt[1024]; /* Prompt string */
- - int digest_tries; /* Number of tries with Digest */
- - static char filename[HTTP_MAX_URI]; /* Local filename */
- -
- - /*
- - * Connect to the correct server as needed...
- - */
- -
- - if ((cups_server = httpConnectEncrypt(cupsServer(), ippPort(),
- - cupsEncryption())) == NULL)
- - {
- - last_error = IPP_SERVICE_UNAVAILABLE;
- - return (NULL);
- - }
- -
- - /*
- - * Get a temp file...
- - */
- -
- - if ((fd = cupsTempFd(filename, sizeof(filename))) < 0)
- - {
- - /*
- - * Can't open file; close the server connection and return NULL...
- - */
- -
- - httpFlush(cups_server);
- - httpClose(cups_server);
- - cups_server = NULL;
- - return (NULL);
- - }
- -
- - /*
- - * And send a request to the HTTP server...
- - */
- -
- - snprintf(resource, sizeof(resource), "/admin/conf/cupsd.conf");
- -
- - digest_tries = 0;
- -
- - do
- - {
- - httpClearFields(cups_server);
- - httpSetField(cups_server, HTTP_FIELD_HOST, cupsServer());
- - httpSetField(cups_server, HTTP_FIELD_AUTHORIZATION, authstring);
- -
- - if (httpGet(cups_server, resource))
- - {
- - if (httpReconnect(cups_server))
- - {
- - status = HTTP_ERROR;
- - break;
- - }
- - else
- - {
- - status = HTTP_UNAUTHORIZED;
- - continue;
- - }
- - }
- -
- - while ((status = httpUpdate(cups_server)) == HTTP_CONTINUE);
- -
- - if (status == HTTP_UNAUTHORIZED)
- - {
- - fprintf(stderr,"cupsGetConf: unauthorized...\n");
- -
- - /*
- - * Flush any error message...
- - */
- -
- - httpFlush(cups_server);
- -
- - /*
- - * See if we can do local authentication...
- - */
- -
- - if (cups_local_auth(cups_server))
- - continue;
- -
- - /*
- - * See if we should retry the current digest password...
- - */
- -
- - if (strncmp(cups_server->fields[HTTP_FIELD_WWW_AUTHENTICATE], "Basic", 5) == 0 ||
- - digest_tries > 1 || !pwdstring[0])
- - {
- - /*
- - * Nope - get a password from the user...
- - */
- -
- - snprintf(prompt, sizeof(prompt), "Password for %s on %s? ", cupsUser(),
- - cups_server->hostname);
- -
- - if ((password = cupsGetPassword(prompt)) == NULL)
- - break;
- - if (!password[0])
- - break;
- -
- - strncpy(pwdstring, password, sizeof(pwdstring) - 1);
- - pwdstring[sizeof(pwdstring) - 1] = '\0';
- -
- - digest_tries = 0;
- - }
- - else
- - digest_tries ++;
- -
- - /*
- - * Got a password; encode it for the server...
- - */
- -
- - if (strncmp(cups_server->fields[HTTP_FIELD_WWW_AUTHENTICATE], "Basic", 5) == 0)
- - {
- - /*
- - * Basic authentication...
- - */
- -
- - snprintf(plain, sizeof(plain), "%s:%s", cupsUser(), pwdstring);
- -#if CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR >= 2
- - httpEncode64_2(encode, sizeof(encode), plain, sizeof(plain));
- -#else
- - httpEncode64(encode, plain);
- -#endif
- - snprintf(authstring, sizeof(authstring), "Basic %s", encode);
- - }
- - else
- - {
- - /*
- - * Digest authentication...
- - */
- -
- - httpGetSubField(cups_server, HTTP_FIELD_WWW_AUTHENTICATE, "realm", realm);
- - httpGetSubField(cups_server, HTTP_FIELD_WWW_AUTHENTICATE, "nonce", nonce);
- -
- - httpMD5(cupsUser(), realm, pwdstring, encode);
- - httpMD5Final(nonce, "GET", resource, encode);
- - snprintf(authstring, sizeof(authstring),
- - "Digest username=\"%s\", realm=\"%s\", nonce=\"%s\", "
- - "response=\"%s\"", cupsUser(), realm, nonce, encode);
- - }
- -
- - continue;
- - }
- -#ifdef HAVE_LIBSSL
- - else if (status == HTTP_UPGRADE_REQUIRED)
- - {
- - /*
- - * Flush any error message...
- - */
- -
- - httpFlush(cups_server);
- -
- - /*
- - * Upgrade with encryption...
- - */
- -
- - httpEncryption(cups_server, HTTP_ENCRYPT_REQUIRED);
- -
- - /*
- - * Try again, this time with encryption enabled...
- - */
- -
- - continue;
- - }
- -#endif /* HAVE_LIBSSL */
- - }
- - while (status == HTTP_UNAUTHORIZED || status == HTTP_UPGRADE_REQUIRED);
- -
- - /*
- - * See if we actually got the file or an error...
- - */
- + int fd; /* PPD file */
- + http_status_t status; /* HTTP status from server */
- + http_t *cups_server;
- + static char filename[HTTP_MAX_URI]; /* Local filename */
- + char fqdn[ HTTP_MAX_URI ]; /* Server name buffer */
- +
- +
- + /*
- + * Connect to the correct server as needed...
- + */
- +
- + cups_server = httpConnectEncrypt(cupsServer(), ippPort(), cupsEncryption());
- + if (cups_server == NULL) {
- + last_error = IPP_SERVICE_UNAVAILABLE;
- + return (NULL);
- + }
- +
- + /*
- + * Get a temp file...
- + */
- +
- + fd = cupsTempFd(filename, sizeof(filename));
- + if (fd < 0) {
- + /*
- + * Can't open file; close the server connection and return NULL...
- + */
- +
- + httpFlush(cups_server);
- + httpClose(cups_server);
- + cups_server = NULL;
- + return (NULL);
- + }
- +
- + /*
- + * And send a request to the HTTP server...
- + */
- + status = cupsGetFd(cups_server, "/admin/conf/cupsd.conf", fd);
-
- - if (status != HTTP_OK)
- - {
- close(fd);
- - unlink(filename);
- httpFlush(cups_server);
- httpClose(cups_server);
- cups_server = NULL;
- - return (NULL);
- - }
- -
- - /*
- - * OK, we need to copy the file...
- - */
-
- - while ((bytes = httpRead(cups_server, buffer, sizeof(buffer))) > 0)
- - {
- - write(fd, buffer, bytes);
- - }
- -
- - close(fd);
- -
- - return (filename);
- + if (status != HTTP_OK) {
- + unlink(filename);
- + return (NULL);
- + } else {
- + return (filename);
- + }
- }
-
- -int /* O - Status of operation */
- -cupsPutConf(const char *name) /* I - Name of the config file to send */
- +int /* O - Status of operation */
- +cupsPutConf(const char *name) /* I - Name of the config file to send */
- {
- - int fd; /* PPD file */
- - int bytes; /* Number of bytes read */
- - char buffer[8192]; /* Buffer for file */
- - char resource[HTTP_MAX_URI]; /* Resource name */
- - const char *password; /* Password string */
- - char realm[HTTP_MAX_VALUE], /* realm="xyz" string */
- - nonce[HTTP_MAX_VALUE], /* nonce="xyz" string */
- - plain[255], /* Plaintext username:password */
- - encode[512]; /* Encoded username:password */
- - http_status_t status; /* HTTP status from server */
- - char prompt[1024]; /* Prompt string */
- - int digest_tries; /* Number of tries with Digest */
- -
- - if (name == NULL)
- - return 0;
- -
- - /*
- - * Connect to the correct server as needed...
- - */
- -
- - if ((cups_server = httpConnectEncrypt(cupsServer(), ippPort(),
- - cupsEncryption())) == NULL)
- - {
- - last_error = IPP_SERVICE_UNAVAILABLE;
- - return 0;
- - }
- + int fd; /* PPD file */
- + http_status_t status; /* HTTP status from server */
- + http_t *cups_server;
-
- - /*
- - * Open the local config file...
- - */
- -
- - if ((fd = open(name, O_RDONLY)) < 0)
- - {
- - /*
- - * Can't open file; close the server connection and return NULL...
- - */
- + if (name == NULL)
- + return 0;
-
- - httpFlush(cups_server);
- - httpClose(cups_server);
- - cups_server = NULL;
- - return 0;
- - }
- + /*
- + * Connect to the correct server as needed...
- + */
-
- - /*
- - * And send a request to the HTTP server...
- - */
- -
- - strncpy(resource, "/admin/conf/cupsd.conf", sizeof(resource));
- -
- - digest_tries = 0;
- -
- - do
- - {
- - httpClearFields(cups_server);
- - httpSetField(cups_server, HTTP_FIELD_HOST, cupsServer());
- - httpSetField(cups_server, HTTP_FIELD_AUTHORIZATION, authstring);
- - httpSetField(cups_server, HTTP_FIELD_TRANSFER_ENCODING, "chunked");
- -
- - if (httpPut(cups_server, resource))
- - {
- - if (httpReconnect(cups_server))
- - {
- - status = HTTP_ERROR;
- - break;
- - }
- - else
- - {
- - status = HTTP_UNAUTHORIZED;
- - continue;
- - }
- + cups_server = httpConnectEncrypt(cupsServer(), ippPort(), cupsEncryption());
- + if (cups_server == NULL) {
- + last_error = IPP_SERVICE_UNAVAILABLE;
- + return 0;
- }
-
- - /* send the file now */
- - lseek(fd, 0, SEEK_SET);
- - status = HTTP_CONTINUE;
- - while ((bytes = read(fd, buffer, sizeof(buffer))) > 0)
- - if (httpCheck(cups_server))
- - {
- - if ((status = httpUpdate(cups_server)) != HTTP_CONTINUE)
- - break;
- - }
- - else
- - httpWrite(cups_server, buffer, bytes);
- -
- - if (status == HTTP_CONTINUE)
- - {
- - httpWrite(cups_server, buffer, 0);
- - while ((status = httpUpdate(cups_server)) == HTTP_CONTINUE);
- - }
- + /*
- + * Open the local config file...
- + */
-
- - if (status == HTTP_UNAUTHORIZED)
- - {
- - fprintf(stderr,"cupsPutConf: unauthorized...");
- -
- - /*
- - * Flush any error message...
- - */
- -
- - httpFlush(cups_server);
- -
- - /*
- - * See if we can do local authentication...
- - */
- -
- - if (cups_local_auth(cups_server))
- - continue;
- -
- - /*
- - * See if we should retry the current digest password...
- - */
- -
- - if (strncmp(cups_server->fields[HTTP_FIELD_WWW_AUTHENTICATE], "Basic", 5) == 0 ||
- - digest_tries > 1 || !pwdstring[0])
- - {
- - /*
- - * Nope - get a password from the user...
- - */
- -
- - snprintf(prompt, sizeof(prompt), "Password for %s on %s? ", cupsUser(),
- - cups_server->hostname);
- -
- - if ((password = cupsGetPassword(prompt)) == NULL)
- - break;
- - if (!password[0])
- - break;
- -
- - strncpy(pwdstring, password, sizeof(pwdstring) - 1);
- - pwdstring[sizeof(pwdstring) - 1] = '\0';
- -
- - digest_tries = 0;
- - }
- - else
- - digest_tries ++;
- -
- - /*
- - * Got a password; encode it for the server...
- - */
- -
- - if (strncmp(cups_server->fields[HTTP_FIELD_WWW_AUTHENTICATE], "Basic", 5) == 0)
- - {
- - /*
- - * Basic authentication...
- - */
- -
- - snprintf(plain, sizeof(plain), "%s:%s", cupsUser(), pwdstring);
- -#if CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR >= 2
- - httpEncode64_2(encode, sizeof(encode), plain, sizeof(plain));
- -#else
- - httpEncode64(encode, plain);
- -#endif
- - snprintf(authstring, sizeof(authstring), "Basic %s", encode);
- - }
- - else
- - {
- - /*
- - * Digest authentication...
- - */
- -
- - httpGetSubField(cups_server, HTTP_FIELD_WWW_AUTHENTICATE, "realm", realm);
- - httpGetSubField(cups_server, HTTP_FIELD_WWW_AUTHENTICATE, "nonce", nonce);
- -
- - httpMD5(cupsUser(), realm, pwdstring, encode);
- - httpMD5Final(nonce, "GET", resource, encode);
- - snprintf(authstring, sizeof(authstring),
- - "Digest username=\"%s\", realm=\"%s\", nonce=\"%s\", "
- - "response=\"%s\"", cupsUser(), realm, nonce, encode);
- - }
- + fd = open(name, O_RDONLY);
- + if (fd < 0) {
- + /*
- + * Can't open file; close the server connection and return NULL...
- + */
-
- - continue;
- + httpFlush(cups_server);
- + httpClose(cups_server);
- + cups_server = NULL;
- + return 0;
- }
- -#ifdef HAVE_LIBSSL
- - else if (status == HTTP_UPGRADE_REQUIRED)
- - {
- - /*
- - * Flush any error message...
- - */
- -
- - httpFlush(cups_server);
- -
- - /*
- - * Upgrade with encryption...
- - */
- -
- - httpEncryption(cups_server, HTTP_ENCRYPT_REQUIRED);
- -
- - /*
- - * Try again, this time with encryption enabled...
- - */
-
- - continue;
- - }
- -#endif /* HAVE_LIBSSL */
- - }
- - while (status == HTTP_UNAUTHORIZED || status == HTTP_UPGRADE_REQUIRED);
- -
- - /*
- - * See if we actually got the file or an error...
- - */
- + /*
- + * And send a request to the HTTP server...
- + */
- +
- + status = cupsPutFd(cups_server, "/admin/conf/cupsd.conf", fd);
-
- - if (status != HTTP_CREATED)
- - {
- httpFlush(cups_server);
- httpClose(cups_server);
- cups_server = NULL;
- close(fd);
- - return 0;
- - }
- -
- - close(fd);
- -
- - return 1;
- -}
- -
- -static int /* O - 1 if available, 0 if not */
- -cups_local_auth(http_t *http) /* I - Connection */
- -{
- - int pid; /* Current process ID */
- - FILE *fp; /* Certificate file */
- - char filename[1024], /* Certificate filename */
- - certificate[33];/* Certificate string */
- - const char *root; /* Server root directory */
- -
- -
- - /*
- - * See if we are accessing localhost...
- - the struct has changed in newer versions - PiggZ (adam@piggz.co.uk)
- - */
- -#if CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR >= 2
- - if (!httpAddrLocalhost(http))
- -#else
- - if (ntohl(*(int*)&http->hostaddr.sin_addr) != 0x7f000001 &&
- - strcasecmp(http->hostname, "localhost") != 0)
- -#endif
- - return (0);
- -
- - /*
- - * Try opening a certificate file for this PID. If that fails,
- - * try the root certificate...
- - */
- -
- - if ((root = getenv("CUPS_SERVERROOT")) == NULL)
- - root = CUPS_SERVERROOT;
- -
- - pid = getpid();
- - snprintf(filename, sizeof(filename), "%s/certs/%d", root, pid);
- - if ((fp = fopen(filename, "r")) == NULL && pid > 0)
- - {
- - snprintf(filename, sizeof(filename), "%s/certs/0", root);
- - fp = fopen(filename, "r");
- - }
- -
- - if (fp == NULL)
- - return (0);
- -
- - /*
- - * Read the certificate from the file...
- - */
- -
- - fgets(certificate, sizeof(certificate), fp);
- - fclose(fp);
- -
- - /*
- - * Set the authorization string and return...
- - */
- -
- - snprintf(authstring, sizeof(authstring), "Local %s", certificate);
-
- - return (1);
- + /*
- + * See if we actually got the file or an error...
- + */
- +
- + if (status != HTTP_CREATED)
- + return 0;
- + else
- + return 1;
- }
-
- --Boundary-00=_tTyAHs9qWLGFusu
- Content-Type: text/x-c++src;
- charset="us-ascii";
- name="patch-kdeprint_cups_ipprequest.cpp"
- Content-Transfer-Encoding: 7bit
- Content-Disposition: attachment;
- filename="patch-kdeprint_cups_ipprequest.cpp"
-
- --- kdeprint/cups/ipprequest.cpp-orig 2007-01-15 05:34:19.000000000 -0600
- +++ kdeprint/cups/ipprequest.cpp 2007-10-02 22:21:52.359893129 -0500
- @@ -310,7 +310,7 @@
- }
-
- #ifdef HAVE_CUPS_NO_PWD_CACHE
- - strncpy( HTTP->authstring, cups_authstring.data(), HTTP_MAX_VALUE );
- + httpSetAuthString( HTTP, NULL, cups_authstring.data() );
- #endif
-
- if (dump_ > 0)
- @@ -320,7 +320,7 @@
-
- request_ = cupsDoFileRequest(HTTP, request_, (res.isEmpty() ? "/" : res.latin1()), (filename.isEmpty() ? NULL : filename.latin1()));
- #ifdef HAVE_CUPS_NO_PWD_CACHE
- - cups_authstring = HTTP->authstring;
- + cups_authstring = httpGetAuthString( HTTP );
- #endif
- httpClose(HTTP);
diff --git a/x11/kdelibs3/files/patch-kdeprint_management_smbview.cpp b/x11/kdelibs3/files/patch-kdeprint_management_smbview.cpp
deleted file mode 100644
index 21735baad2d7..000000000000
--- a/x11/kdelibs3/files/patch-kdeprint_management_smbview.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- kdeprint/management/smbview.cpp 2007-08-30 19:42:25.000000000 -0700
-+++ kdeprint/management/smbview.cpp.old 2007-08-30 19:43:50.000000000 -0700
-@@ -179,7 +179,7 @@
- m_current = item;
- *m_proc << "nmblookup"+m_wins_server+"-M ";
- *m_proc << KProcess::quote(item->text(0));
-- *m_proc << " -S | grep '<20>' | sed -e 's/^[[:space:]]*//' -e 's/[[:space:]]*<20>.*//' | xargs -iserv_name smbclient -N -L 'serv_name' -W ";
-+ *m_proc << " -S | grep '<20>' | sed -e 's/^[[:space:]]*//' -e 's/[[:space:]]*<20>.*//' | xargs -Iserv_name smbclient -N -L 'serv_name' -W ";
- *m_proc << KProcess::quote(item->text(0));
- *m_proc << " -A ";
- *m_proc << KProcess::quote(m_passwdFile->name());
diff --git a/x11/kdelibs3/files/patch-kdeui-kactionclasses.cpp b/x11/kdelibs3/files/patch-kdeui-kactionclasses.cpp
new file mode 100644
index 000000000000..caee9f862c62
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kdeui-kactionclasses.cpp
@@ -0,0 +1,13 @@
+--- kdeui/kactionclasses.cpp 2007/10/08 11:32:36 722993
++++ kdeui/kactionclasses.cpp 2007/10/20 20:49:01 727528
+@@ -667,8 +667,8 @@
+ KToolBar* bar = static_cast<KToolBar*>( widget );
+ int id_ = KAction::getToolButtonID();
+ bar->insertCombo( comboItems(), id_, isEditable(),
+- SIGNAL( activated( int ) ), this,
+- SLOT( slotActivated( int ) ), isEnabled(),
++ SIGNAL( activated( const QString & ) ), this,
++ SLOT( slotActivated( const QString & ) ), isEnabled(),
+ toolTip(), -1, index );
+
+ QComboBox *cb = bar->getCombo( id_ );
diff --git a/x11/kdelibs3/files/patch-kinit-start_kdeinit_wrapper.c b/x11/kdelibs3/files/patch-kinit-start_kdeinit_wrapper.c
new file mode 100644
index 000000000000..396ca8af4ff2
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kinit-start_kdeinit_wrapper.c
@@ -0,0 +1,11 @@
+--- kinit/start_kdeinit_wrapper.c.orig 2007-10-29 22:49:04.000000000 +0100
++++ kinit/start_kdeinit_wrapper.c 2007-10-29 22:49:21.000000000 +0100
+@@ -85,7 +85,7 @@
+ if(argc == 0)
+ return 1;
+ argv[0] = "start_kdeinit";
+- execv("start_kdeinit",argv);
++ execvp("start_kdeinit",argv);
+ perror("start_kdeinit");
+ return 1;
+ }
diff --git a/x11/kdelibs3/files/patch-kioslave_http-http.cc b/x11/kdelibs3/files/patch-kioslave_http-http.cc
new file mode 100644
index 000000000000..73929be6efcf
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kioslave_http-http.cc
@@ -0,0 +1,39 @@
+--- kioslave/http/http.cc 2007/09/26 17:08:43 717341
++++ kioslave/http/http.cc 2007/10/17 04:11:51 726097
+@@ -3409,10 +3409,6 @@
+
+ } while (!m_bEOF && (len || noHeader) && (headerSize < maxHeaderSize) && (gets(buffer, sizeof(buffer)-1)));
+
+- // Send the current response before processing starts or it
+- // might never get sent...
+- forwardHttpResponseHeader();
+-
+ // Now process the HTTP/1.1 upgrade
+ QStringList::Iterator opt = upgradeOffers.begin();
+ for( ; opt != upgradeOffers.end(); ++opt) {
+@@ -3818,6 +3814,10 @@
+ mimeType( m_strMimeType );
+ }
+
++ // Do not move send response header before any redirection as it seems
++ // to screw up some sites. See BR# 150904.
++ forwardHttpResponseHeader();
++
+ if (m_request.method == HTTP_HEAD)
+ return true;
+
+@@ -3830,10 +3830,10 @@
+ // Check...
+ createCacheEntry(m_strMimeType, expireDate); // Create a cache entry
+ if (!m_request.fcache)
+- {
+- m_request.bCachedWrite = false; // Error creating cache entry.
+- kdDebug(7113) << "(" << m_pid << ") Error creating cache entry for " << m_request.url.url()<<"!\n";
+- }
++ {
++ m_request.bCachedWrite = false; // Error creating cache entry.
++ kdDebug(7113) << "(" << m_pid << ") Error creating cache entry for " << m_request.url.url()<<"!\n";
++ }
+ m_request.expireDate = expireDate;
+ m_maxCacheSize = config()->readNumEntry("MaxCacheSize", DEFAULT_MAX_CACHE_SIZE) / 2;
+ }
diff --git a/x11/kdelibs3/files/patch-post-3.5.7-kdelibs-kdecore-2.diff b/x11/kdelibs3/files/patch-post-3.5.7-kdelibs-kdecore-2.diff
deleted file mode 100644
index 50a9ed17e1dc..000000000000
--- a/x11/kdelibs3/files/patch-post-3.5.7-kdelibs-kdecore-2.diff
+++ /dev/null
@@ -1,34 +0,0 @@
---- kdecore/kurl.cpp
-+++ kdecore/kurl.cpp
-@@ -30,6 +30,7 @@
- #include <kglobal.h>
- #include <kidna.h>
- #include <kprotocolinfo.h>
-+#include <kstringhandler.h>
- #endif
-
- #include <stdio.h>
-@@ -183,7 +184,7 @@ static QString lazy_encode( const QStrin
- (character == '?') || // Start of query delimiter
- ((character == '@') && encodeAt) || // Username delimiter
- (character == '#') || // Start of reference delimiter
-- ((character == 32) && (i+1 == old_length))) // A trailing space
-+ ((character == 32) && (i+1 == old_length || segment[i+1] == ' '))) // A trailing space
- {
- new_segment[ new_length++ ] = '%';
-
-@@ -1540,7 +1541,13 @@ QString KURL::prettyURL( int _trailing )
- u += "//";
- if ( hasUser() )
- {
-- u += lazy_encode(m_strUser);
-+ QString s = m_strUser;
-+#ifndef KDE_QT_ONLY
-+ // shorten the username, its unlikely to be valid without password anyway
-+ if (!hasPass())
-+ s = KStringHandler::csqueeze(s, 16);
-+#endif
-+ u += encode(s, 0, 0);
- // Don't show password!
- u += "@";
- }
diff --git a/x11/kdelibs3/pkg-plist b/x11/kdelibs3/pkg-plist
index 2f6befae1caa..9dd8bed5489d 100644
--- a/x11/kdelibs3/pkg-plist
+++ b/x11/kdelibs3/pkg-plist
@@ -60,6 +60,7 @@ bin/makekdewidgets
bin/meinproc
bin/preparetips
bin/start_kdeinit
+bin/start_kdeinit_wrapper
etc/xdg/menus/kde-applications.menu
include/arts/artskde.h
include/arts/kartsdispatcher.h
@@ -641,6 +642,7 @@ include/kstringhandler.h
include/kstringvalidator.h
include/kstyle.h
include/ksvgiconengine.h
+include/kswitchlanguagedialog.h
include/ksycoca.h
include/ksycocaentry.h
include/ksycocatype.h
@@ -1340,6 +1342,8 @@ share/apps/kdeprint/filters/enscript.desktop
share/apps/kdeprint/filters/enscript.xml
share/apps/kdeprint/filters/imagetops.desktop
share/apps/kdeprint/filters/imagetops.xml
+share/apps/kdeprint/filters/pdf2ps.desktop
+share/apps/kdeprint/filters/pdf2ps.xml
share/apps/kdeprint/filters/pdfwrite.desktop
share/apps/kdeprint/filters/pdfwrite.xml
share/apps/kdeprint/filters/poster.desktop
@@ -5249,6 +5253,7 @@ share/mimelnk/application/x-webarchive.desktop
share/mimelnk/application/x-x509-ca-cert.desktop
share/mimelnk/application/x-xliff.desktop
share/mimelnk/application/x-zerosize.desktop
+share/mimelnk/application/x-zip-compressed.desktop
share/mimelnk/application/x-zip.desktop
share/mimelnk/application/x-zoo.desktop
share/mimelnk/application/xhtml+xml.desktop