aboutsummaryrefslogtreecommitdiff
path: root/x11/keybinder
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-01-22 10:05:58 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-01-22 10:05:58 +0000
commit2ff986069dbc3eb2ce70e409dfc75e59868fe383 (patch)
treebcd8fad9410b2f7b376cd9042db3d412bd81f75a /x11/keybinder
parent7ea94782d6671a243d0962479eb7eae586045e45 (diff)
downloadports-2ff986069dbc3eb2ce70e409dfc75e59868fe383.tar.gz
ports-2ff986069dbc3eb2ce70e409dfc75e59868fe383.zip
Notes
Diffstat (limited to 'x11/keybinder')
-rw-r--r--x11/keybinder/Makefile64
-rw-r--r--x11/keybinder/distinfo4
-rw-r--r--x11/keybinder/pkg-descr6
-rw-r--r--x11/keybinder/pkg-plist16
4 files changed, 38 insertions, 52 deletions
diff --git a/x11/keybinder/Makefile b/x11/keybinder/Makefile
index 5a62f476b267..4f62540a9ff2 100644
--- a/x11/keybinder/Makefile
+++ b/x11/keybinder/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= keybinder
-PORTVERSION= 0.3.0
-PORTREVISION= 5
+PORTVERSION= 0.3.1
+DISTVERSIONPREFIX= v
CATEGORIES= x11
-MASTER_SITES= GENTOO
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for registering keyboard shortcuts
@@ -12,42 +11,43 @@ COMMENT= Library for registering keyboard shortcuts
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
-USES= gmake libtool pathfix pkgconfig
+BUILD_DEPENDS= gtkdocize:${PORTSDIR}/textproc/gtk-doc
+
+USE_GITHUB= yes
+GH_ACCOUNT= engla
+
+USES= autoreconf gmake libtool pathfix pkgconfig
+PATHFIX_MAKEFILEIN= Makefile.am
USE_GNOME= gtk20 introspection:build
USE_XORG= x11 xext xrender
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-silent-rules --disable-gtk-doc
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOCS EXAMPLES PYTHON LUA
-OPTIONS_DEFAULT=PYTHON
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= EXAMPLES LUA PYTHON
+OPTIONS_DEFAULT= PYTHON
+OPTIONS_SUB= yes
# Override LUA description
-LUA_DESC= Lua bindings
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPYTHON}
-USES+= python:2
-USE_GNOME+= pygtk2
-.else
-CONFIGURE_ARGS+= --disable-python
-.endif
-
-.if ${PORT_OPTIONS:MLUA}
-USES+= lua:51
-CONFIGURE_ARGS+= --with-lua-includes=${LUA_INCDIR}
-.else
-CONFIGURE_ARGS+= --disable-lua
-.endif
-
-post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${REINPLACE_CMD} -i '' -e 's|lua5.1|lua-${LUA_VER}|g' ${WRKSRC}/examples/Makefile
+LUA_DESC= Lua bindings
+LUA_USES= lua:51
+LUA_CONFIGURE_ON= --with-lua-includes=${LUA_INCDIR}
+LUA_CONFIGURE_OFF= --disable-lua
+PYTHON_USES= python:2
+PYTHON_USE= gnome=pygtk2
+PYTHON_CONFIGURE_OFF= --disable-python
+
+pre-configure:
+ @(cd ${CONFIGURE_WRKSRC} && ${LOCALBASE}/bin/gtkdocize)
+
+post-build-EXAMPLES-on:
+ @${REINPLACE_CMD} -i '' -e \
+ 's|lua5.1|lua-${LUA_VER}|g' ${WRKSRC}/examples/Makefile
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
-.endif
+ (cd ${WRKSRC}/examples && ${INSTALL_DATA} * \
+ ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/x11/keybinder/distinfo b/x11/keybinder/distinfo
index 51509718e127..543583e3cdf9 100644
--- a/x11/keybinder/distinfo
+++ b/x11/keybinder/distinfo
@@ -1,2 +1,2 @@
-SHA256 (keybinder-0.3.0.tar.gz) = 42863ca0174d568a8c02c6fb243fee1681823825e8bcb1718c51611d8e9793bb
-SIZE (keybinder-0.3.0.tar.gz) = 377765
+SHA256 (engla-keybinder-v0.3.1_GH0.tar.gz) = 6073bb5f626f75c4a6f25291b32673af02d47e735b56f9d471150d678ac0b5fa
+SIZE (engla-keybinder-v0.3.1_GH0.tar.gz) = 31727
diff --git a/x11/keybinder/pkg-descr b/x11/keybinder/pkg-descr
index 232152650b9f..bdc3a9d3daa0 100644
--- a/x11/keybinder/pkg-descr
+++ b/x11/keybinder/pkg-descr
@@ -1,5 +1,5 @@
-Keybinder is a library for registering global keyboard shortcuts. Keybinder
-works with GTK-based applications using the X Window System.
+Keybinder is a library for registering global keyboard shortcuts.
+Keybinder works with GTK-based applications using the X Window System.
The port provides the following:
@@ -8,4 +8,4 @@ The port provides the following:
- Python bindings, python-keybinder
- An examples directory with programs in C, Lua, Python, and Vala
-WWW: http://kaizer.se/wiki/keybinder/
+WWW: https://github.com/engla/keybinder
diff --git a/x11/keybinder/pkg-plist b/x11/keybinder/pkg-plist
index 15f1a9727a48..ceb7bd7757d7 100644
--- a/x11/keybinder/pkg-plist
+++ b/x11/keybinder/pkg-plist
@@ -4,25 +4,11 @@ lib/libkeybinder.so
lib/libkeybinder.so.0
lib/libkeybinder.so.0.1.0
%%LUA%%%%LUA_MODLIBDIR%%/keybinder.so
+libdata/pkgconfig/keybinder.pc
%%PYTHON%%%%PYTHON_SITELIBDIR%%/keybinder/__init__.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/keybinder/__init__.pyc
%%PYTHON%%%%PYTHON_SITELIBDIR%%/keybinder/__init__.pyo
%%PYTHON%%%%PYTHON_SITELIBDIR%%/keybinder/_keybinder.so
-libdata/pkgconfig/keybinder.pc
-%%PORTDOCS%%%%DOCSDIR%%/annotation-glossary.html
-%%PORTDOCS%%%%DOCSDIR%%/api-index-full.html
-%%PORTDOCS%%%%DOCSDIR%%/ch01.html
-%%PORTDOCS%%%%DOCSDIR%%/deprecated-api-index.html
-%%PORTDOCS%%%%DOCSDIR%%/home.png
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/index.sgml
-%%PORTDOCS%%%%DOCSDIR%%/keybinder-keybinder.html
-%%PORTDOCS%%%%DOCSDIR%%/keybinder.devhelp2
-%%PORTDOCS%%%%DOCSDIR%%/left.png
-%%PORTDOCS%%%%DOCSDIR%%/object-tree.html
-%%PORTDOCS%%%%DOCSDIR%%/right.png
-%%PORTDOCS%%%%DOCSDIR%%/style.css
-%%PORTDOCS%%%%DOCSDIR%%/up.png
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.lua