aboutsummaryrefslogtreecommitdiff
path: root/x11/keynav
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-07-10 15:34:47 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-07-10 15:34:47 +0000
commit692e9aad2e09cb81c2f5936e31cad9e7d6f9f641 (patch)
treeab74078b7cf9c94b5c00f75031a19499360c9974 /x11/keynav
parent348c483d411cd6b7237361ce4e6c3dbc837928ae (diff)
downloadports-692e9aad2e09cb81c2f5936e31cad9e7d6f9f641.tar.gz
ports-692e9aad2e09cb81c2f5936e31cad9e7d6f9f641.zip
- Update to 0.20110708.0, which now builds under clang.
Notes
Notes: svn path=/head/; revision=277455
Diffstat (limited to 'x11/keynav')
-rw-r--r--x11/keynav/Makefile6
-rw-r--r--x11/keynav/distinfo4
-rw-r--r--x11/keynav/files/patch-keynav.c38
3 files changed, 3 insertions, 45 deletions
diff --git a/x11/keynav/Makefile b/x11/keynav/Makefile
index b7cf5da54dbd..5ff5349f757c 100644
--- a/x11/keynav/Makefile
+++ b/x11/keynav/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= keynav
-DISTVERSION= 0.20101224.3183
+DISTVERSION= 0.20110708.0
PORTEPOCH= 1
CATEGORIES= x11
MASTER_SITES= http://semicomplete.googlecode.com/files/
@@ -27,10 +27,6 @@ MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
-.if (${OSVERSION} <= 700000)
-IGNORE= does not build on 6.x
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/keynav ${PREFIX}/bin
.if !defined(NOPORTEXAMPLES)
diff --git a/x11/keynav/distinfo b/x11/keynav/distinfo
index f4474afe9dfd..b79df0712ace 100644
--- a/x11/keynav/distinfo
+++ b/x11/keynav/distinfo
@@ -1,2 +1,2 @@
-SHA256 (keynav-0.20101224.3183.tar.gz) = 76707752702023a0930807c0dcd52f2e79fd8bf0a1b78c5baee02bfb3761b56d
-SIZE (keynav-0.20101224.3183.tar.gz) = 21095
+SHA256 (keynav-0.20110708.0.tar.gz) = 1f39c7181bf2f6185946afc35bdcca28ec15fed012a4b57bef57fb1125943fbe
+SIZE (keynav-0.20110708.0.tar.gz) = 21124
diff --git a/x11/keynav/files/patch-keynav.c b/x11/keynav/files/patch-keynav.c
deleted file mode 100644
index 0e327e721287..000000000000
--- a/x11/keynav/files/patch-keynav.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- ./keynav.c.orig 2011-06-29 20:24:04.335382341 -0400
-+++ ./keynav.c 2011-06-29 21:21:31.846377864 -0400
-@@ -10,6 +10,7 @@
- #include <unistd.h>
- #include <string.h>
- #include <errno.h>
-+#include <ctype.h>
- #include <sys/types.h>
- #include <sys/wait.h>
- #include <signal.h>
-@@ -174,6 +175,8 @@
- void query_screen_normal();
- int viewport_sort(const void *a, const void *b);
- int query_current_screen();
-+int query_current_screen_xinerama();
-+int query_current_screen_normal();
- void viewport_left();
- void viewport_right();
- int pointinrect(int px, int py, int rx, int ry, int rw, int rh);
-@@ -1029,7 +1032,8 @@
- Window curwin;
- Window rootwin;
- Window dummy_win;
-- int x, y, width, height, border_width, depth;
-+ int x, y;
-+ unsigned int width, height, border_width, depth;
-
- xdo_window_get_active(xdo, &curwin);
- XGetGeometry(xdo->xdpy, curwin, &rootwin, &x, &y, &width, &height,
-@@ -1469,7 +1473,7 @@
-
- //printf("Recording as keycode:%d\n", e->keycode);
- active_recording->keycode = e->keycode;
-- return;
-+ return HANDLE_CONTINUE;
- }
-
- handler_info_t handle_gridnav(XKeyEvent *e) {