aboutsummaryrefslogtreecommitdiff
path: root/x11/kickoff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-08-03 00:39:51 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-09-20 14:35:01 +0000
commit18741dd85a2e8e88c89e2fcbaa7c71d48f4d3740 (patch)
tree571fba9e464020ea103c302987377776582b8db8 /x11/kickoff
parent14af59f1879184d0c954536321ef797e743a4229 (diff)
downloadports-18741dd85a2e8e88c89e2fcbaa7c71d48f4d3740.tar.gz
ports-18741dd85a2e8e88c89e2fcbaa7c71d48f4d3740.zip
x11-wm/sway-devel: unbreak Rust-based clients after edd477c5e7a4
interface 'wl_surface' has no event 2 PR: 268810
Diffstat (limited to 'x11/kickoff')
-rw-r--r--x11/kickoff/Makefile2
-rw-r--r--x11/kickoff/files/patch-sctk25
2 files changed, 26 insertions, 1 deletions
diff --git a/x11/kickoff/Makefile b/x11/kickoff/Makefile
index 950059c67d02..28417b2ae274 100644
--- a/x11/kickoff/Makefile
+++ b/x11/kickoff/Makefile
@@ -1,7 +1,7 @@
PORTNAME= kickoff
DISTVERSIONPREFIX= v
DISTVERSION= 0.7.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11 wayland
MAINTAINER= ports@FreeBSD.org
diff --git a/x11/kickoff/files/patch-sctk b/x11/kickoff/files/patch-sctk
new file mode 100644
index 000000000000..ed5aa00e138b
--- /dev/null
+++ b/x11/kickoff/files/patch-sctk
@@ -0,0 +1,25 @@
+Backport https://github.com/Smithay/client-toolkit/commit/5cfd95021c05
+to ignore wl_surface::Event::preferred_buffer_scale after
+https://invent.kde.org/plasma/kwin/-/commit/d2b0ed0c5a1e
+https://github.com/swaywm/sway/commit/fc16fb65491b
+
+--- cargo-crates/smithay-client-toolkit-0.15.4/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.15.4/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {
+--- cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {