aboutsummaryrefslogtreecommitdiff
path: root/x11/lemonbar
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-12-21 16:33:30 +0000
committerJohn Marino <marino@FreeBSD.org>2015-12-21 16:33:30 +0000
commit351981c0d59d7e509cf833ec4e682a4caa8ecf1a (patch)
tree164296f7e434d99b5c5236fda4bb2492780c4af2 /x11/lemonbar
parent153c70b177d497172ceda1be7a15de13f38e0bba (diff)
downloadports-351981c0d59d7e509cf833ec4e682a4caa8ecf1a.tar.gz
ports-351981c0d59d7e509cf833ec4e682a4caa8ecf1a.zip
Add new port x11/lemonbar v1.1
The PR was for bar-aint-recursive v1.0, but the project was renamed and got a new release since the PR was submitted nearly a year ago. PR: 196682 Submitted by: evgeni.dimitrov (gmail) bar is a lightweight bar entirely based on XCB. Provides full UTF-8 support, basic formatting, RandR and Xinerama support and EWMH compliance without wasting your precious memory.
Notes
Notes: svn path=/head/; revision=404133
Diffstat (limited to 'x11/lemonbar')
-rw-r--r--x11/lemonbar/Makefile44
-rw-r--r--x11/lemonbar/distinfo2
-rw-r--r--x11/lemonbar/pkg-descr5
3 files changed, 51 insertions, 0 deletions
diff --git a/x11/lemonbar/Makefile b/x11/lemonbar/Makefile
new file mode 100644
index 000000000000..2df709fcde6b
--- /dev/null
+++ b/x11/lemonbar/Makefile
@@ -0,0 +1,44 @@
+# Created by: Evgeni Dimitrov <evgeni.dimitrov@gmail.com>
+# $FreeBSD$
+
+PORTNAME= lemonbar
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1
+CATEGORIES= x11
+
+MAINTAINER= evgeni.dimitrov@gmail.com
+COMMENT= Lightweight xcb based bar
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake perl5
+USE_PERL5= build
+USE_XORG= xcb
+
+USE_GITHUB= yes
+GH_ACCOUNT= LemonBoy
+GH_PROJECT= bar
+
+CFLAGS+= -I${LOCALBASE}/include -DVERSION=${DISTVERSION}
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/lemonbar \
+ man/man1/lemonbar.1.gz
+
+post-patch:
+ ${REINPLACE_CMD} -e '/STRIP/d' -e '/^CC.*=/d' -e '/^CFLAGS.*=/d' \
+ -e 's/^LDFLAGS.*=\(.*\)/LDFLAGS+=\1/' ${WRKSRC}/Makefile
+
+post-build:
+ ${LOCALBASE}/bin/pod2man --section=1 --name=bar-aint-recursive \
+ --center="bar-aint-recursive manual" \
+ --release="bar-aint-recursive ${PORTVERSION}" \
+ ${WRKSRC}/README.pod > ${WRKSRC}/bar.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lemonbar ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/bar.1 \
+ ${STAGEDIR}${PREFIX}/man/man1/lemonbar.1
+
+.include <bsd.port.mk>
diff --git a/x11/lemonbar/distinfo b/x11/lemonbar/distinfo
new file mode 100644
index 000000000000..86339077d729
--- /dev/null
+++ b/x11/lemonbar/distinfo
@@ -0,0 +1,2 @@
+SHA256 (LemonBoy-bar-v1.1_GH0.tar.gz) = 567955575a09a7231cae7f2003e0fd66f4c86d7acbe1f53f407233730c8f2c9c
+SIZE (LemonBoy-bar-v1.1_GH0.tar.gz) = 14486
diff --git a/x11/lemonbar/pkg-descr b/x11/lemonbar/pkg-descr
new file mode 100644
index 000000000000..d498e08e353c
--- /dev/null
+++ b/x11/lemonbar/pkg-descr
@@ -0,0 +1,5 @@
+bar is a lightweight bar entirely based on XCB. Provides full UTF-8 support,
+basic formatting, RandR and Xinerama support and EWMH compliance without
+wasting your precious memory.
+
+WWW: https://github.com/LemonBoy/bar