aboutsummaryrefslogtreecommitdiff
path: root/x11/libICE
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2004-05-07 20:53:19 +0000
committerEric Anholt <anholt@FreeBSD.org>2004-05-07 20:53:19 +0000
commit91cba327f1ecdfe9680ac6303804897e01037c6b (patch)
tree919fea9b3cdc331ad36b13a3635fa9943979ca36 /x11/libICE
parent21fea37d047cca6d8eeb0eb04027dd53f2f7f53d (diff)
downloadports-91cba327f1ecdfe9680ac6303804897e01037c6b.tar.gz
ports-91cba327f1ecdfe9680ac6303804897e01037c6b.zip
Use gnomehack to replace patch, and register xtrans as a RUN_DEPENDS as well.
Remove dependency on libX11, which appears spurious.
Notes
Notes: svn path=/head/; revision=108642
Diffstat (limited to 'x11/libICE')
-rw-r--r--x11/libICE/Makefile13
-rw-r--r--x11/libICE/files/patch-Makefile.in11
2 files changed, 8 insertions, 16 deletions
diff --git a/x11/libICE/Makefile b/x11/libICE/Makefile
index ca4fed0e3102..9da917648438 100644
--- a/x11/libICE/Makefile
+++ b/x11/libICE/Makefile
@@ -7,16 +7,15 @@
PORTNAME= libICE
PORTVERSION= 6.3.2
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://pdx.freedesktop.org/~xlibs/release/
MAINTAINER= x11@FreeBSD.org
COMMENT= Inter Client Exchange library for X11
-LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
- ${X11BASE}/libdata/pkgconfig/xtrans.pc:${PORTSDIR}/x11/libXtrans \
- ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/xtrans.pc:${PORTSDIR}/x11/libXtrans
+BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
${LIB_PC_DEPENDS}
RUN_DEPENDS= ${LIB_PC_DEPENDS}
@@ -28,7 +27,11 @@ MTREE_FILE= /etc/mtree/BSD.x11-4.dist
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=13
-
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
+USE_GNOME= gnomehack pkgconfig
+
+post-patch:
+ ${REINPLACE_CMD} 's|xproto x11|xproto|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/x11/libICE/files/patch-Makefile.in b/x11/libICE/files/patch-Makefile.in
deleted file mode 100644
index 6c9439f8a395..000000000000
--- a/x11/libICE/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Sun Nov 9 21:20:38 2003
-+++ Makefile.in Sun Nov 9 22:54:17 2003
-@@ -180,7 +180,7 @@
- include/X11/ICE/ICEutil.h
-
-
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = ice.pc
-
- EXTRA_DIST = ice.pc.in