aboutsummaryrefslogtreecommitdiff
path: root/x11/libfm
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-06 10:37:55 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-06 10:37:55 +0000
commit84af81781854b1d1a1256574613249392ca8ee5f (patch)
tree89836740d8275aed312d20f34abde8df1d4a7aff /x11/libfm
parent5284a5b97e75c08f7e8760c6c0627445d2a212b1 (diff)
downloadports-84af81781854b1d1a1256574613249392ca8ee5f.tar.gz
ports-84af81781854b1d1a1256574613249392ca8ee5f.zip
- USE_AUTOTOOLS contains aclocal but not autoconf which leaves configure
out of date and causes make (build phase) to run autoconf, erasing any configure patches. Then make reruns configure. Instead of adding autoconf to USE_AUTOTOOLS avoid USE_AUTOTOOLS altogether by patching Makefile.in instead of Makefile.am. - Use INSTALL_TARGET=install-strip and USES=pathfix Reported by: antoine
Notes
Notes: svn path=/head/; revision=367411
Diffstat (limited to 'x11/libfm')
-rw-r--r--x11/libfm/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/x11/libfm/Makefile b/x11/libfm/Makefile
index 8b1642497ca9..2581546a0a66 100644
--- a/x11/libfm/Makefile
+++ b/x11/libfm/Makefile
@@ -16,15 +16,15 @@ BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
LIB_DEPENDS= libmenu-cache.so:${PORTSDIR}/x11/menu-cache \
libexif.so:${PORTSDIR}/graphics/libexif
-USES= desktop-file-utils fam gmake pkgconfig shared-mime-info tar:xz libtool
+USES= desktop-file-utils fam gmake libtool pathfix pkgconfig \
+ shared-mime-info tar:xz
USE_GNOME= gtk20
-USE_AUTOTOOLS= aclocal automake libtoolize:env
-CONFIGURE_ARGS+=--sysconfdir=${LOCALBASE}/etc
-MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
USE_LDCONFIG= yes
-
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
PORTDOCS= AUTHORS NEWS README
@@ -41,14 +41,9 @@ PLIST_SUB+= VER=4
post-patch:
@${REINPLACE_CMD} -e 's|-DG_DISABLE_DEPRECATED||' \
${WRKSRC}/src/Makefile.in
- @${REINPLACE_CMD} -e '/^pkgconfigdir/s|$$(libdir)|$$(prefix)/libdata|; \
- s|libfm-gtk3.pc||' \
- ${WRKSRC}/Makefile.am
- @${REINPLACE_CMD} -e '/libfm.conf/ d' ${WRKSRC}/data/Makefile.am
post-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/etc/xdg/libfm
- ${INSTALL_DATA} ${WRKSRC}/data/libfm.conf \
+ ${MV} ${STAGEDIR}${PREFIX}/etc/xdg/libfm/libfm.conf \
${STAGEDIR}${PREFIX}/etc/xdg/libfm/libfm.conf.sample
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}