aboutsummaryrefslogtreecommitdiff
path: root/x11/libfm
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-06-22 11:57:08 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-06-22 11:57:08 +0000
commitbadabd2b97af9afbda58b8e49e3c7c242fa6efc2 (patch)
tree4e20b203103ffb63878f50951ec1c19776051dbd /x11/libfm
parent357743a2335c7745e5dcd7c1ca775ce8c1908378 (diff)
downloadports-badabd2b97af9afbda58b8e49e3c7c242fa6efc2.tar.gz
ports-badabd2b97af9afbda58b8e49e3c7c242fa6efc2.zip
x11/libfm: minor fixes
- Fix NLS option [1] - Preserve .conf files [1] - Pass maintainership to submitter [1] - Fix pkg-plist and install of .conf PR: ports/179703 [1] Submitted by: nemysis <nemysis@gmx.ch>
Notes
Notes: svn path=/head/; revision=321568
Diffstat (limited to 'x11/libfm')
-rw-r--r--x11/libfm/Makefile39
-rw-r--r--x11/libfm/files/patch-configure11
-rw-r--r--x11/libfm/pkg-plist30
3 files changed, 44 insertions, 36 deletions
diff --git a/x11/libfm/Makefile b/x11/libfm/Makefile
index 4ae7805bb860..e5d5a77180b3 100644
--- a/x11/libfm/Makefile
+++ b/x11/libfm/Makefile
@@ -7,7 +7,7 @@ PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= SF/pcmanfm/PCManFM%20%2B%20Libfm%20%28tarball%20release%29/libfm%20%28required%20by%20PCManFM%29/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= The libFM backend library to PCManFM
LICENSE= GPLv2
@@ -15,38 +15,53 @@ LICENSE= GPLv2
LIB_DEPENDS= startup-notification-1:${PORTSDIR}/x11/startup-notification \
menu-cache:${PORTSDIR}/x11/menu-cache
+USES= pkgconfig
USE_GNOME= gnomehack gtk20
USE_AUTOTOOLS= libtool
+CONFIGURE_ARGS+=--sysconfdir=${LOCALBASE}/etc
USE_GMAKE= yes
USE_FAM= yes
USE_LDCONFIG= yes
-USES= pkgconfig
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+=--sysconfdir=${LOCALBASE}/etc
MAN1= libfm-pref-apps.1
OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+NLS_USES= gettext
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+.include <bsd.port.options.mk>
post-patch:
+ @${REINPLACE_CMD} -e 's|^VALAC.*|VALAC=""|' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-DG_DISABLE_DEPRECATED||g' \
${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e \
's|-Wno-unused-but-set-variable||' \
${WRKSRC}/src/actions/Makefile.am ${WRKSRC}/src/actions/Makefile.in
+ @${REINPLACE_CMD} -e '/libfm.conf/,/pref-apps.conf/ d' ${WRKSRC}/data/Makefile.in
+
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e 's|src po|src|' \
+ ${WRKSRC}/Makefile.in
+.endif
pre-install:
- cd ${WRKDIR}/libfm-${PORTVERSION} && ${CHMOD} 755 install-sh
+ @(cd ${WRKDIR}/libfm-${PORTVERSION} && ${CHMOD} 755 install-sh)
+
+post-install:
+ ${MKDIR} ${PREFIX}/etc/xdg/libfm
+ ${INSTALL_DATA} ${WRKSRC}/data/libfm.conf ${PREFIX}/etc/xdg/libfm/libfm.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/data/pref-apps.conf ${PREFIX}/etc/xdg/libfm/pref-apps.conf.sample
+.if ! exists(${PREFIX}/etc/xdg/libfm/libfm.conf)
+ ${INSTALL_DATA} ${WRKSRC}/data/libfm.conf ${PREFIX}/etc/xdg/libfm/libfm.conf
+.endif
+.if ! exists(${PREFIX}/etc/xdg/libfm/pref-apps.conf)
+ ${INSTALL_DATA} ${WRKSRC}/data/pref-apps.conf ${PREFIX}/etc/xdg/libfm/pref-apps.conf
+.endif
.include <bsd.port.mk>
diff --git a/x11/libfm/files/patch-configure b/x11/libfm/files/patch-configure
deleted file mode 100644
index cadaf1d6f2b6..000000000000
--- a/x11/libfm/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2012-09-06 10:00:49.687508071 -0400
-+++ configure 2012-09-06 10:01:00.168508809 -0400
-@@ -12491,7 +12491,7 @@
- ;;
- esac
- fi
--VALAC=$ac_cv_path_VALAC
-+VALAC=""
- if test -n "$VALAC"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $VALAC" >&5
- $as_echo "$VALAC" >&6; }
diff --git a/x11/libfm/pkg-plist b/x11/libfm/pkg-plist
index 4db1b37c9ba0..2e486947b13a 100644
--- a/x11/libfm/pkg-plist
+++ b/x11/libfm/pkg-plist
@@ -1,7 +1,11 @@
bin/libfm-pref-apps
-etc/xdg/libfm/libfm.conf
-etc/xdg/libfm/pref-apps.conf
include/libfm
+@unexec if cmp -s %D/etc/xdg/libfm/libfm.conf %D/etc/xdg/libfm/libfm.conf.sample; then rm -f %D/etc/xdg/libfm/libfm.conf; fi
+etc/xdg/libfm/libfm.conf.sample
+@exec if [ ! -f %D/etc/xdg/libfm/libfm.conf ] ; then cp -p %D/%F %B/libfm.conf; fi
+@unexec if cmp -s %D/etc/xdg/libfm/pref-apps.conf %D/etc/xdg/libfm/pref-apps.conf.sample; then rm -f %D/etc/xdg/libfm/pref-apps.conf; fi
+etc/xdg/libfm/pref-apps.conf.sample
+@exec if [ ! -f %D/etc/xdg/libfm/pref-apps.conf ] ; then cp -p %D/%F %B/pref-apps.conf; fi
include/libfm-1.0/fm-actions.h
include/libfm-1.0/fm-app-chooser-combo-box.h
include/libfm-1.0/fm-app-chooser-dlg.h
@@ -140,19 +144,19 @@ share/applications/libfm-pref-apps.desktop
%%NLS%%share/locale/zh_CN/LC_MESSAGES/libfm.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/libfm.mo
share/mime/packages/libfm.xml
-@dirrm etc/xdg/libfm
-@dirrm etc/xdg
-@dirrmtry share/locale/es_VE/LC_MESSAGES
-@dirrmtry share/locale/es_VE
-@dirrmtry share/locale/lg/LC_MESSAGES
-@dirrmtry share/locale/lg
-@dirrmtry share/locale/tt_RU/LC_MESSAGES
-@dirrmtry share/locale/tt_RU
-@dirrmtry share/locale/ur_PK/LC_MESSAGES
-@dirrmtry share/locale/ur_PK
-@dirrmtry share/applications
+@dirrmtry etc/xdg/libfm
+@dirrmtry etc/xdg
@dirrmtry share/mime/packages
@dirrmtry share/mime
+%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur_PK
+%%NLS%%@dirrmtry share/locale/tt_RU/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/tt_RU
+%%NLS%%@dirrmtry share/locale/lg/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/lg
+%%NLS%%@dirrmtry share/locale/es_VE/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/es_VE
@dirrm %%DATADIR%%/ui
@dirrm %%DATADIR%%
+@dirrmtry share/applications
@dirrm include/libfm-1.0