aboutsummaryrefslogtreecommitdiff
path: root/x11/libxfce4menu
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-30 16:49:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-30 16:49:12 +0000
commit4b68fc723bc6478544954fa1a7554ca5c269f611 (patch)
tree752bd2703b89f85a96b337b223e14ab4bb621705 /x11/libxfce4menu
parent66521294b08078847ba4c56a6423c20cf34d68f8 (diff)
downloadports-4b68fc723bc6478544954fa1a7554ca5c269f611.tar.gz
ports-4b68fc723bc6478544954fa1a7554ca5c269f611.zip
- Convert complete XFCE to new options framework
While here some extra work: - Remove 6.X gruft - Correct NOPORTDOCS - Pet portlint - Whitespaces fixes Reviewed by: beat, bapt (thx!)
Notes
Notes: svn path=/head/; revision=297800
Diffstat (limited to 'x11/libxfce4menu')
-rw-r--r--x11/libxfce4menu/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/x11/libxfce4menu/Makefile b/x11/libxfce4menu/Makefile
index a76740b8c1e6..59938edff7ef 100644
--- a/x11/libxfce4menu/Makefile
+++ b/x11/libxfce4menu/Makefile
@@ -25,24 +25,22 @@ USE_XFCE= configenv libutil xfconf
INSTALLS_ICONS= yes
CONFIGURE_ARGS= --disable-gtk-doc-html \
- --with-vendor-info=FreeBSD
+ --with-vendor-info=FreeBSD
-OPTIONS= APIDOCS "Install api documentation" off \
- NLS "Enable Native Language Support" on \
- STARTUP "Enable startup notification" on \
- GLADEUI "Enable Glade interface designer support" off
+OPTIONS_DEFINE= DOCS NLS NOTIFY GLADE
+OPTIONS_DEFAULT= NOTIFY
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_APIDOCS)
-CONFIGURE_ARGS+=--without-html-dir
-PLIST_SUB+= APIDOCS="@comment "
-.else
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+=--with-html-dir=${PREFIX}/share/gtk-doc/html
PLIST_SUB+= APIDOCS=""
+.else
+CONFIGURE_ARGS+=--without-html-dir
+PLIST_SUB+= APIDOCS="@comment "
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
@@ -51,18 +49,18 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if !defined(WITHOUT_STARTUP)
+.if ${PORT_OPTIONS:MNOTIFY}
LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
CONFIGURE_ARGS+=--enable-startup-notification
.else
CONFIGURE_ARGS+=--disable-startup-notification
.endif
-.if !defined(WITHOUT_GLADEUI)
+.if ${PORT_OPTIONS:MGLADE}
LIB_DEPENDS+= gladeui-1.10:${PORTSDIR}/devel/glade3
CONFIGURE_ARGS+=--enable-gladeui
.else
CONFIGURE_ARGS+=--disable-gladeui
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>