aboutsummaryrefslogtreecommitdiff
path: root/x11/libxklavier/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /x11/libxklavier/Makefile
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'x11/libxklavier/Makefile')
-rw-r--r--x11/libxklavier/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/x11/libxklavier/Makefile b/x11/libxklavier/Makefile
index 677e6c4c264e..e16ec4e25427 100644
--- a/x11/libxklavier/Makefile
+++ b/x11/libxklavier/Makefile
@@ -1,10 +1,10 @@
# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/x11/libxklavier/Makefile,v 1.53 2010/01/12 02:18:34 avl Exp $
+# $MCom: ports/trunk/x11/libxklavier/Makefile 19813 2014-08-15 19:44:33Z gusi $
PORTNAME= libxklavier
-PORTVERSION= 5.0
-PORTREVISION= 3
+PORTVERSION= 5.2.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
@@ -12,29 +12,25 @@ MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= Utility library to make XKB stuff easier
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+BUILD_DEPENDS= iso-codes>=0:${PORTSDIR}/misc/iso-codes
RUN_DEPENDS= xkbcomp:${PORTSDIR}/x11/xkbcomp \
- ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+ iso-codes>=0:${PORTSDIR}/misc/iso-codes
-USES= gmake libtool:keepla pathfix pkgconfig tar:bzip2
-USE_XORG= x11 xi xkbfile
-USE_GNOME= libxml2 glib20
+USE_XORG= x11 xkbfile
+USES= gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME= libxml2 glib20 introspection:build
USE_LDCONFIG= yes
-INSTALL_TARGET= install-strip
-CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-doxygen \
- --with-xkb-base=${LOCALBASE}/share/X11/xkb \
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS= --with-xkb-base=${LOCALBASE}/share/X11/xkb \
--with-xkb-bin-base=${LOCALBASE}/bin \
--with-xmodmap-base=${LOCALBASE}/share/xmodmap \
--disable-gtk-doc \
--with-html-dir=${GNOME_HTML_DIR}
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
PLIST_SUB= VERSION=${PORTVERSION}
-post-patch:
- @${REINPLACE_CMD} -e 's|== "yes|= "yes|g' \
- ${WRKSRC}/configure
-
.include <bsd.port.mk>