aboutsummaryrefslogtreecommitdiff
path: root/x11/lightdm
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2017-01-03 12:00:38 +0000
committerBen Woods <woodsb02@FreeBSD.org>2017-01-03 12:00:38 +0000
commit106f55f757429d5b753a82a3ef8816d873fb5071 (patch)
tree29bf5755707caa2ea6d4bef7144220a7ec40c33c /x11/lightdm
parent97296617e14efa082414481ed5a6c1be1e782554 (diff)
downloadports-106f55f757429d5b753a82a3ef8816d873fb5071.tar.gz
ports-106f55f757429d5b753a82a3ef8816d873fb5071.zip
x11/lightdm: Correct off-by-one error when relating vtN to /dev/ttyvN
- lightdm will now correctly report vt9 as using /dev/ttyv8
Notes
Notes: svn path=/head/; revision=430457
Diffstat (limited to 'x11/lightdm')
-rw-r--r--x11/lightdm/Makefile1
-rw-r--r--x11/lightdm/files/patch-src_x-server.c2
2 files changed, 2 insertions, 1 deletions
diff --git a/x11/lightdm/Makefile b/x11/lightdm/Makefile
index ffb0a616ef5c..0a8d1cf9de31 100644
--- a/x11/lightdm/Makefile
+++ b/x11/lightdm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lightdm
PORTVERSION= 1.20.0
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= https://launchpad.net/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}/+download/
diff --git a/x11/lightdm/files/patch-src_x-server.c b/x11/lightdm/files/patch-src_x-server.c
index d329ba9a6aa9..ffaf8c5f0106 100644
--- a/x11/lightdm/files/patch-src_x-server.c
+++ b/x11/lightdm/files/patch-src_x-server.c
@@ -5,7 +5,7 @@
gchar *t;
- t = g_strdup_printf ("/dev/tty%d", vt);
-+ t = g_strdup_printf ("/dev/ttyv%d", vt);
++ t = g_strdup_printf ("/dev/ttyv%d", vt-1);
session_set_tty (session, t);
g_free (t);