aboutsummaryrefslogtreecommitdiff
path: root/x11/lumina-core
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /x11/lumina-core
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'x11/lumina-core')
-rw-r--r--x11/lumina-core/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/x11/lumina-core/Makefile b/x11/lumina-core/Makefile
index b57a924e2165..c72870c3fca7 100644
--- a/x11/lumina-core/Makefile
+++ b/x11/lumina-core/Makefile
@@ -39,11 +39,11 @@ RUN_DEPENDS+= gstreamer1-plugins-core>=0:multimedia/gstreamer1-plugins-core
MAKE_JOBS_UNSAFE=yes
-USES= qmake
+USES= qmake qt:5
USE_GL= gl
USE_XORG= x11 xdamage xcb
USE_LDCONFIG= yes
-USE_QT5= core gui widgets network svg multimedia imageformats \
+USE_QT= core gui widgets network svg multimedia imageformats \
buildtools_build x11extras concurrent
USE_GITHUB= yes
GH_ACCOUNT= trueos
@@ -51,13 +51,13 @@ GH_PROJECT= lumina
GH_TAGNAME= b6536c1547571ae8dd0618bed752e2e0025bf2a7
WRKSRC_SUBDIR= src-qt5/core
-#Setup the qmake configuration options
+#Setup the qmake qt:5 configuration options
.if ${PORT_OPTIONS:MTRUEOS}
QMAKE_ARGS= DEFAULT_SETTINGS=TrueOS
.endif
.if${PORT_OPTIONS:MI18N}
-USE_QT5+= linguist_build
+USE_QT+= linguist_build
QMAKE_ARGS+=CONFIG+=WITH_I18N
.endif