aboutsummaryrefslogtreecommitdiff
path: root/x11/lxqt-about/Makefile
diff options
context:
space:
mode:
authorJesper Schmitz Mouridsen <jsm@FreeBSD.org>2018-08-27 16:00:10 +0000
committerJesper Schmitz Mouridsen <jsm@FreeBSD.org>2018-08-27 16:00:10 +0000
commitdbef4029b5e7b4fcea7f853baabe147214698afa (patch)
treedb489d3f5929d1c3507f8a729a0fc8a89bf5e762 /x11/lxqt-about/Makefile
parent6a13f9a0c32fd5b6a8bd9919e2eaa9e274bd8f37 (diff)
downloadports-dbef4029b5e7b4fcea7f853baabe147214698afa.tar.gz
ports-dbef4029b5e7b4fcea7f853baabe147214698afa.zip
Notes
Diffstat (limited to 'x11/lxqt-about/Makefile')
-rw-r--r--x11/lxqt-about/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11/lxqt-about/Makefile b/x11/lxqt-about/Makefile
new file mode 100644
index 000000000000..07b74556b81e
--- /dev/null
+++ b/x11/lxqt-about/Makefile
@@ -0,0 +1,24 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= lxqt-about
+PORTVERSION= 0.13.0
+CATEGORIES= x11
+MASTER_SITES= LXQT
+DIST_SUBDIR= lxqt
+
+MAINTAINER= jsm@FreeBSD.org
+COMMENT= About dialog of LXQt
+
+LICENSE= LGPL21+
+
+USES= cmake:outsource kde:5 lxqt pkgconfig tar:xz qt:5
+USE_QT= buildtools_build qmake_build core dbus gui svg widgets \
+ x11extras xml
+USE_KDE= windowsystem
+USE_LXQT= buildtools lxqt
+
+PLIST_FILES= bin/lxqt-about \
+ share/applications/lxqt-about.desktop
+
+.include <bsd.port.mk>