aboutsummaryrefslogtreecommitdiff
path: root/x11/lxqt-globalkeys
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-06-25 00:47:02 +0000
committerSteve Wills <swills@FreeBSD.org>2018-06-25 00:47:02 +0000
commit0e23926c7d5dac3e1cdbc916b466107575d19e9a (patch)
treed870747d4b907ff2726d764869735f4f83fd3cb3 /x11/lxqt-globalkeys
parentcf83d880fb417d0c531a42b7277cee5700cb9495 (diff)
downloadports-0e23926c7d5dac3e1cdbc916b466107575d19e9a.tar.gz
ports-0e23926c7d5dac3e1cdbc916b466107575d19e9a.zip
x11/lxqt-globalkeys: create port
Daemon and library for global keyboard shortcuts registration for the LXQt desktop. WWW: http://lxqt.org/ PR: 229282 Submitted by: Jesper Schmitz Mouridsen <jesper@schmitz.computer>
Notes
Notes: svn path=/head/; revision=473286
Diffstat (limited to 'x11/lxqt-globalkeys')
-rw-r--r--x11/lxqt-globalkeys/Makefile21
-rw-r--r--x11/lxqt-globalkeys/distinfo3
-rw-r--r--x11/lxqt-globalkeys/pkg-descr4
-rw-r--r--x11/lxqt-globalkeys/pkg-plist31
4 files changed, 59 insertions, 0 deletions
diff --git a/x11/lxqt-globalkeys/Makefile b/x11/lxqt-globalkeys/Makefile
new file mode 100644
index 000000000000..566ecc13b257
--- /dev/null
+++ b/x11/lxqt-globalkeys/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= lxqt-globalkeys
+PORTVERSION= 0.13.0
+CATEGORIES= x11
+MASTER_SITES= LXQT
+
+MAINTAINER= jesper@schmitz.computer
+COMMENT= Global keyboard shortcuts registration
+
+LICENSE= LGPL21+
+
+USES= cmake:outsource compiler:c++11-lib kde:5 lxqt pkgconfig tar:xz
+USE_QT5= buildtools_build qmake_build core dbus gui linguisttools \
+ svg widgets x11extras xml
+USE_KDE= windowsystem
+USE_LXQT= buildtools lxqt
+USE_XORG= ice sm x11 xext
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/x11/lxqt-globalkeys/distinfo b/x11/lxqt-globalkeys/distinfo
new file mode 100644
index 000000000000..fa8ca6f88232
--- /dev/null
+++ b/x11/lxqt-globalkeys/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1527328595
+SHA256 (lxqt/lxqt-globalkeys-0.13.0.tar.xz) = ed6dc56e0374939caeb44380ef4a8765b097761be7381dfedbf79f089764dbbf
+SIZE (lxqt/lxqt-globalkeys-0.13.0.tar.xz) = 53128
diff --git a/x11/lxqt-globalkeys/pkg-descr b/x11/lxqt-globalkeys/pkg-descr
new file mode 100644
index 000000000000..75930cb4fa19
--- /dev/null
+++ b/x11/lxqt-globalkeys/pkg-descr
@@ -0,0 +1,4 @@
+Daemon and library for global keyboard shortcuts registration for the LXQt
+desktop.
+
+WWW: http://lxqt.org/
diff --git a/x11/lxqt-globalkeys/pkg-plist b/x11/lxqt-globalkeys/pkg-plist
new file mode 100644
index 000000000000..317f638db5ba
--- /dev/null
+++ b/x11/lxqt-globalkeys/pkg-plist
@@ -0,0 +1,31 @@
+bin/lxqt-config-globalkeyshortcuts
+bin/lxqt-globalkeysd
+include/lxqt-globalkeys-ui/LXQtGlobalKeysUi/ShortcutSelector
+include/lxqt-globalkeys-ui/shortcut_selector.h
+include/lxqt-globalkeys-ui/shortcutselector.h
+include/lxqt-globalkeys/LXQtGlobalKeys/Action
+include/lxqt-globalkeys/LXQtGlobalKeys/Client
+include/lxqt-globalkeys/LXQtGlobalKeys/LXQtGlobalKeys
+include/lxqt-globalkeys/action.h
+include/lxqt-globalkeys/client.h
+include/lxqt-globalkeys/lxqt-globalkeys.h
+include/lxqt-globalkeys/lxqtglobalkeys.h
+lib/liblxqt-globalkeys-ui.so
+lib/liblxqt-globalkeys-ui.so.0
+lib/liblxqt-globalkeys-ui.so.%%VERSION%%
+lib/liblxqt-globalkeys.so
+lib/liblxqt-globalkeys.so.0
+lib/liblxqt-globalkeys.so.%%VERSION%%
+libdata/pkgconfig/lxqt-globalkeys-ui.pc
+libdata/pkgconfig/lxqt-globalkeys.pc
+etc/xdg/autostart/lxqt-globalkeyshortcuts.desktop
+etc/xdg/lxqt/globalkeyshortcuts.conf
+share/applications/lxqt-config-globalkeyshortcuts.desktop
+share/cmake/lxqt-globalkeys-ui/lxqt-globalkeys-ui-config-version.cmake
+share/cmake/lxqt-globalkeys-ui/lxqt-globalkeys-ui-config.cmake
+share/cmake/lxqt-globalkeys-ui/lxqt-globalkeys-ui-targets-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/lxqt-globalkeys-ui/lxqt-globalkeys-ui-targets.cmake
+share/cmake/lxqt-globalkeys/lxqt-globalkeys-config-version.cmake
+share/cmake/lxqt-globalkeys/lxqt-globalkeys-config.cmake
+share/cmake/lxqt-globalkeys/lxqt-globalkeys-targets-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/lxqt-globalkeys/lxqt-globalkeys-targets.cmake