aboutsummaryrefslogtreecommitdiff
path: root/x11/mate-session-manager
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-09-10 13:11:28 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-09-10 13:11:28 +0000
commitbcf3a830a4f4c1c5453ee72607fea3aa99a4b5cc (patch)
treee98877eaeb5e2a44f00691183c3f6564168e2955 /x11/mate-session-manager
parentf9f9a731b4169a1148866d9821539fe3f5dd5aa6 (diff)
downloadports-bcf3a830a4f4c1c5453ee72607fea3aa99a4b5cc.tar.gz
ports-bcf3a830a4f4c1c5453ee72607fea3aa99a4b5cc.zip
Welcome Mate Desktop 1.8
The porting work as been done by gnome@ (kwm) and Eric Turgeon (ericturgeon@ghostbsd.org)
Notes
Notes: svn path=/head/; revision=367830
Diffstat (limited to 'x11/mate-session-manager')
-rw-r--r--x11/mate-session-manager/Makefile10
-rw-r--r--x11/mate-session-manager/distinfo4
-rw-r--r--x11/mate-session-manager/files/patch-configure92
-rw-r--r--x11/mate-session-manager/files/patch-mate-session_gsm-logout-dialog.c26
-rw-r--r--x11/mate-session-manager/files/patch-mate-session_gsm-manager.c64
-rw-r--r--x11/mate-session-manager/pkg-plist15
6 files changed, 204 insertions, 7 deletions
diff --git a/x11/mate-session-manager/Makefile b/x11/mate-session-manager/Makefile
index 8114c151ab17..ed4fce7605f2 100644
--- a/x11/mate-session-manager/Makefile
+++ b/x11/mate-session-manager/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mate-session-manager
-PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTVERSION= 1.8.1
CATEGORIES= x11 mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -12,16 +11,17 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Session component for the MATE desktop
LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
- libupower-glib.so:${PORTSDIR}/sysutils/upower
+ libupower-glib.so:${PORTSDIR}/sysutils/upower \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo
RUN_DEPENDS= ${LOCALBASE}/sbin/console-kit-daemon:${PORTSDIR}/sysutils/consolekit \
${LOCALBASE}/bin/xdpyinfo:${PORTSDIR}/x11/xdpyinfo
PORTSCOUT= limitw:1,even
-USES= execinfo gettext gmake pathfix pkgconfig tar:xz
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
USE_MATE= settingsdaemon
USE_XORG= ice sm xau xext xrandr xrender xtrans xtst
-USE_GNOME= glib20 gnomehier gtk20 intlhack librsvg2 libxslt pango
+USE_GNOME= gnomehier gtk20 intlhack librsvg2 libxslt pango
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-docbook-docs \
--with-gtk=2.0 \
diff --git a/x11/mate-session-manager/distinfo b/x11/mate-session-manager/distinfo
index dd729c45aaf0..d924f991ace7 100644
--- a/x11/mate-session-manager/distinfo
+++ b/x11/mate-session-manager/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mate/mate-session-manager-1.6.1.tar.xz) = 4ee7b4ae18df5becd986b05634428edf0ad8de150a14dc29848b6d34ab312ce9
-SIZE (mate/mate-session-manager-1.6.1.tar.xz) = 641524
+SHA256 (mate/mate-session-manager-1.8.1.tar.xz) = 2f85a714704bc475d08809be6ecf24a5d94d2e2d0ea5ac704d67557c349d7b8c
+SIZE (mate/mate-session-manager-1.8.1.tar.xz) = 524204
diff --git a/x11/mate-session-manager/files/patch-configure b/x11/mate-session-manager/files/patch-configure
new file mode 100644
index 000000000000..03ccb0ce7efe
--- /dev/null
+++ b/x11/mate-session-manager/files/patch-configure
@@ -0,0 +1,92 @@
+--- configure.orig 2014-04-20 19:14:11.248250628 +0000
++++ configure 2014-04-20 19:14:11.260251121 +0000
+@@ -13329,7 +13329,89 @@
+ esac
+
+
++# We can only support old upower
+
++pkg_failed=no
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for UPOWER" >&5
++$as_echo_n "checking for UPOWER... " >&6; }
++
++if test -n "$UPOWER_CFLAGS"; then
++ pkg_cv_UPOWER_CFLAGS="$UPOWER_CFLAGS"
++ elif test -n "$PKG_CONFIG"; then
++ if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"upower-glib < 0.99.0\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "upower-glib < 0.99.0") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ pkg_cv_UPOWER_CFLAGS=`$PKG_CONFIG --cflags "upower-glib < 0.99.0" 2>/dev/null`
++ test "x$?" != "x0" && pkg_failed=yes
++else
++ pkg_failed=yes
++fi
++ else
++ pkg_failed=untried
++fi
++if test -n "$UPOWER_LIBS"; then
++ pkg_cv_UPOWER_LIBS="$UPOWER_LIBS"
++ elif test -n "$PKG_CONFIG"; then
++ if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"upower-glib < 0.99.0\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "upower-glib < 0.99.0") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ pkg_cv_UPOWER_LIBS=`$PKG_CONFIG --libs "upower-glib < 0.99.0" 2>/dev/null`
++ test "x$?" != "x0" && pkg_failed=yes
++else
++ pkg_failed=yes
++fi
++ else
++ pkg_failed=untried
++fi
++if test $pkg_failed = yes; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++
++if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
++ _pkg_short_errors_supported=yes
++else
++ _pkg_short_errors_supported=no
++fi
++ if test $_pkg_short_errors_supported = yes; then
++ UPOWER_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "upower-glib < 0.99.0" 2>&1`
++ else
++ UPOWER_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "upower-glib < 0.99.0" 2>&1`
++ fi
++ # Put the nasty error message in config.log where it belongs
++ echo "$UPOWER_PKG_ERRORS" >&5
++
++ have_old_upower=no
++elif test $pkg_failed = untried; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++ have_old_upower=no
++else
++ UPOWER_CFLAGS=$pkg_cv_UPOWER_CFLAGS
++ UPOWER_LIBS=$pkg_cv_UPOWER_LIBS
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
++$as_echo "yes" >&6; }
++ have_old_upower=yes
++fi
++if test x$have_old_upower = xyes; then :
++
++
++$as_echo "#define HAVE_OLD_UPOWER 1" >>confdefs.h
++
++
++fi
++ if test x$have_old_upower = xyes; then
++ HAVE_OLD_UPOWER_TRUE=
++ HAVE_OLD_UPOWER_FALSE='#'
++else
++ HAVE_OLD_UPOWER_TRUE='#'
++ HAVE_OLD_UPOWER_FALSE=
++fi
+
+
+
diff --git a/x11/mate-session-manager/files/patch-mate-session_gsm-logout-dialog.c b/x11/mate-session-manager/files/patch-mate-session_gsm-logout-dialog.c
new file mode 100644
index 000000000000..83910fc665d4
--- /dev/null
+++ b/x11/mate-session-manager/files/patch-mate-session_gsm-logout-dialog.c
@@ -0,0 +1,26 @@
+--- mate-session/gsm-logout-dialog.c.orig 2014-03-05 20:39:13.000000000 +0000
++++ mate-session/gsm-logout-dialog.c 2014-04-20 18:19:12.537577789 +0000
+@@ -214,8 +214,10 @@
+ #if defined(HAVE_SYSTEMD) && defined(HAVE_UPOWER)
+ else
+ #endif
+-#ifdef HAVE_UPOWER
++#ifdef HAVE_OLD_UPOWER
+ ret = up_client_get_can_suspend (logout_dialog->priv->up_client);
++#else
++ ret = FALSE;
+ #endif
+ return ret;
+ }
+@@ -232,8 +234,10 @@
+ #if defined(HAVE_SYSTEMD) && defined(HAVE_UPOWER)
+ else
+ #endif
+-#ifdef HAVE_UPOWER
++#ifdef HAVE_OLD_UPOWER
+ ret = up_client_get_can_hibernate (logout_dialog->priv->up_client);
++#else
++ ret = FALSE;
+ #endif
+ return ret;
+ }
diff --git a/x11/mate-session-manager/files/patch-mate-session_gsm-manager.c b/x11/mate-session-manager/files/patch-mate-session_gsm-manager.c
new file mode 100644
index 000000000000..63d84cc82236
--- /dev/null
+++ b/x11/mate-session-manager/files/patch-mate-session_gsm-manager.c
@@ -0,0 +1,64 @@
+--- mate-session/gsm-manager.c.orig 2014-03-05 20:39:13.000000000 +0000
++++ mate-session/gsm-manager.c 2014-04-20 18:31:08.980429286 +0000
+@@ -1166,22 +1166,28 @@
+ #if defined(HAVE_SYSTEMD) && defined(HAVE_UPOWER)
+ else {
+ #endif
+-#ifdef HAVE_UPOWER
++#ifdef HAVE_OLD_UPOWER
+ can_hibernate = up_client_get_can_hibernate (manager->priv->up_client);
++#else
++ can_hibernate = FALSE;
++#endif
+ if (can_hibernate) {
+
+ /* lock the screen before we suspend */
+ manager_perhaps_lock (manager);
+
+ error = NULL;
++#ifdef HAVE_OLD_UPOWER
+ ret = up_client_hibernate_sync (manager->priv->up_client, NULL, &error);
++#else
++ ret = FALSE;
++#endif
+ if (!ret) {
+ g_warning ("Unexpected hibernate failure: %s",
+ error->message);
+ g_error_free (error);
+ }
+ }
+-#endif
+ #if defined(HAVE_SYSTEMD) && defined(HAVE_UPOWER)
+ }
+ #endif
+@@ -1211,22 +1217,28 @@
+ #if defined(HAVE_SYSTEMD) && defined(HAVE_UPOWER)
+ else {
+ #endif
+-#ifdef HAVE_UPOWER
++#ifdef HAVE_OLD_UPOWER
+ can_suspend = up_client_get_can_suspend (manager->priv->up_client);
++#else
++ can_suspend = FALSE;
++#endif
+ if (can_suspend) {
+
+ /* lock the screen before we suspend */
+ manager_perhaps_lock (manager);
+
+ error = NULL;
++#ifdef HAVE_OLD_UPOWER
+ ret = up_client_suspend_sync (manager->priv->up_client, NULL, &error);
++#else
++ ret = FALSE;
++#endif
+ if (!ret) {
+ g_warning ("Unexpected suspend failure: %s",
+ error->message);
+ g_error_free (error);
+ }
+ }
+-#endif
+ #if defined(HAVE_SYSTEMD) && defined(HAVE_UPOWER)
+ }
+ #endif
diff --git a/x11/mate-session-manager/pkg-plist b/x11/mate-session-manager/pkg-plist
index 316e38d6df3f..53b81a613817 100644
--- a/x11/mate-session-manager/pkg-plist
+++ b/x11/mate-session-manager/pkg-plist
@@ -29,6 +29,7 @@ share/locale/br/LC_MESSAGES/mate-session-manager.mo
share/locale/bs/LC_MESSAGES/mate-session-manager.mo
share/locale/ca/LC_MESSAGES/mate-session-manager.mo
share/locale/ca@valencia/LC_MESSAGES/mate-session-manager.mo
+share/locale/cmn/LC_MESSAGES/mate-session-manager.mo
share/locale/crh/LC_MESSAGES/mate-session-manager.mo
share/locale/cs/LC_MESSAGES/mate-session-manager.mo
share/locale/cy/LC_MESSAGES/mate-session-manager.mo
@@ -37,8 +38,11 @@ share/locale/de/LC_MESSAGES/mate-session-manager.mo
share/locale/dz/LC_MESSAGES/mate-session-manager.mo
share/locale/el/LC_MESSAGES/mate-session-manager.mo
share/locale/en@shaw/LC_MESSAGES/mate-session-manager.mo
+share/locale/en_AU/LC_MESSAGES/mate-session-manager.mo
share/locale/en_CA/LC_MESSAGES/mate-session-manager.mo
share/locale/en_GB/LC_MESSAGES/mate-session-manager.mo
+share/locale/en_US/LC_MESSAGES/mate-session-manager.mo
+share/locale/es_MX/LC_MESSAGES/mate-session-manager.mo
share/locale/eo/LC_MESSAGES/mate-session-manager.mo
share/locale/es/LC_MESSAGES/mate-session-manager.mo
share/locale/et/LC_MESSAGES/mate-session-manager.mo
@@ -63,9 +67,11 @@ share/locale/is/LC_MESSAGES/mate-session-manager.mo
share/locale/it/LC_MESSAGES/mate-session-manager.mo
share/locale/ja/LC_MESSAGES/mate-session-manager.mo
share/locale/ka/LC_MESSAGES/mate-session-manager.mo
+share/locale/kk/LC_MESSAGES/mate-session-manager.mo
share/locale/kn/LC_MESSAGES/mate-session-manager.mo
share/locale/ko/LC_MESSAGES/mate-session-manager.mo
share/locale/ku/LC_MESSAGES/mate-session-manager.mo
+share/locale/ky/LC_MESSAGES/mate-session-manager.mo
share/locale/lt/LC_MESSAGES/mate-session-manager.mo
share/locale/lv/LC_MESSAGES/mate-session-manager.mo
share/locale/mai/LC_MESSAGES/mate-session-manager.mo
@@ -106,6 +112,7 @@ share/locale/tk/LC_MESSAGES/mate-session-manager.mo
share/locale/tr/LC_MESSAGES/mate-session-manager.mo
share/locale/ug/LC_MESSAGES/mate-session-manager.mo
share/locale/uk/LC_MESSAGES/mate-session-manager.mo
+share/locale/ur/LC_MESSAGES/mate-session-manager.mo
share/locale/uz/LC_MESSAGES/mate-session-manager.mo
share/locale/uz@cyrillic/LC_MESSAGES/mate-session-manager.mo
share/locale/vi/LC_MESSAGES/mate-session-manager.mo
@@ -131,6 +138,8 @@ share/xsessions/mate.desktop
@dirrmtry share/locale/xh
@dirrmtry share/locale/uz@cyrillic/LC_MESSAGES
@dirrmtry share/locale/uz@cyrillic
+@dirrmtry share/locale/ur/LC_MESSAGES
+@dirrmtry share/locale/ur
@dirrmtry share/locale/ug/LC_MESSAGES
@dirrmtry share/locale/ug
@dirrmtry share/locale/te/LC_MESSAGES
@@ -157,8 +166,12 @@ share/xsessions/mate.desktop
@dirrmtry share/locale/mg
@dirrmtry share/locale/mai/LC_MESSAGES
@dirrmtry share/locale/mai
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
@dirrmtry share/locale/ig/LC_MESSAGES
@dirrmtry share/locale/ig
@dirrmtry share/locale/hy/LC_MESSAGES
@@ -175,6 +188,8 @@ share/xsessions/mate.desktop
@dirrmtry share/locale/dz
@dirrmtry share/locale/crh/LC_MESSAGES
@dirrmtry share/locale/crh
+@dirrmtry share/locale/cmn/LC_MESSAGES
+@dirrmtry share/locale/cmn
@dirrmtry share/locale/ca@valencia/LC_MESSAGES
@dirrmtry share/locale/ca@valencia
@dirrmtry share/locale/bn_IN/LC_MESSAGES