aboutsummaryrefslogtreecommitdiff
path: root/x11/mlterm
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2018-02-03 14:00:47 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2018-02-03 14:00:47 +0000
commit2bb879dd6ac868068793b8407e2924c50c6d041d (patch)
tree83b772c848771680dd86966e20f02f9f9156c797 /x11/mlterm
parentee08fc60e5738bfa9d02876d8374492f5ca168ea (diff)
downloadports-2bb879dd6ac868068793b8407e2924c50c6d041d.tar.gz
ports-2bb879dd6ac868068793b8407e2924c50c6d041d.zip
Notes
Diffstat (limited to 'x11/mlterm')
-rw-r--r--x11/mlterm/Makefile2
-rw-r--r--x11/mlterm/distinfo6
-rw-r--r--x11/mlterm/files/patch-configure6
-rw-r--r--x11/mlterm/files/patch-inputmethod_ibus_im__ibus.c6
4 files changed, 10 insertions, 10 deletions
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 792edb589984..45d5683fbaf7 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mlterm
-PORTVERSION= 3.8.3
+PORTVERSION= 3.8.4
CATEGORIES= x11
MASTER_SITES= SF/${PORTNAME}/01release/${PORTNAME}-${PORTVERSION}
diff --git a/x11/mlterm/distinfo b/x11/mlterm/distinfo
index 7c3cd3276284..63c733d5b798 100644
--- a/x11/mlterm/distinfo
+++ b/x11/mlterm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1509800157
-SHA256 (mlterm-3.8.3.tar.gz) = cd4bddb10bd7866255ddf45192add4853c2e8c49b36df6e9a9d2f274af18f9ee
-SIZE (mlterm-3.8.3.tar.gz) = 3850354
+TIMESTAMP = 1517665433
+SHA256 (mlterm-3.8.4.tar.gz) = c9f1cc380e8cd1546cf2bb4e1cedc80ca8a2d629567a9553ca32e43b4a3a301e
+SIZE (mlterm-3.8.4.tar.gz) = 3881872
diff --git a/x11/mlterm/files/patch-configure b/x11/mlterm/files/patch-configure
index 5bb5ef8dc09b..8646c5ebc5cf 100644
--- a/x11/mlterm/files/patch-configure
+++ b/x11/mlterm/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2017-01-07 22:24:39 UTC
+--- configure.orig 2017-12-02 16:03:25 UTC
+++ configure
-@@ -21932,7 +21932,7 @@ if test "$utmp" = "yes" -a "$pty_helper"
+@@ -21976,7 +21976,7 @@ if test "$utmp" = "yes" -a "$pty_helper"
if test "$has_utmp" ; then
INSTALL_OPT="-m 2755 -g utmp"
else
@@ -9,7 +9,7 @@
fi
else
INSTALL_OPT="-m 755"
-@@ -22158,6 +22158,7 @@ $as_echo "yes" >&6; }
+@@ -22202,6 +22202,7 @@ $as_echo "yes" >&6; }
fi
fi
if test "$have_vte" = "yes" ; then
diff --git a/x11/mlterm/files/patch-inputmethod_ibus_im__ibus.c b/x11/mlterm/files/patch-inputmethod_ibus_im__ibus.c
index cf9ed9493b74..e54b4ea6caf7 100644
--- a/x11/mlterm/files/patch-inputmethod_ibus_im__ibus.c
+++ b/x11/mlterm/files/patch-inputmethod_ibus_im__ibus.c
@@ -1,11 +1,11 @@
---- inputmethod/ibus/im_ibus.c.orig 2017-01-07 22:24:38 UTC
+--- inputmethod/ibus/im_ibus.c.orig 2017-12-02 16:03:23 UTC
+++ inputmethod/ibus/im_ibus.c
-@@ -1008,7 +1008,7 @@ im_info_t* im_ibus_get_info(char* locale
+@@ -1033,7 +1033,7 @@ im_info_t *im_ibus_get_info(char *locale
}
result->id = strdup("ibus");
- result->name = strdup("iBus");
+ result->name = strdup("ibus");
- result->num_of_args = 0;
+ result->num_args = 0;
result->args = NULL;
result->readable_args = NULL;