aboutsummaryrefslogtreecommitdiff
path: root/x11/nvidia-driver
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-06-30 06:33:21 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-06-30 06:33:21 +0000
commitc44d975f657a7305209b839cd79c7dea2596f807 (patch)
treeabbc8bd7a2a6934bb62c9e82d390d08fb7bdc5a5 /x11/nvidia-driver
parent25be1c3403d8e66ffee8528a1428c18119b7b149 (diff)
downloadports-c44d975f657a7305209b839cd79c7dea2596f807.tar.gz
ports-c44d975f657a7305209b839cd79c7dea2596f807.zip
Notes
Diffstat (limited to 'x11/nvidia-driver')
-rw-r--r--x11/nvidia-driver/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/x11/nvidia-driver/Makefile b/x11/nvidia-driver/Makefile
index 4387ed141a88..8dd46ad7456c 100644
--- a/x11/nvidia-driver/Makefile
+++ b/x11/nvidia-driver/Makefile
@@ -312,16 +312,13 @@ post-install: .SILENT
# update distinfo (i.e., keeping other driver version entries intact)
.if ${.TARGETS:Mupdate-distinfo}
DISTINFO_FILE= ${MASTERDIR}/distinfo.new
-JOIN?= /usr/bin/join
.endif
update-distinfo: makesum .SILENT
- ${REINPLACE_CMD} -i '' -e '/${ARCH_SUFX}-${NVVERSION:R}/s/^/~/' \
- ${MASTERDIR}/distinfo ${DISTINFO_FILE}
- ${SED} -e '/^~/s/(.*//' ${MASTERDIR}/distinfo | ${JOIN} -a 1 \
- - ${DISTINFO_FILE} | ${SED} -e 's/^~//' \
- > ${MASTERDIR}/distinfo.tmp
- ${MV} ${MASTERDIR}/distinfo.tmp ${MASTERDIR}/distinfo
- ${RM} ${DISTINFO_FILE}
+ ${REINPLACE_CMD} -e '/${ARCH_SUFX}-${NVVERSION:R}/s/^/~/' \
+ ${MASTERDIR}/distinfo
+ ${REINPLACE_CMD} -e '/^~SHA256/r ${DISTINFO_FILE}' -e '/^~/d' \
+ ${MASTERDIR}/distinfo
+ ${RM} ${DISTINFO_FILE} ${MASTERDIR}/distinfo.bak
.include <bsd.port.mk>