aboutsummaryrefslogtreecommitdiff
path: root/x11/ooxcb/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-07-13 12:48:28 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-07-13 12:48:28 +0000
commitae937334e7a54da0f71e544416f1242eb59f7588 (patch)
treebf6fcdc38bc2a3a188b0bf06909df50baa2e5108 /x11/ooxcb/Makefile
parent94f2c59c64f06390c2e4d2d0dcae5454e624bca3 (diff)
downloadports-ae937334e7a54da0f71e544416f1242eb59f7588.tar.gz
ports-ae937334e7a54da0f71e544416f1242eb59f7588.zip
Notes
Diffstat (limited to 'x11/ooxcb/Makefile')
-rw-r--r--x11/ooxcb/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11/ooxcb/Makefile b/x11/ooxcb/Makefile
new file mode 100644
index 000000000000..0a032d5d44f5
--- /dev/null
+++ b/x11/ooxcb/Makefile
@@ -0,0 +1,22 @@
+# New ports collection Makefile for: ooxcb
+# Date created: 26 June 2009
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= ooxcb
+PORTVERSION= 1.0
+CATEGORIES= x11
+MASTER_SITES= http://samurai-x.org/downloads/
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Python binding to the X server using xcb
+
+LIB_DEPENDS= xcb.2:${PORTSDIR}/x11/libxcb
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PLIST_FILES= ${PYTHON_SITELIBDIR:S/${LOCALBASE}\///}/${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+.include <bsd.port.mk>