aboutsummaryrefslogtreecommitdiff
path: root/x11/pipeglade
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-02-27 21:24:53 +0000
committerSteve Wills <swills@FreeBSD.org>2017-02-27 21:24:53 +0000
commit562fb15fe1de15e2af731da2afe72afd66d43513 (patch)
tree149aea27a07c3d36798e53822a215ee5483b8779 /x11/pipeglade
parent10a0fb614ebee64f19efbe99cfdd7081508e5471 (diff)
downloadports-562fb15fe1de15e2af731da2afe72afd66d43513.tar.gz
ports-562fb15fe1de15e2af731da2afe72afd66d43513.zip
x11/pipeglade: create port
Pipeglade is a helper program that displays graphical user interfaces for other programs. It renders the GUI definition found in a GtkBuilder file (created using the Glade Interface Designer), and communicates with the main program solely via pipes or fifos. WWW: http://pipeglade.boundp.org PR: 203523 Submitted by: Bert Burgemeister <trebbu@googlemail.com> (with modifications)
Notes
Notes: svn path=/head/; revision=434993
Diffstat (limited to 'x11/pipeglade')
-rw-r--r--x11/pipeglade/Makefile35
-rw-r--r--x11/pipeglade/distinfo3
-rw-r--r--x11/pipeglade/pkg-descr21
-rw-r--r--x11/pipeglade/pkg-plist8
4 files changed, 67 insertions, 0 deletions
diff --git a/x11/pipeglade/Makefile b/x11/pipeglade/Makefile
new file mode 100644
index 000000000000..90cda90b5582
--- /dev/null
+++ b/x11/pipeglade/Makefile
@@ -0,0 +1,35 @@
+# Created by: Bert Burgemeister <trebbu@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= pipeglade
+PORTVERSION= 4.7.0
+CATEGORIES= x11 devel
+
+MAINTAINER= trebbu@googlemail.com
+COMMENT= Graphical user interface driven by pipes or fifos
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= trebb
+
+USES= gettext-runtime pkgconfig
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 libxml2
+
+OPTIONS_DEFINE= EXAMPLES
+OPTIONS_SUB= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1/
+
+post-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/clock.sh ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/echo.sh ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/clock.ui ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/pipeglade.ui ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/simple_dialog.ui ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/simple_open.ui ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/x11/pipeglade/distinfo b/x11/pipeglade/distinfo
new file mode 100644
index 000000000000..9be64a0acf4d
--- /dev/null
+++ b/x11/pipeglade/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1488225220
+SHA256 (trebb-pipeglade-4.7.0_GH0.tar.gz) = 91020685849ccb1fd091d41fbace68b23be2bb4b9d6c543a6b1bb68ccb3ca828
+SIZE (trebb-pipeglade-4.7.0_GH0.tar.gz) = 82888
diff --git a/x11/pipeglade/pkg-descr b/x11/pipeglade/pkg-descr
new file mode 100644
index 000000000000..4cee05c3932f
--- /dev/null
+++ b/x11/pipeglade/pkg-descr
@@ -0,0 +1,21 @@
+Pipeglade is a helper program that displays graphical user interfaces
+for other programs. It renders the GUI definition found in a
+GtkBuilder file (created using the Glade Interface Designer), and
+communicates with the main program solely via pipes or fifos.
+
+To have its GUI rendered by pipeglade, a program must be able to
+ - send plain text commands to standard output or a named pipe and/or
+ - receive and parse simple plain text messages from standard input or
+ a named pipe.
+
+Simple one-shot dialogs as well as more complex, long-running programs
+can be built.
+
+Pipeglade provides access to a subset of the features available in
+GTK+ 3. Widgets able to communicate via pipeglade include text labels
+and images, statusbars and progress indicators, various kinds of
+buttons, spinbuttons and scales/sliders, comboboxes and menus, various
+text and tabular inputs, various standard dialog windows, calendars,
+drawing areas.
+
+WWW: http://pipeglade.boundp.org
diff --git a/x11/pipeglade/pkg-plist b/x11/pipeglade/pkg-plist
new file mode 100644
index 000000000000..1d3722ab94e1
--- /dev/null
+++ b/x11/pipeglade/pkg-plist
@@ -0,0 +1,8 @@
+bin/pipeglade
+man/man1/pipeglade.1.gz
+%%EXAMPLES%%%%EXAMPLESDIR%%/clock.sh
+%%EXAMPLES%%%%EXAMPLESDIR%%/clock.ui
+%%EXAMPLES%%%%EXAMPLESDIR%%/echo.sh
+%%EXAMPLES%%%%EXAMPLESDIR%%/pipeglade.ui
+%%EXAMPLES%%%%EXAMPLESDIR%%/simple_dialog.ui
+%%EXAMPLES%%%%EXAMPLESDIR%%/simple_open.ui