aboutsummaryrefslogtreecommitdiff
path: root/x11/plasma5-plasma-desktop/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-09-14 10:20:01 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-09-14 10:41:45 +0000
commit6e62549d4c3afadd6c633e22ac58afbd47fd3504 (patch)
tree575d2674a85fdb0daff99fdcff89e404e8717c96 /x11/plasma5-plasma-desktop/Makefile
parent3b8394180ae56027d381f59a9a632a2c696a32c1 (diff)
downloadports-6e62549d4c3afadd6c633e22ac58afbd47fd3504.tar.gz
ports-6e62549d4c3afadd6c633e22ac58afbd47fd3504.zip
Diffstat (limited to 'x11/plasma5-plasma-desktop/Makefile')
-rw-r--r--x11/plasma5-plasma-desktop/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/x11/plasma5-plasma-desktop/Makefile b/x11/plasma5-plasma-desktop/Makefile
index a629eac4b65a..5bd2fa6bd2a6 100644
--- a/x11/plasma5-plasma-desktop/Makefile
+++ b/x11/plasma5-plasma-desktop/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-desktop
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -29,22 +30,22 @@ BUILD_DEPENDS= xf86-input-evdev>0:x11-drivers/xf86-input-evdev \
wayland-protocols>=1.18:graphics/wayland-protocols
USES= cmake compiler:c++11-lib cpe desktop-file-utils gettext gnome \
- kde:5 pkgconfig python:run qt:5 shebangfix tar:xz xorg
+ kde:5 pkgconfig qt:5 shebangfix tar:xz xorg \
+ python:run
USE_GNOME= glib20
-USE_KDE= activities activities-stats archive attica auth baloo \
- bookmarks codecs completion config configwidgets coreaddons \
- crash dbusaddons emoticons filemetadata globalaccel guiaddons \
- i18n iconthemes init itemmodels itemviews jobwidgets kcmutils \
- kdeclarative kdelibs4support kio libksysguard newstuff \
- notifications notifyconfig package parts people \
- plasma-framework plasma-workspace runner service solid sonnet \
- textwidgets unitconversion wallet widgetsaddons windowsystem \
- xmlgui \
+USE_KDE= activities activities-stats attica auth baloo bookmarks codecs \
+ completion config configwidgets coreaddons crash dbusaddons \
+ filemetadata globalaccel guiaddons i18n iconthemes init \
+ itemmodels itemviews jobwidgets kcmutils kdeclarative \
+ kdelibs4support kio kpipewire libksysguard newstuff \
+ notifications notifyconfig package parts plasma-framework \
+ plasma-workspace runner service solid sonnet textwidgets \
+ unitconversion widgetsaddons windowsystem xmlgui \
doctools:build ecm:build \
drkonqi:run infocenter:run kde-cli-tools:run kmenuedit:run \
ksysguard:run polkit-kde-agent-1:run systemsettings:run
USE_QT= concurrent core dbus declarative gui network phonon4 \
- printsupport sql svg wayland widgets x11extras xml \
+ printsupport sql wayland widgets x11extras xml \
buildtools:build qmake:build
USE_XORG= ice sm x11 xcb xcursor xext xfixes xft xi xrender