aboutsummaryrefslogtreecommitdiff
path: root/x11/polybar
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-26 19:07:54 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-26 19:07:54 +0000
commit13a4aa54c724708331e2a4d4b5ea08f23f151e21 (patch)
tree9080232c22362c5c75a4949e8ab1a29b6b214230 /x11/polybar
parent55230ce71bd4b2c715a8ee1d670cf106dff54ee6 (diff)
downloadports-13a4aa54c724708331e2a4d4b5ea08f23f151e21.tar.gz
ports-13a4aa54c724708331e2a4d4b5ea08f23f151e21.zip
x11/polybar: Fix build against x11/xcb-proto 1.13.
* Update to a more recent upstream commit to fix the build against xcb-proto 1.13 * Drop upstreamed patches, which already included now * Give MAINTAINERSHIP to lbdm PR: 228330 Submitted by: Alexandre C. GuimarĂ£es <lebarondemerde@privacychain.ch> Approved by: <capt_redbeard@protonmail.com> (maintainer timeout) Differential Revision: https://reviews.freebsd.org/D15965
Notes
Notes: svn path=/head/; revision=473406
Diffstat (limited to 'x11/polybar')
-rw-r--r--x11/polybar/Makefile29
-rw-r--r--x11/polybar/distinfo14
-rw-r--r--x11/polybar/files/patch-cmake_01-core.cmake20
-rw-r--r--x11/polybar/files/patch-cmake_03-libs.cmake11
-rw-r--r--x11/polybar/files/patch-include_adapters_alsa_generic.hpp14
-rw-r--r--x11/polybar/files/patch-man_CMakeLists.txt7
-rw-r--r--x11/polybar/pkg-plist2
7 files changed, 27 insertions, 70 deletions
diff --git a/x11/polybar/Makefile b/x11/polybar/Makefile
index acc401727e71..3013b00fa7fb 100644
--- a/x11/polybar/Makefile
+++ b/x11/polybar/Makefile
@@ -1,19 +1,18 @@
# $FreeBSD$
PORTNAME= polybar
-DISTVERSION= 3.1.0
-PORTREVISION= 2
+DISTVERSION= 3.1.0.20180621
CATEGORIES= x11
-MAINTAINER= capt_redbeard@protonmail.com
+MAINTAINER= lebarondemerde@privacychain.ch
COMMENT= Fast and easy-to-use status bar
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_aarch64= fails to build: KeyError: 'eventstruct'
-BROKEN_armv6= fails to build: KeyError: 'eventstruct'
-BROKEN_armv7= fails to build: KeyError: 'eventstruct'
+BROKEN_aarch64= fails to build: KeyError: 'eventstruct'
+BROKEN_armv6= fails to build: KeyError: 'eventstruct'
+BROKEN_armv7= fails to build: KeyError: 'eventstruct'
BUILD_DEPENDS= xcb-proto>=1.9:x11/xcb-proto
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
@@ -26,15 +25,17 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libxcb-util.so:x11/xcb-util \
libxcb-xrm.so:x11/xcb-util-xrm
-USES= cmake:outsource localbase:ldflags pkgconfig python:2.7,build
+USES= cmake:outsource localbase:ldflags pkgconfig \
+ python:2.7,build
USE_GITHUB= yes
GH_ACCOUNT= jaagr
-GH_TUPLE= jaagr:i3ipcpp:v0.7.1:i3ipcpp/lib/i3ipcpp \
- jaagr:xpp:1.4.0-1-g64bd576:xpp/lib/xpp
+GH_TAGNAME= 028b141
+GH_TUPLE= jaagr:i3ipcpp:v0.7.1-4-gd4e4786:i3ipcpp/lib/i3ipcpp \
+ jaagr:xpp:1.4.0-4-g00165e1:xpp/lib/xpp
USE_GNOME= cairo
USE_XORG= xcb
-OPTIONS_DEFINE= ALSA CURL EXAMPLES I3 IPC MPD TESTS
+OPTIONS_DEFINE= ALSA DEBUG CURL EXAMPLES I3 IPC MPD TESTS
OPTIONS_DEFAULT= CURL I3 IPC MPD
OPTIONS_SUB= yes
@@ -51,6 +52,8 @@ ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
CURL_CMAKE_BOOL= ENABLE_CURL
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
+DEBUG_CMAKE_BOOL= DEBUG_LOGGER
+
I3_BUILD_DEPENDS= ${LOCALBASE}/include/i3/ipc.h:x11-wm/i3
I3_CMAKE_BOOL= ENABLE_I3
I3_LIB_DEPENDS= libjsoncpp.so:devel/jsoncpp
@@ -60,11 +63,11 @@ IPC_CMAKE_BOOL= BUILD_IPC_MSG
MPD_CMAKE_BOOL= ENABLE_MPD
MPD_LIB_DEPENDS= libmpdclient.so:audio/libmpdclient
+# fail while building on poudriere because it need network access
+# during the building process to download googletest on-the-fly.
+TESTS_BUILD_DEPENDS= git>=0:devel/git
TESTS_CMAKE_BOOL= BUILD_TESTS
-post-patch:
- @${REINPLACE_CMD} -e 's|python2|${PYTHON_CMD}|g' ${WRKSRC_xpp}/CMakeLists.txt
-
do-test-TESTS-on:
cd ${TEST_WRKSRC} && ${SETENV} BUILD_TESTS=ON \
${SH} ${WRKSRC}/common/travis/tests.sh
diff --git a/x11/polybar/distinfo b/x11/polybar/distinfo
index 5ff327085abc..192657f41f55 100644
--- a/x11/polybar/distinfo
+++ b/x11/polybar/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1515547603
-SHA256 (jaagr-polybar-3.1.0_GH0.tar.gz) = cb6f404e1c3e9f0239ecde095c04dcb50a164ce346046f077744b2c53fab7fc4
-SIZE (jaagr-polybar-3.1.0_GH0.tar.gz) = 418298
-SHA256 (jaagr-i3ipcpp-v0.7.1_GH0.tar.gz) = 644d82d0e73b7c653e344ac8852e4d7435d9fb7ea54a160ab81662ab4b3652cf
-SIZE (jaagr-i3ipcpp-v0.7.1_GH0.tar.gz) = 191417
-SHA256 (jaagr-xpp-1.4.0-1-g64bd576_GH0.tar.gz) = 451052c2d71b55cb3ea35dcf2f422162756caf05e3d4bfb9e36b47e802fbf109
-SIZE (jaagr-xpp-1.4.0-1-g64bd576_GH0.tar.gz) = 84145
+TIMESTAMP = 1530038626
+SHA256 (jaagr-polybar-3.1.0.20180621-028b141_GH0.tar.gz) = a4465db46192dec4c6644d8d1dd24fbe8f668c55c502f170827561b573029ac7
+SIZE (jaagr-polybar-3.1.0.20180621-028b141_GH0.tar.gz) = 241473
+SHA256 (jaagr-i3ipcpp-v0.7.1-4-gd4e4786_GH0.tar.gz) = 2154bf1a0b0a211bddcf5904ba97f99eb86ef6faded5dd864858e2a1a2389cec
+SIZE (jaagr-i3ipcpp-v0.7.1-4-gd4e4786_GH0.tar.gz) = 191511
+SHA256 (jaagr-xpp-1.4.0-4-g00165e1_GH0.tar.gz) = a0496281fbf52ce7e798426b56ba7c2130d08bbb8241ced7053b1941a4dcb90d
+SIZE (jaagr-xpp-1.4.0-4-g00165e1_GH0.tar.gz) = 84823
diff --git a/x11/polybar/files/patch-cmake_01-core.cmake b/x11/polybar/files/patch-cmake_01-core.cmake
deleted file mode 100644
index cfdb6064f5fb..000000000000
--- a/x11/polybar/files/patch-cmake_01-core.cmake
+++ /dev/null
@@ -1,20 +0,0 @@
---- cmake/01-core.cmake.orig 2017-12-03 17:03:49 UTC
-+++ cmake/01-core.cmake
-@@ -31,8 +31,17 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O2")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pedantic")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pedantic-errors")
-
-+if (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
-+ # Need dprintf() for FreeBSD 11.1 and older
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -D_WITH_DPRINTF")
-+
-+ # libinotify uses c99 extension, so suppress this error
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-c99-extensions")
-+endif()
-+
- if(${CMAKE_CXX_COMPILER_ID} STREQUAL Clang)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=parentheses-equality")
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-zero-length-array")
- endif()
-
- set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DDEBUG")
diff --git a/x11/polybar/files/patch-cmake_03-libs.cmake b/x11/polybar/files/patch-cmake_03-libs.cmake
deleted file mode 100644
index 53675e0d5479..000000000000
--- a/x11/polybar/files/patch-cmake_03-libs.cmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- cmake/03-libs.cmake.orig 2017-12-03 17:03:49 UTC
-+++ cmake/03-libs.cmake
-@@ -21,3 +21,8 @@ querylib(WITH_XRENDER "pkg-config" xcb-render libs dir
- querylib(WITH_XRM "pkg-config" xcb-xrm libs dirs)
- querylib(WITH_XSYNC "pkg-config" xcb-sync libs dirs)
- querylib(WITH_XCURSOR "pkg-config" xcb-cursor libs dirs)
-+
-+# FreeBSD Support
-+if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
-+ querylib(TRUE "pkg-config" libinotify libs dirs)
-+endif()
diff --git a/x11/polybar/files/patch-include_adapters_alsa_generic.hpp b/x11/polybar/files/patch-include_adapters_alsa_generic.hpp
deleted file mode 100644
index 72accc2e14c3..000000000000
--- a/x11/polybar/files/patch-include_adapters_alsa_generic.hpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- include/adapters/alsa/generic.hpp.orig 2017-12-03 17:03:49 UTC
-+++ include/adapters/alsa/generic.hpp
-@@ -4,7 +4,11 @@
- #include <alsa/asoundlib.h>
- #else
- #include <assert.h>
-+
-+#ifndef __FreeBSD__
- #include <endian.h>
-+#endif
-+
- #include <errno.h>
- #include <fcntl.h>
- #include <stdarg.h>
diff --git a/x11/polybar/files/patch-man_CMakeLists.txt b/x11/polybar/files/patch-man_CMakeLists.txt
index a39bee5496f4..ba0793336649 100644
--- a/x11/polybar/files/patch-man_CMakeLists.txt
+++ b/x11/polybar/files/patch-man_CMakeLists.txt
@@ -1,9 +1,8 @@
---- man/CMakeLists.txt.orig 2017-12-03 17:03:49 UTC
+--- man/CMakeLists.txt.orig 2018-05-18 04:58:51 UTC
+++ man/CMakeLists.txt
-@@ -1,4 +1,5 @@
-+include(GNUInstallDirs)
+@@ -1,4 +1,4 @@
set(MAN_PAGES_1 polybar.1)
INSTALL(FILES ${MAN_PAGES_1}
- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man1
-+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1
COMPONENT doc)
diff --git a/x11/polybar/pkg-plist b/x11/polybar/pkg-plist
index 413e9716a0c5..ddfa0bc55b86 100644
--- a/x11/polybar/pkg-plist
+++ b/x11/polybar/pkg-plist
@@ -1,7 +1,7 @@
bin/polybar
%%IPC%%bin/polybar-msg
man/man1/polybar.1.gz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/config
share/bash-completion/completions/polybar
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/config
share/zsh/site-functions/_polybar
share/zsh/site-functions/_polybar_msg