aboutsummaryrefslogtreecommitdiff
path: root/x11/polybar
diff options
context:
space:
mode:
authorAlexandre C. GuimarĂ£es <rigoletto@FreeBSD.org>2019-08-08 05:16:28 +0000
committerAlexandre C. GuimarĂ£es <rigoletto@FreeBSD.org>2019-08-08 05:16:28 +0000
commit92d2eea9d99182289fcca4b57a10f636ade5bf34 (patch)
treec8adbf299b9cbd793cc3da600cec6350d609810b /x11/polybar
parent82029411ed7bae156c14e4658cc6fe160ac45dfc (diff)
downloadports-92d2eea9d99182289fcca4b57a10f636ade5bf34.tar.gz
ports-92d2eea9d99182289fcca4b57a10f636ade5bf34.zip
Notes
Diffstat (limited to 'x11/polybar')
-rw-r--r--x11/polybar/Makefile13
-rw-r--r--x11/polybar/distinfo10
-rw-r--r--x11/polybar/files/patch-doc_CMakeLists.txt11
-rw-r--r--x11/polybar/files/patch-lib_xpp_CMakeLists.txt11
-rw-r--r--x11/polybar/files/patch-man_CMakeLists.txt8
-rw-r--r--x11/polybar/pkg-plist1
6 files changed, 9 insertions, 45 deletions
diff --git a/x11/polybar/Makefile b/x11/polybar/Makefile
index 0ee106b2b06a..d7324b620825 100644
--- a/x11/polybar/Makefile
+++ b/x11/polybar/Makefile
@@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= polybar
-DISTVERSION= 3.3.1
-PORTREVISION= 2
+DISTVERSION= 3.4.0
CATEGORIES= x11
+MASTER_SITES= https://github.com/polybar/polybar/releases/download/${DISTVERSION}/
MAINTAINER= rigoletto@FreeBSD.org
COMMENT= Fast and easy-to-use status bar
@@ -23,12 +23,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
# compiler:c++11-lang is needed for powerpc64
USES= cmake compiler:c++11-lang gnome localbase:ldflags \
- pkgconfig python:2.7,build
-
-USE_GITHUB= yes
-GH_ACCOUNT= jaagr
-GH_TUPLE= jaagr:i3ipcpp:v0.7.1-4-gd4e4786:i3ipcpp/lib/i3ipcpp \
- jaagr:xpp:1.4.0-8-gab6247b:xpp/lib/xpp
+ pkgconfig python:2.7,build tar
USE_GNOME= cairo
USE_XORG= xcb
@@ -81,6 +76,8 @@ TESTS_CMAKE_BOOL= BUILD_TESTS
XKEYBOARD_CMAKE_BOOL= ENABLE_XKEYBOARD
XKEYBOARD_LIB_DEPENDS= libxcb-xkb.so:x11/libxcb
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
do-test-TESTS-on:
cd ${TEST_WRKSRC} && ${SETENV} BUILD_TESTS=ON \
${SH} ${WRKSRC}/common/travis/tests.sh
diff --git a/x11/polybar/distinfo b/x11/polybar/distinfo
index 879d4d66c2b0..4835bcf6ca26 100644
--- a/x11/polybar/distinfo
+++ b/x11/polybar/distinfo
@@ -1,7 +1,3 @@
-TIMESTAMP = 1554317325
-SHA256 (jaagr-polybar-3.3.1_GH0.tar.gz) = d0a0ad987abb9da74c5b1ea4a57f7b17aec1653876b0a26c7da72fc669b53ee7
-SIZE (jaagr-polybar-3.3.1_GH0.tar.gz) = 248790
-SHA256 (jaagr-i3ipcpp-v0.7.1-4-gd4e4786_GH0.tar.gz) = 2154bf1a0b0a211bddcf5904ba97f99eb86ef6faded5dd864858e2a1a2389cec
-SIZE (jaagr-i3ipcpp-v0.7.1-4-gd4e4786_GH0.tar.gz) = 191511
-SHA256 (jaagr-xpp-1.4.0-8-gab6247b_GH0.tar.gz) = ff95905e60da13b6ac8a5670dd259cc0cdd4ebf8ebae985c8bba16c54bbe69ad
-SIZE (jaagr-xpp-1.4.0-8-gab6247b_GH0.tar.gz) = 84294
+TIMESTAMP = 1564027994
+SHA256 (polybar-3.4.0.tar) = 69a098f22d7a72eb594030aff687801252b18520b097c12f5c7894a99c4bcd1b
+SIZE (polybar-3.4.0.tar) = 2713600
diff --git a/x11/polybar/files/patch-doc_CMakeLists.txt b/x11/polybar/files/patch-doc_CMakeLists.txt
deleted file mode 100644
index ab0d726aa2db..000000000000
--- a/x11/polybar/files/patch-doc_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/CMakeLists.txt.orig 2017-12-03 17:03:49 UTC
-+++ doc/CMakeLists.txt
-@@ -85,7 +85,7 @@ configure_file(
- ESCAPE_QUOTES @ONLY)
-
- install(FILES config
-- DESTINATION share/doc/polybar
-+ DESTINATION share/examples/polybar
- COMPONENT config)
-
- # }}}
diff --git a/x11/polybar/files/patch-lib_xpp_CMakeLists.txt b/x11/polybar/files/patch-lib_xpp_CMakeLists.txt
index ac69a6617af1..e7aa9fc62e69 100644
--- a/x11/polybar/files/patch-lib_xpp_CMakeLists.txt
+++ b/x11/polybar/files/patch-lib_xpp_CMakeLists.txt
@@ -1,4 +1,4 @@
---- lib/xpp/CMakeLists.txt.orig 2019-01-12 15:06:55 UTC
+--- lib/xpp/CMakeLists.txt.orig 2019-07-25 04:34:56 UTC
+++ lib/xpp/CMakeLists.txt
@@ -48,7 +48,7 @@ set(XPP_LIBRARIES
#
@@ -9,12 +9,3 @@
message(STATUS "Searching for xcbgen with " ${CURRENT_EXECUTABLE})
execute_process(COMMAND "${CURRENT_EXECUTABLE}" "-c"
-@@ -161,7 +161,7 @@ foreach(PROTO ${PROTO_LIST})
- set(OUTPUT_FILE ${PROJECT_SOURCE_DIR}/include/xpp/proto/${PROTO_OUTPUT}.hpp)
- add_custom_command(
- OUTPUT ${OUTPUT_FILE}
-- COMMAND ${PYTHON_EXECUTABLE} ${PROJECT_SOURCE_DIR}/generators/cpp_client.py -p "${PYTHON_XCBGEN}"
-+ COMMAND ${PYTHON_EXECUTABLE} -B ${PROJECT_SOURCE_DIR}/generators/cpp_client.py -p "${PYTHON_XCBGEN}"
- ${XCBPROTO_XCBINCLUDEDIR}/${PROTO}.xml > ${OUTPUT_FILE})
- list(APPEND PROTO_HEADER_FILES ${OUTPUT_FILE})
- endforeach(PROTO)
diff --git a/x11/polybar/files/patch-man_CMakeLists.txt b/x11/polybar/files/patch-man_CMakeLists.txt
deleted file mode 100644
index ba0793336649..000000000000
--- a/x11/polybar/files/patch-man_CMakeLists.txt
+++ /dev/null
@@ -1,8 +0,0 @@
---- man/CMakeLists.txt.orig 2018-05-18 04:58:51 UTC
-+++ man/CMakeLists.txt
-@@ -1,4 +1,4 @@
- set(MAN_PAGES_1 polybar.1)
- INSTALL(FILES ${MAN_PAGES_1}
-- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man1
-+ DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1
- COMPONENT doc)
diff --git a/x11/polybar/pkg-plist b/x11/polybar/pkg-plist
index b52f02cf089c..1cd6ace0a6d6 100644
--- a/x11/polybar/pkg-plist
+++ b/x11/polybar/pkg-plist
@@ -1,6 +1,5 @@
bin/polybar
%%IPC%%bin/polybar-msg
-man/man1/polybar.1.gz
share/bash-completion/completions/polybar
share/zsh/site-functions/_polybar
share/zsh/site-functions/_polybar_msg