aboutsummaryrefslogtreecommitdiff
path: root/x11/polybar
diff options
context:
space:
mode:
authorAlexandre C. GuimarĂ£es <rigoletto@FreeBSD.org>2019-10-30 16:11:09 +0000
committerAlexandre C. GuimarĂ£es <rigoletto@FreeBSD.org>2019-10-30 16:11:09 +0000
commit97c5683e749d3e25d616a3478ecbcd2b4f634b16 (patch)
tree2915edd4cfe3261275f365cee6fe462dd8896fb9 /x11/polybar
parent0616fa1a2232918548eb754e9e2a1f1376a3c3ca (diff)
downloadports-97c5683e749d3e25d616a3478ecbcd2b4f634b16.tar.gz
ports-97c5683e749d3e25d616a3478ecbcd2b4f634b16.zip
x11/polybar: Update to 3.4.1
Approved by: tcberner (mentor, implicit)
Notes
Notes: svn path=/head/; revision=516084
Diffstat (limited to 'x11/polybar')
-rw-r--r--x11/polybar/Makefile6
-rw-r--r--x11/polybar/distinfo6
-rw-r--r--x11/polybar/files/patch-lib_xpp_CMakeLists.txt6
3 files changed, 9 insertions, 9 deletions
diff --git a/x11/polybar/Makefile b/x11/polybar/Makefile
index d7324b620825..5afbd049de31 100644
--- a/x11/polybar/Makefile
+++ b/x11/polybar/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= polybar
-DISTVERSION= 3.4.0
+DISTVERSION= 3.4.1
CATEGORIES= x11
MASTER_SITES= https://github.com/polybar/polybar/releases/download/${DISTVERSION}/
@@ -23,12 +23,12 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
# compiler:c++11-lang is needed for powerpc64
USES= cmake compiler:c++11-lang gnome localbase:ldflags \
- pkgconfig python:2.7,build tar
+ pkgconfig python:3.5+,build tar xorg
USE_GNOME= cairo
USE_XORG= xcb
-# Needs libnl to work. Disabling completely.
+# Needs libnl to work. Disabling it completely.
CMAKE_OFF= ENABLE_NETWORK
OPTIONS_DEFINE= ALSA CURSOR DEBUG GITHUB I3 IPC MPD PULSEAUDIO \
diff --git a/x11/polybar/distinfo b/x11/polybar/distinfo
index 4835bcf6ca26..1349cb94efa9 100644
--- a/x11/polybar/distinfo
+++ b/x11/polybar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1564027994
-SHA256 (polybar-3.4.0.tar) = 69a098f22d7a72eb594030aff687801252b18520b097c12f5c7894a99c4bcd1b
-SIZE (polybar-3.4.0.tar) = 2713600
+TIMESTAMP = 1572450750
+SHA256 (polybar-3.4.1.tar) = 9e37fa48a1027881f14546f2b4f6ace4c91d09a20a293685f845da9cbaedc4eb
+SIZE (polybar-3.4.1.tar) = 2713600
diff --git a/x11/polybar/files/patch-lib_xpp_CMakeLists.txt b/x11/polybar/files/patch-lib_xpp_CMakeLists.txt
index e7aa9fc62e69..2347106fa1d9 100644
--- a/x11/polybar/files/patch-lib_xpp_CMakeLists.txt
+++ b/x11/polybar/files/patch-lib_xpp_CMakeLists.txt
@@ -1,11 +1,11 @@
---- lib/xpp/CMakeLists.txt.orig 2019-07-25 04:34:56 UTC
+--- lib/xpp/CMakeLists.txt.orig 2019-10-30 15:57:14 UTC
+++ lib/xpp/CMakeLists.txt
@@ -48,7 +48,7 @@ set(XPP_LIBRARIES
#
# Loop through a hardcoded list of python executables to locate the python module "xcbgen"
#
--foreach(CURRENT_EXECUTABLE python2 python2.7 python3 python)
-+foreach(CURRENT_EXECUTABLE python2 python2.7 python3 python3.5 python3.6 python3.7 python)
+-foreach(CURRENT_EXECUTABLE python python3 python2 python2.7)
++foreach(CURRENT_EXECUTABLE python python3 python3.5 python3.6 python3.7 python2 python2.7)
message(STATUS "Searching for xcbgen with " ${CURRENT_EXECUTABLE})
execute_process(COMMAND "${CURRENT_EXECUTABLE}" "-c"