aboutsummaryrefslogtreecommitdiff
path: root/x11/qt5-qev
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-01-25 20:19:38 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-01-25 20:19:38 +0000
commit93eea426e87f4ad07ba7751dea5dbff00744b015 (patch)
treea930492ad4894bbd691e092a984bbf3558e1feb8 /x11/qt5-qev
parentcf769d83efdb558f7179371d422b9a4f723b9697 (diff)
downloadports-93eea426e87f4ad07ba7751dea5dbff00744b015.tar.gz
ports-93eea426e87f4ad07ba7751dea5dbff00744b015.zip
misc/qtchooser: do not create unnecessary wrappers
misc/qtchooser provides a wrapper binary bin/qtchooser, that when called with name foo, will lauch the corresponding binary from lib/qt${current_qt_version}/bin/foo. Previously qtchooser would install a list of 30-ish symlinks to itself automatically. Now we switch this around. qt-dist ports that define QT_BINARIES will now have a @postexec and @postunexec entry added to their plist to run the shell-script update-qtchooser-wrapper (installed by qtchooser). update-qtchooser-wrapper removes all symlinks to bin/qtcreator that have no corresponding binary in lib/qt*/bin, and readds links that are missing. Exp-run by: antoine PR: 242905 PR: 243443 Reported by: grarpamp@gmail.com Reviewed by: adridg Differential Revision: https://reviews.freebsd.org/D22991
Notes
Notes: svn path=/head/; revision=524129
Diffstat (limited to 'x11/qt5-qev')
-rw-r--r--x11/qt5-qev/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/x11/qt5-qev/Makefile b/x11/qt5-qev/Makefile
index 4ef012577306..347d1d6e2198 100644
--- a/x11/qt5-qev/Makefile
+++ b/x11/qt5-qev/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qev
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= x11
PKGNAMEPREFIX= qt5-
@@ -13,6 +14,8 @@ USE_QT= core widgets
WRKSRC_SUBDIR= src/${PORTNAME}
+QT_BINARIES= yes
+
# qev is not connected to qttool's build system, so we cannot just run qmake qt-dist:5,tools
# and set {BUILD,INSTALL}_WRKSRC.
# Instead, we run qmake qt-dist:5,tools from src/${PORTNAME} but need to copy .qmake qt-dist:5,tools.conf to