aboutsummaryrefslogtreecommitdiff
path: root/x11/rofi-pass
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-02-27 04:07:11 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-02-27 04:07:11 +0000
commit6d32c6e7cc9581e8e070ae11d5c784289ed192aa (patch)
tree00aa0f04961f69092e9107fdde79d96c8851c28f /x11/rofi-pass
parent9c8f6c40ca76e82c0dadda46ce906dcb72354b8e (diff)
downloadports-6d32c6e7cc9581e8e070ae11d5c784289ed192aa.tar.gz
ports-6d32c6e7cc9581e8e070ae11d5c784289ed192aa.zip
New port: x11/rofi-pass
A bash script to handle Simple Password Store in a convenient way using rofi. Features: - Open URLs of entries with hotkey - Add new Entries to Password Storage - Edit existing Entries - Generate new passwords for entries - Inline view, which can copy/type individual entries - Move/Delete existing entries - Type any field from entry - Auto-typing of user and/or password fields - Generating OTPs WWW: https://github.com/carnager/rofi-pass PR: 235114 Submitted by: alex@xanderio.de
Notes
Notes: svn path=/head/; revision=494017
Diffstat (limited to 'x11/rofi-pass')
-rw-r--r--x11/rofi-pass/Makefile45
-rw-r--r--x11/rofi-pass/distinfo3
-rw-r--r--x11/rofi-pass/pkg-descr15
3 files changed, 63 insertions, 0 deletions
diff --git a/x11/rofi-pass/Makefile b/x11/rofi-pass/Makefile
new file mode 100644
index 000000000000..1dc99351af38
--- /dev/null
+++ b/x11/rofi-pass/Makefile
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+PORTNAME= rofi-pass
+DISTVERSION= 2.0.2
+CATEGORIES= x11
+
+MAINTAINER= alex@xanderio.de
+COMMENT= Rofi frontend for pass
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+xRUN_DEPENDS= bash:shells/bash \
+ gawk:lang/gawk \
+ ${LOCALBASE}/bin/grep:textproc/gnugrep \
+ pass:sysutils/password-store \
+ pwgen:sysutils/pwgen \
+ qrencode:graphics/libqrencode \
+ rofi:x11/rofi \
+ xdotool:x11/xdotool
+
+USE_GITHUB= yes
+GH_ACCOUNT= carnager
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/addpass \
+ bin/rofi-pass \
+ "@sample etc/rofi-pass.conf.sample"
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/addpass ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/rofi-pass ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/config.example \
+ ${STAGEDIR}${PREFIX}/etc/rofi-pass.conf.sample
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11/rofi-pass/distinfo b/x11/rofi-pass/distinfo
new file mode 100644
index 000000000000..1e97246438b0
--- /dev/null
+++ b/x11/rofi-pass/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1550147378
+SHA256 (carnager-rofi-pass-2.0.2_GH0.tar.gz) = 6ba8d08c39d8df671ce37f272bd05b0926365d3512f5037dab699b462015b22d
+SIZE (carnager-rofi-pass-2.0.2_GH0.tar.gz) = 58897
diff --git a/x11/rofi-pass/pkg-descr b/x11/rofi-pass/pkg-descr
new file mode 100644
index 000000000000..aa586e8959a0
--- /dev/null
+++ b/x11/rofi-pass/pkg-descr
@@ -0,0 +1,15 @@
+A bash script to handle Simple Password Store in a convenient way
+using rofi.
+
+Features:
+- Open URLs of entries with hotkey
+- Add new Entries to Password Storage
+- Edit existing Entries
+- Generate new passwords for entries
+- Inline view, which can copy/type individual entries
+- Move/Delete existing entries
+- Type any field from entry
+- Auto-typing of user and/or password fields
+- Generating OTPs
+
+WWW: https://github.com/carnager/rofi-pass