aboutsummaryrefslogtreecommitdiff
path: root/x11/setlayout
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-19 00:31:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-19 00:31:17 +0000
commitbcec4fa2a15ea05a63a42e82ae87b1479411d48f (patch)
tree8cd2a3dbc372518b394677fb4995d41e3b9a0039 /x11/setlayout
parentd4f17c6e1a9a4af46bc40cefe30f13c2ccbbd37a (diff)
downloadports-bcec4fa2a15ea05a63a42e82ae87b1479411d48f.tar.gz
ports-bcec4fa2a15ea05a63a42e82ae87b1479411d48f.zip
setlayout is a small program that arranges desktops in an MxN grid.
It should work with any EWHM-compliant window manager, such as Openbox. Example usage: setlayout 0 2 2 0 for a 2x2 grid. WWW: http://icculus.org/openbox/index.php PR: ports/118804 Submitted by: oleg at bsdpower.com
Notes
Notes: svn path=/head/; revision=204065
Diffstat (limited to 'x11/setlayout')
-rw-r--r--x11/setlayout/Makefile34
-rw-r--r--x11/setlayout/distinfo3
-rw-r--r--x11/setlayout/pkg-descr6
3 files changed, 43 insertions, 0 deletions
diff --git a/x11/setlayout/Makefile b/x11/setlayout/Makefile
new file mode 100644
index 000000000000..3dba56db0887
--- /dev/null
+++ b/x11/setlayout/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: setlayout
+# Date created: 17 December 2007
+# Whom: oleg@bsdpower.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= setlayout
+DISTVERSION= 20071217
+CATEGORIES= x11
+MASTER_SITES= http://icculus.org/openbox/tools/
+DISTFILES= ${PORTNAME}.c
+EXTRACT_ONLY= #none
+
+MAINTAINER= oleg@bsdpower.com
+COMMENT= Arrange desktops in an MxN grid layout
+
+USE_XORG= x11
+NO_WRKSUBDIR= yes
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -o ${PORTNAME} -I ${PREFIX}/include -L ${PREFIX}/lib -lX11 ${DISTFILES}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/x11/setlayout/distinfo b/x11/setlayout/distinfo
new file mode 100644
index 000000000000..77dbe717a2d0
--- /dev/null
+++ b/x11/setlayout/distinfo
@@ -0,0 +1,3 @@
+MD5 (setlayout.c) = 76f263e1550532ae54fd53c3a49b2c71
+SHA256 (setlayout.c) = fd0b488babad5a3e81f0dae2e28b2f9caf39bc7654455988c59638067ac5062e
+SIZE (setlayout.c) = 1374
diff --git a/x11/setlayout/pkg-descr b/x11/setlayout/pkg-descr
new file mode 100644
index 000000000000..2e9667913e0f
--- /dev/null
+++ b/x11/setlayout/pkg-descr
@@ -0,0 +1,6 @@
+setlayout is a small program that arranges desktops in an MxN grid.
+It should work with any EWHM-compliant window manager, such as Openbox.
+
+Example usage: setlayout 0 2 2 0 for a 2x2 grid.
+
+WWW: http://icculus.org/openbox/index.php