aboutsummaryrefslogtreecommitdiff
path: root/x11/simdock
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-05 12:19:31 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-05 12:19:31 +0000
commit8f21ab977f3e6aa0eef5b3ed2147826d7e2bc166 (patch)
tree9b735ae9e2a95908fc5008cb6b3d5aa0a98904ee /x11/simdock
parent62c19f0d877c2c5d70a795d8836a0548a509102e (diff)
downloadports-8f21ab977f3e6aa0eef5b3ed2147826d7e2bc166.tar.gz
ports-8f21ab977f3e6aa0eef5b3ed2147826d7e2bc166.zip
- Stage support
- Add LICENSE - Use desktop-file-utils - Add missing OPTIONS_DEFINE
Notes
Notes: svn path=/head/; revision=338753
Diffstat (limited to 'x11/simdock')
-rw-r--r--x11/simdock/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/x11/simdock/Makefile b/x11/simdock/Makefile
index 7a3ba8d8afc3..717646e8b8ec 100644
--- a/x11/simdock/Makefile
+++ b/x11/simdock/Makefile
@@ -11,17 +11,20 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Fast and customizable dockbar
+LICENSE= GPLv2
+
GNU_CONFIGURE= yes
-USES= pathfix pkgconfig
+USES= desktop-file-utils pathfix pkgconfig
USE_GNOME= gnomeprefix gconf2 libwnck
USE_WX= 2.8
WX_CONF_ARGS= absolute
WRKSRC= ${WRKDIR}/trunk
-PORTDOCS= AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README TODO
+PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README TODO
+
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -34,10 +37,8 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
-.for doc in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
-.endfor
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>