aboutsummaryrefslogtreecommitdiff
path: root/x11/sprop/Makefile
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2021-01-20 05:37:25 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-01-20 05:37:25 +0000
commit2c5df0dedae047871a05b2aa99106b3f37158317 (patch)
tree2074c8d820fc78e91502f4073dbd46163986c6fb /x11/sprop/Makefile
parente2b2e6c65c43a2342847721ece41369df918fac9 (diff)
downloadports-2c5df0dedae047871a05b2aa99106b3f37158317.tar.gz
ports-2c5df0dedae047871a05b2aa99106b3f37158317.zip
Notes
Diffstat (limited to 'x11/sprop/Makefile')
-rw-r--r--x11/sprop/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/x11/sprop/Makefile b/x11/sprop/Makefile
new file mode 100644
index 000000000000..ce18aa968d91
--- /dev/null
+++ b/x11/sprop/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= sprop
+PORTVERSION= 0.1
+CATEGORIES= x11
+MASTER_SITES= https://dl.suckless.org/tools/
+
+MAINTAINER= kfv@kfv.io
+COMMENT= Simple X property utility
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= xorg
+USE_XORG= x11
+
+MAKE_ARGS= PREFIX="${PREFIX}" X11LIB="${LOCALBASE}/lib" \
+ X11INC="${LOCALBASE}/include" CC="${CC}"
+PLIST_FILES= bin/${PORTNAME} share/man/man1/${PORTNAME}.1.gz
+
+.include <bsd.port.mk>