aboutsummaryrefslogtreecommitdiff
path: root/x11/squeekboard
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-12-01 09:04:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-12-01 09:04:43 +0000
commit817be5f311161dd5ed6ac0ffed874f41b69e9daf (patch)
treea137d3ea228b70e3ce3322b7dccb0926d1f9097a /x11/squeekboard
parent2c40e87890c3e453e3972924a95b24919e56be76 (diff)
downloadports-817be5f311161dd5ed6ac0ffed874f41b69e9daf.tar.gz
ports-817be5f311161dd5ed6ac0ffed874f41b69e9daf.zip
x11/squeekboard: drop CARGO_ENV hack
All cargo variables are prefixed, and USES=meson already passes environ(7) to ninja. No need to exclude variables anymore as cargo.sh adjusts cargo variables for meson to find build artifacts. Idea from: games/jaggedalliance2
Notes
Notes: svn path=/head/; revision=518762
Diffstat (limited to 'x11/squeekboard')
-rw-r--r--x11/squeekboard/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11/squeekboard/Makefile b/x11/squeekboard/Makefile
index 6618f37e9e5e..5be7ffc742e8 100644
--- a/x11/squeekboard/Makefile
+++ b/x11/squeekboard/Makefile
@@ -25,7 +25,7 @@ USE_GNOME= cairo gdkpixbuf2 gtk30
GL_SITE= https://source.puri.sm
GL_ACCOUNT= Librem5
GL_COMMIT= 579ba8ab87f395c550eede40922b498feb245300
-MAKE_ENV= CARGO_ENV='${CARGO_ENV:N*TARGET_DIR*}'
+MAKE_ENV= ${CARGO_ENV}
PLIST_FILES= bin/${PORTNAME} \
bin/${PORTNAME}-real \
share/applications/sm.puri.Squeekboard.desktop
@@ -83,7 +83,7 @@ post-patch:
# Add --verbose after each cargo subcommand
# Don't use BSD realpath(1) against non-existing files
@${REINPLACE_CMD} -e '/^cargo/ { \
- s,^,cmd=$$1; shift; eval export $$CARGO_ENV; ,; \
+ s,^,cmd=$$1; shift; ,; \
s,"$$@","$$cmd" --verbose &,; }' \
-e '/OUT_PATH=/s,=.*,=$$PWD/$$1,' \
${WRKSRC}/cargo*.sh