aboutsummaryrefslogtreecommitdiff
path: root/x11/squeekboard
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-12-01 08:19:02 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-12-01 08:19:02 +0000
commitf49f941f137d4a5b58c3e7ed3574e89081be3dea (patch)
treea3b2b0f6a70f77f08f77afe322ef3e3429fc0af7 /x11/squeekboard
parent4cf3c02d47670237f595c9824d12a0697621cbbe (diff)
downloadports-f49f941f137d4a5b58c3e7ed3574e89081be3dea.tar.gz
ports-f49f941f137d4a5b58c3e7ed3574e89081be3dea.zip
x11/squeekboard: unbreak if LDFLAGS contain comma
$ LDFLAGS=-Wl,--as-needed make [...] sed: 1: "/^cargo/ { s,^,cmd=$1; ...": bad flag in substitute command: '-'
Notes
Notes: svn path=/head/; revision=518756
Diffstat (limited to 'x11/squeekboard')
-rw-r--r--x11/squeekboard/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/x11/squeekboard/Makefile b/x11/squeekboard/Makefile
index ec7dbefb1201..deab90328dcf 100644
--- a/x11/squeekboard/Makefile
+++ b/x11/squeekboard/Makefile
@@ -25,6 +25,7 @@ USE_GNOME= cairo gdkpixbuf2 gtk30
GL_SITE= https://source.puri.sm
GL_ACCOUNT= Librem5
GL_COMMIT= 579ba8ab87f395c550eede40922b498feb245300
+MAKE_ENV= CARGO_ENV='${CARGO_ENV:N*TARGET_DIR*}'
PLIST_FILES= bin/${PORTNAME} \
bin/${PORTNAME}-real \
share/applications/sm.puri.Squeekboard.desktop
@@ -79,7 +80,7 @@ post-patch:
# Add --verbose after each cargo subcommand
# Don't use BSD realpath(1) against non-existing files
@${REINPLACE_CMD} -e '/^cargo/ { \
- s,^,cmd=$$1;shift;${CARGO_ENV:N*TARGET_DIR*} ,; \
+ s,^,cmd=$$1; shift; eval export $${CARGO_ENV}; ,; \
s,"$$@","$$cmd" --verbose &,; }' \
-e '/OUT_PATH=/s,=.*,=$$PWD/$$1,' \
${WRKSRC}/cargo*.sh