aboutsummaryrefslogtreecommitdiff
path: root/x11/sselp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-19 13:51:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-19 13:51:22 +0000
commit9d6e501ed870cdb6fde158efe01fcbd3dcd6e14b (patch)
treed49b7782a8b464bf98dd7e78493a68f311a836e7 /x11/sselp
parent2ce9abb5cdd9f36061e5e32f7b9210a8443862b3 (diff)
downloadports-9d6e501ed870cdb6fde158efe01fcbd3dcd6e14b.tar.gz
ports-9d6e501ed870cdb6fde158efe01fcbd3dcd6e14b.zip
Simple X selection printer. Prints the X selection to stdout.
If there is no X client owning the selection it just exits. Useful for scripts where you can query the X selection without pressing mouse Button2 in cumbersome ways. WWW: http://www.suckless.org/programs/sselp.html PR: ports/125770 Submitted by: Julien Laffaye <kimelto at gmail.com>
Notes
Notes: svn path=/head/; revision=217092
Diffstat (limited to 'x11/sselp')
-rw-r--r--x11/sselp/Makefile21
-rw-r--r--x11/sselp/distinfo3
-rw-r--r--x11/sselp/files/patch-config.mk32
-rw-r--r--x11/sselp/pkg-descr6
4 files changed, 62 insertions, 0 deletions
diff --git a/x11/sselp/Makefile b/x11/sselp/Makefile
new file mode 100644
index 000000000000..4ea16fec73a6
--- /dev/null
+++ b/x11/sselp/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: sselp
+# Date created: July 19, 2008
+# Whom: Julien Laffaye <kimelto@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sselp
+PORTVERSION= 0.1
+CATEGORIES= x11
+MASTER_SITES= http://code.suckless.org/dl/tools/ \
+ http://laffaye.free.fr/distfiles/
+
+MAINTAINER= kimelto@gmail.com
+COMMENT= Simple SELection Printer for X11
+
+USE_XORG= x11
+
+PLIST_FILES= bin/sselp
+
+.include <bsd.port.mk>
diff --git a/x11/sselp/distinfo b/x11/sselp/distinfo
new file mode 100644
index 000000000000..9a5b6fb27b9f
--- /dev/null
+++ b/x11/sselp/distinfo
@@ -0,0 +1,3 @@
+MD5 (sselp-0.1.tar.gz) = 5c0c98469fbf21649eb13e5ff878dafb
+SHA256 (sselp-0.1.tar.gz) = 8f25b8d5cd62929618b8ba56d36f6d6556e4de1d1952f77aa160e087d3d79899
+SIZE (sselp-0.1.tar.gz) = 2694
diff --git a/x11/sselp/files/patch-config.mk b/x11/sselp/files/patch-config.mk
new file mode 100644
index 000000000000..296254590221
--- /dev/null
+++ b/x11/sselp/files/patch-config.mk
@@ -0,0 +1,32 @@
+--- config.mk.orig 2008-07-19 13:20:31.000000000 +0200
++++ config.mk 2008-07-19 14:18:14.000000000 +0200
+@@ -4,22 +4,22 @@
+ # Customize below to fit your system
+
+ # paths
+-PREFIX = /usr/local
+-MANPREFIX = ${PREFIX}/share/man
++PREFIX ?= /usr/local
++MANPREFIX = ${PREFIX}/man
+
+-X11INC = /usr/X11R6/include
+-X11LIB = /usr/X11R6/lib
++X11INC = $(LOCALBASE)/include
++X11LIB = $(LOCALBASE)/lib
+
+ # includes and libs
+ INCS = -I. -I/usr/include -I${X11INC}
+ LIBS = -L/usr/lib -lc -L${X11LIB} -lX11
+
+ # flags
+-CFLAGS = -Os ${INCS} -DVERSION=\"${VERSION}\"
+-LDFLAGS = ${LIBS}
++CFLAGS += -Os ${INCS} -DVERSION=\"${VERSION}\"
++LDFLAGS += ${LIBS}
+ #CFLAGS = -g -Wall -O2 ${INCS} -DVERSION=\"${VERSION}\"
+ #LDFLAGS = -g ${LIBS}
+
+ # compiler and linker
+-CC = cc
++CC ?= cc
+ LD = ${CC}
diff --git a/x11/sselp/pkg-descr b/x11/sselp/pkg-descr
new file mode 100644
index 000000000000..e3b74b00b4db
--- /dev/null
+++ b/x11/sselp/pkg-descr
@@ -0,0 +1,6 @@
+Simple X selection printer. Prints the X selection to stdout.
+If there is no X client owning the selection it just exits.
+Useful for scripts where you can query the X selection
+without pressing mouse Button2 in cumbersome ways.
+
+WWW: http://www.suckless.org/programs/sselp.html