aboutsummaryrefslogtreecommitdiff
path: root/x11/stalonetray/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-04-08 03:05:55 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-04-08 03:05:55 +0000
commit3b917d9d28a0c7283c0ed75ab9a946be53bac7a6 (patch)
treea4859b158285fe66aa4d0caff8c97b3189b79a76 /x11/stalonetray/Makefile
parent0864e90ae1c69fa65552e8fc0d530d973d34bc01 (diff)
downloadports-3b917d9d28a0c7283c0ed75ab9a946be53bac7a6.tar.gz
ports-3b917d9d28a0c7283c0ed75ab9a946be53bac7a6.zip
Notes
Diffstat (limited to 'x11/stalonetray/Makefile')
-rw-r--r--x11/stalonetray/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11/stalonetray/Makefile b/x11/stalonetray/Makefile
new file mode 100644
index 000000000000..0eb86a0ec9f3
--- /dev/null
+++ b/x11/stalonetray/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: stalonetray
+# Date created: Apr 6 2006
+# Whom: Stepan Zastupov [RedChrom] <redchrom@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= stalonetray
+PORTVERSION= 0.3
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= redchrom@gmail.com
+COMMENT= STAnd-aLONE system tray
+
+LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-native-kde --disable-debug
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lexecinfo"
+
+MAN1= stalonetray.1
+PLIST_FILES= bin/stalonetray
+
+.include <bsd.port.mk>