aboutsummaryrefslogtreecommitdiff
path: root/x11/sterm
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2024-01-11 10:30:34 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2024-01-11 10:31:03 +0000
commite762d0756bd3dd0ecf51d412559453d5031e6155 (patch)
treeb4ed160695aa96324a53e32132f7101421119453 /x11/sterm
parent8ab6cbe60e1954261f2129b24e32ed8ac147c9f6 (diff)
downloadports-e762d0756bd3dd0ecf51d412559453d5031e6155.tar.gz
ports-e762d0756bd3dd0ecf51d412559453d5031e6155.zip
MANPREFIX: eliminate the use of MANPREFIX for x11*
While here move some manpages to share/man
Diffstat (limited to 'x11/sterm')
-rw-r--r--x11/sterm/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/x11/sterm/Makefile b/x11/sterm/Makefile
index bce7879dd15c..39258d3cb42c 100644
--- a/x11/sterm/Makefile
+++ b/x11/sterm/Makefile
@@ -17,7 +17,9 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
USES= pkgconfig xorg
USE_XORG= x11 xext xft
-PLIST_FILES= bin/st man/man1/st.1.gz
+PLIST_FILES= bin/st share/man/man1/st.1.gz
+MAKE_ARGS= PREFIX="${PREFIX}" VERSION="${PORTVERSION}" \
+ X11INC="${LOCALBASE}/include" X11LIB="${LOCALBASE}/lib"
# This way we avoid running tic on st.info which does not work as expected.
BINARY_ALIAS= tic=true
@@ -45,12 +47,7 @@ post-patch:
@${ECHO_MSG} "creating config.h from ${ST_CONF}"
@${LN} -sf ${ST_CONF} ${WRKSRC}/config.h
.endif
- @${REINPLACE_CMD} -e 's|^VERSION = .*|VERSION = ${PORTVERSION}|' \
- -e 's|^PREFIX = .*|PREFIX = ${PREFIX}|' \
- -e "s|^MANPREFIX = .*|MANPREFIX = ${MANPREFIX}/man|" \
- -e "s|^X11INC = .*|X11INC = ${LOCALBASE}/include|" \
- -e "s|^X11LIB = .*|X11LIB = ${LOCALBASE}/lib|" \
- -e "s|^CPPFLAGS =|CPPFLAGS +=|" \
+ @${REINPLACE_CMD} -e "s|^CPPFLAGS =|CPPFLAGS +=|" \
${WRKSRC}/config.mk
post-install: