aboutsummaryrefslogtreecommitdiff
path: root/x11/swarp
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-05 12:55:36 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-05 12:55:36 +0000
commita47f41affe62f7c5f6ce2618634788a65ba318bf (patch)
treef576d674ef9a10d1cab73840fba066674a038567 /x11/swarp
parent63e06f38d3dbc1e19816c0e4d12c9efbe67c8aa3 (diff)
downloadports-a47f41affe62f7c5f6ce2618634788a65ba318bf.tar.gz
ports-a47f41affe62f7c5f6ce2618634788a65ba318bf.zip
- Stage support
- Add missing OPTIONS_DEFINE
Notes
Notes: svn path=/head/; revision=338761
Diffstat (limited to 'x11/swarp')
-rw-r--r--x11/swarp/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11/swarp/Makefile b/x11/swarp/Makefile
index 4ed0f9de8002..f8c8c9e1b916 100644
--- a/x11/swarp/Makefile
+++ b/x11/swarp/Makefile
@@ -22,7 +22,8 @@ MAKE_ARGS= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lX11" \
PORTDOCS= README
PLIST_FILES= bin/swarp
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
@@ -30,8 +31,8 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>