aboutsummaryrefslogtreecommitdiff
path: root/x11/swaylock
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-01-15 00:52:45 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-01-15 00:52:45 +0000
commiteb2e63135cdda78018bb4c7ce73c8d32e7f70861 (patch)
tree27175f62285d8c69e945559160c61184f69cdf3e /x11/swaylock
parent79cd352a718d48447eb09d4f08ba6d9ac91de55e (diff)
downloadports-eb2e63135cdda78018bb4c7ce73c8d32e7f70861.tar.gz
ports-eb2e63135cdda78018bb4c7ce73c8d32e7f70861.zip
x11-wm/sway: update to 1.0.b.2.189
The last beta is several months old, so use a snapshot to help users evaluate the current state. Changes: https://github.com/swaywm/sway/compare/1.0-beta.2...2573606b Changes: https://github.com/swaywm/wlroots/compare/0.2...10a2c4ed
Notes
Notes: svn path=/head/; revision=490329
Diffstat (limited to 'x11/swaylock')
-rw-r--r--x11/swaylock/Makefile38
-rw-r--r--x11/swaylock/distinfo3
-rw-r--r--x11/swaylock/pkg-descr9
3 files changed, 50 insertions, 0 deletions
diff --git a/x11/swaylock/Makefile b/x11/swaylock/Makefile
new file mode 100644
index 000000000000..5e89e018c45f
--- /dev/null
+++ b/x11/swaylock/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= swaylock
+DISTVERSION= 1.2
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Screen locker for Wayland
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>=1.14:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libwlroots.so:x11-toolkits/wlroots \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c11 meson pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= swaywm
+USE_GNOME= cairo gdkpixbuf2 pango
+MESON_ARGS= -Dsway-version="${DISTVERSIONFULL}"
+PLIST_FILES= bin/${PORTNAME} \
+ etc/pam.d/${PORTNAME} \
+ share/bash-completion/completions/${PORTNAME} \
+ share/fish/completions/${PORTNAME}.fish \
+ share/zsh/site-functions/_${PORTNAME}
+
+OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFAULT=MANPAGES
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
+
+post-patch-MANPAGES-off:
+ @${REINPLACE_CMD} -i '' "s/'scdoc/&-disabled/" ${WRKSRC}/meson.build
+
+.include <bsd.port.mk>
diff --git a/x11/swaylock/distinfo b/x11/swaylock/distinfo
new file mode 100644
index 000000000000..566a5122a8a4
--- /dev/null
+++ b/x11/swaylock/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1547513311
+SHA256 (swaywm-swaylock-1.2_GH0.tar.gz) = 211c77a40ff464651522c751838b04b4703b02c191e388d83d147a960e45c0c1
+SIZE (swaywm-swaylock-1.2_GH0.tar.gz) = 32594
diff --git a/x11/swaylock/pkg-descr b/x11/swaylock/pkg-descr
new file mode 100644
index 000000000000..892e256bfa6d
--- /dev/null
+++ b/x11/swaylock/pkg-descr
@@ -0,0 +1,9 @@
+swaylock is a screen locking utility for Wayland compositors. It is compatible
+with any Wayland compositor which implements the following Wayland protocols:
+
+- wlr-layer-shell
+- wlr-input-inhibitor
+- xdg-output
+- xdg-shell
+
+WWW: https://github.com/swaywm/swaylock