aboutsummaryrefslogtreecommitdiff
path: root/x11/temperature.app/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-20 19:18:18 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-20 19:18:18 +0000
commit0a7dddb50027579f23326b34f974895c27b6259b (patch)
tree4dfa941e70ceedf9af7cd0e06061aa310c0f8d35 /x11/temperature.app/Makefile
parent857927137f164b4a8124ef14b50caebcde0c6a75 (diff)
downloadports-0a7dddb50027579f23326b34f974895c27b6259b.tar.gz
ports-0a7dddb50027579f23326b34f974895c27b6259b.zip
Notes
Diffstat (limited to 'x11/temperature.app/Makefile')
-rw-r--r--x11/temperature.app/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/x11/temperature.app/Makefile b/x11/temperature.app/Makefile
index 24773927851e..6b51bedc46ff 100644
--- a/x11/temperature.app/Makefile
+++ b/x11/temperature.app/Makefile
@@ -11,21 +11,23 @@ DISTNAME= Temperature.app-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Dockable WindowMaker applet which displays the local temperature
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE= GPLv2 # (or later)
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+OPTIONS_DEFINE= DOCS
+
USE_XORG= x11 xpm
-NO_STAGE= yes
+PORTDOCS= README
+PLIST_FILES= bin/Temperature.app
+
.include <bsd.port.options.mk>
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/Temperature.app ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} Temperature.app \
+ ${STAGEDIR}${PREFIX}/bin)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} README ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>