aboutsummaryrefslogtreecommitdiff
path: root/x11/terminator
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2020-04-19 15:19:28 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2020-04-19 15:19:28 +0000
commit82cec660058f2f338335f4fbc840cefa90e61707 (patch)
treecaf8064b1fcf4b004e8943ed3ff66d2bfecbe56e /x11/terminator
parent843fc9cda8ae9f41e70c29778775c144a0651509 (diff)
downloadports-82cec660058f2f338335f4fbc840cefa90e61707.tar.gz
ports-82cec660058f2f338335f4fbc840cefa90e61707.zip
Re-add x11/terminator -- Multiple GNOME terminals in one window
This is Python3 port of Terminator. The original version of Terminator does not support Python3, yet. Once, the original supports Python3, this port will switch to the original.
Notes
Notes: svn path=/head/; revision=532123
Diffstat (limited to 'x11/terminator')
-rw-r--r--x11/terminator/Makefile26
-rw-r--r--x11/terminator/distinfo6
-rw-r--r--x11/terminator/files/patch-terminatorlib__notebook.py29
3 files changed, 45 insertions, 16 deletions
diff --git a/x11/terminator/Makefile b/x11/terminator/Makefile
index 319b3681e6fd..fee1c68c0182 100644
--- a/x11/terminator/Makefile
+++ b/x11/terminator/Makefile
@@ -2,38 +2,38 @@
# $FreeBSD$
PORTNAME= terminator
-PORTVERSION= 1.91
-PORTREVISION= 1
+PORTVERSION= 1.92
CATEGORIES= x11 python
-MASTER_SITES= http://launchpad.net/terminator/gtk3/${PORTVERSION}/+download/
+MASTER_SITES= https://bazaar.launchpad.net/~hellodeargrandma/terminator/python3/tarball/1852/
+DISTNAME= terminator-python3-bzr-r1852
-MAINTAINER= tom@hur.st
+MAINTAINER= ume@FreeBSD.org
COMMENT= Multiple GNOME terminals in one window
LICENSE= GPLv2
-DEPRECATED= Old, uses EOLed python27
-EXPIRATION_DATE= 2020-02-28
-
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}notify>=0:devel/py-notify@${PY_FLAVOR} \
- ${PYTHON_SITELIBDIR}/keybinder/_keybinder.so:x11/keybinder \
- ${PYTHON_PKGNAMEPREFIX}vte>=0:x11-toolkits/py-vte@${PY_FLAVOR} \
+RUN_DEPENDS= ${LOCALBASE}/lib/libkeybinder-3.0.so:x11/keybinder-gtk3 \
+ ${LOCALBASE}/lib/libnotify.so:devel/libnotify \
+ ${PYTHON_PKGNAMEPREFIX}configobj>0:devel/py-configobj@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}psutil>0:sysutils/py-psutil@${PY_FLAVOR}
-USES= gnome python:2.7 shebangfix
-USE_GNOME= pygobject3 intltool vte3
-USE_PYTHON= distutils
+USES= gnome python:3.5+ shebangfix
+USE_GNOME= intltool pygobject3 vte3
+USE_PYTHON= autoplist distutils
PYDISTUTILS_PKGNAME= Terminator
INSTALLS_ICONS= yes
SHEBANG_FILES= terminator.wrapper
+bash_CMD= ${SH}
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
NLS_USES= gettext
+WRKSRC= ${WRKDIR}/~hellodeargrandma/terminator/python3
+
.include <bsd.port.pre.mk>
.if !${PORT_OPTIONS:MNLS}
diff --git a/x11/terminator/distinfo b/x11/terminator/distinfo
index c6d2dfc41a4a..ff4420f322aa 100644
--- a/x11/terminator/distinfo
+++ b/x11/terminator/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1563965307
-SHA256 (terminator-1.91.tar.gz) = 95f76e3c0253956d19ceab2f8da709a496f1b9cf9b1c5b8d3cd0b6da3cc7be69
-SIZE (terminator-1.91.tar.gz) = 910536
+TIMESTAMP = 1587305888
+SHA256 (terminator-python3-bzr-r1852.tar.gz) = 223802142fb535a9174a0da50051eeb6fce153a6462c9992deba1c9ee15e3a12
+SIZE (terminator-python3-bzr-r1852.tar.gz) = 889301
diff --git a/x11/terminator/files/patch-terminatorlib__notebook.py b/x11/terminator/files/patch-terminatorlib__notebook.py
new file mode 100644
index 000000000000..ebd06307ec59
--- /dev/null
+++ b/x11/terminator/files/patch-terminatorlib__notebook.py
@@ -0,0 +1,29 @@
+--- terminatorlib/notebook.py.orig 2020-04-19 03:13:43 UTC
++++ terminatorlib/notebook.py
+@@ -77,17 +77,6 @@ class Notebook(Container, Gtk.Notebook):
+
+ def create_layout(self, layout):
+ """Apply layout configuration"""
+- def child_compare(a, b):
+- order_a = children[a]['order']
+- order_b = children[b]['order']
+-
+- if (order_a == order_b):
+- return 0
+- if (order_a < order_b):
+- return -1
+- if (order_a > order_b):
+- return 1
+-
+ if 'children' not in layout:
+ err('layout specifies no children: %s' % layout)
+ return
+@@ -100,7 +89,7 @@ class Notebook(Container, Gtk.Notebook):
+
+ num = 0
+ keys = list(children.keys())
+- keys.sort(child_compare)
++ keys.sort(key=lambda x: children[x]['order'])
+
+ for child_key in keys:
+ child = children[child_key]