aboutsummaryrefslogtreecommitdiff
path: root/x11/tilda
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2019-06-20 08:19:04 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2019-06-20 08:19:04 +0000
commita0eaf18675dfa7e45fa1025cc1980f5828ccfe71 (patch)
treeb3016fabe1e5785fed21291a8d4c7c003d2bf337 /x11/tilda
parent4dc3414ec7eb4ceee6af7406d4a4b78b778bf772 (diff)
downloadports-a0eaf18675dfa7e45fa1025cc1980f5828ccfe71.tar.gz
ports-a0eaf18675dfa7e45fa1025cc1980f5828ccfe71.zip
use dirent.h instead of deprecated sys/dir.h
tilda currently includes sys/dir.h, but this header is scheduled for removal. Its successor is dirent.h. Update this port accordingly. Poudriere build run with Freebsd 11 and 12 PR: 238695 Submitted by: rene
Notes
Notes: svn path=/head/; revision=504621
Diffstat (limited to 'x11/tilda')
-rw-r--r--x11/tilda/Makefile2
-rw-r--r--x11/tilda/files/patch-tilda.c15
2 files changed, 13 insertions, 4 deletions
diff --git a/x11/tilda/Makefile b/x11/tilda/Makefile
index 40d5d26934ff..190730582925 100644
--- a/x11/tilda/Makefile
+++ b/x11/tilda/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tilda
PORTVERSION= 1.4.1
DISTVERSIONPREFIX= ${PORTNAME}-
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MAINTAINER= rodrigo@FreeBSD.org
diff --git a/x11/tilda/files/patch-tilda.c b/x11/tilda/files/patch-tilda.c
index c215f05d14d5..8589d9f64076 100644
--- a/x11/tilda/files/patch-tilda.c
+++ b/x11/tilda/files/patch-tilda.c
@@ -1,5 +1,5 @@
---- src/tilda.c.orig 2017-09-08 22:19:35.318278000 +0300
-+++ src/tilda.c 2017-09-08 22:21:22.752550000 +0300
+--- src/tilda.c.orig 2018-02-08 19:55:42 UTC
++++ src/tilda.c
@@ -12,6 +12,7 @@
* You should have received a copy of the GNU Library General Public
* License along with this library. If not, see <http://www.gnu.org/licenses/>.
@@ -8,7 +8,16 @@
#define _POSIX_SOURCE /* feature test macro for signal functions */
#define _XOPEN_SOURCE /* feature test macro for popen */
-@@ -230,7 +231,7 @@
+@@ -52,7 +53,7 @@
+ #include <sys/stat.h>
+ #include <sys/file.h>
+ #include <errno.h>
+-#include <sys/dir.h>
++#include <dirent.h>
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <string.h>
+@@ -230,7 +231,7 @@ nomatch:
static GSList *getPids() {
GSList *pids = NULL;
FILE *ps_output;