aboutsummaryrefslogtreecommitdiff
path: root/x11/tint
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-08-07 19:12:30 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-08-07 19:12:30 +0000
commit4f3b88b748dce4c98105abb2adc8766790f1924a (patch)
tree4e257955024bef00e04fe701dc37669b2b17890a /x11/tint
parent4f5435a9c4a0724a713a1dc00d2162ef9ce5d18c (diff)
downloadports-4f3b88b748dce4c98105abb2adc8766790f1924a.tar.gz
ports-4f3b88b748dce4c98105abb2adc8766790f1924a.zip
- Update to 0.12.1
- Use new mirror - Adjust dependencies - Rewrite options helper (remove DOCS and PYCONF options) - Update WWW entry (pkg-descr), project is now hosted on GitLab.com PR: 202137 Submitted by: myself Approved by: yamagi (maintainer)
Notes
Notes: svn path=/head/; revision=393700
Diffstat (limited to 'x11/tint')
-rw-r--r--x11/tint/Makefile64
-rw-r--r--x11/tint/distinfo4
-rw-r--r--x11/tint/files/patch-CMakeLists.txt11
-rw-r--r--x11/tint/files/patch-src-battery-battery.c144
-rw-r--r--x11/tint/pkg-descr2
-rw-r--r--x11/tint/pkg-plist43
6 files changed, 63 insertions, 205 deletions
diff --git a/x11/tint/Makefile b/x11/tint/Makefile
index e84b9b467ed5..770f220e9e14 100644
--- a/x11/tint/Makefile
+++ b/x11/tint/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= tint2
-PORTVERSION= 0.11
-PORTREVISION= 4
+PORTVERSION= 0.12.1
CATEGORIES= x11
-MASTER_SITES= GOOGLE_CODE
+MASTER_SITES= http://leigh123linux.fedorapeople.org/pub/${PORTNAME}/source/
MAINTAINER= yamagi@yamagi.org
COMMENT= Lightweight freedesktop-compliant panel/taskbar/systray/clock
@@ -12,59 +11,18 @@ COMMENT= Lightweight freedesktop-compliant panel/taskbar/systray/clock
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
- libImlib2.so:${PORTSDIR}/graphics/imlib2
+LIB_DEPENDS= libImlib2.so:${PORTSDIR}/graphics/imlib2 \
+ libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
-PROJECTHOST= tint2
-USES= alias cmake pkgconfig tar:bzip2
-USE_GNOME= glib20 pango
-USE_XORG= xdamage xcomposite xinerama xrandr
+USES= alias cmake gettext pkgconfig
+USE_GNOME= glib20 librsvg2 pango
+USE_XORG= x11 xcomposite xdamage xinerama xrandr xrender
-CMAKE_ARGS= -DENABLE_BATTERY:BOOL=ON -DMANDIR:PATH=man
+CMAKE_ARGS= -DMANDIR:PATH=man
-OPTIONS_DEFINE= DOCS EXAMPLES PYCONF
-OPTIONS_DEFAULT= PYCONF
+OPTIONS_DEFINE= EXAMPLES
+EXAMPLES_CMAKE_ON= -DENABLE_EXAMPLES:BOOL=ON
+EXAMPLES_CMAKE_OFF= -DENABLE_EXAMPLES:BOOL=OFF
OPTIONS_SUB= yes
-PYCONF_DESC= Configuration editing tool (requires python)
-
-PORTEXAMPLES= icon_and_text_1.tint2rc icon_and_text_2.tint2rc \
- icon_and_text_3.tint2rc icon_and_text_4.tint2rc \
- icon_only_1.tint2rc icon_only_2.tint2rc icon_only_3.tint2rc \
- icon_only_4.tint2rc icon_only_6.tint2rc icon_only_7.tint2rc \
- text_only_1.tint2rc text_only_2.tint2rc text_only_3.tint2rc \
- text_only_4.tint2rc text_only_5.tint2rc text_only_6.tint2rc tint2rc
-PORTDOCS= AUTHORS ChangeLog README
-
-PYCONF_USES= python
-PYCONF_USE= gnome=gtk20,pygtk2
-PYCONF_CMAKE_ON= -DENABLE_TINT2CONF:BOOL=ON
-PYCONF_CMAKE_OFF= -DENABLE_TINT2CONF:BOOL=OFF
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPYCONF}
-PYCONF_SRC= ${WRKSRC}/src/tint2conf
-post-patch:
- @${MV} ${PYCONF_SRC}/tintwizard.py ${PYCONF_SRC}/tintwizard.py.Dist
- @${SED} -e 's#pidof#pgrep#g' ${PYCONF_SRC}/tintwizard.py.Dist \
- > ${PYCONF_SRC}/tintwizard.py
-.endif
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/tint2 ${STAGEDIR}${PREFIX}/bin
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/tint2
- ${INSTALL_DATA} ${WRKSRC}/default_icon.png ${STAGEDIR}${PREFIX}/share/tint2
- ${INSTALL_MAN} ${WRKSRC}/doc/tint2.1 ${STAGEDIR}${MANPREFIX}/man/man1
-.if ${PORT_OPTIONS:MPYCONF}
- ${INSTALL_PROGRAM} ${PYCONF_SRC}/tint2conf ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_SCRIPT} ${PYCONF_SRC}/tintwizard.py ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${PYCONF_SRC}/tint2conf.desktop ${STAGEDIR}${PREFIX}/share/applications
- ${INSTALL_DATA} ${PYCONF_SRC}/tint2conf.png ${STAGEDIR}${PREFIX}/share/pixmaps
- ${INSTALL_DATA} ${PYCONF_SRC}/tint2conf.svg ${STAGEDIR}${PREFIX}/share/pixmaps
-.endif
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/sample/|} ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/x11/tint/distinfo b/x11/tint/distinfo
index 8b0dac0b8420..ed03131c649d 100644
--- a/x11/tint/distinfo
+++ b/x11/tint/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tint2-0.11.tar.bz2) = fe106e6a6057d2631abddde9f82d3fd4fb1985c4fb93f10d3886417a9e22471d
-SIZE (tint2-0.11.tar.bz2) = 91716
+SHA256 (tint2-0.12.1.tar.gz) = 5731394b812215f56441146d2a50dcf063efda0a19ccf51b3599ddbe07b14559
+SIZE (tint2-0.12.1.tar.gz) = 230228
diff --git a/x11/tint/files/patch-CMakeLists.txt b/x11/tint/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..00f4538f4b2a
--- /dev/null
+++ b/x11/tint/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2015-08-04 09:22:00 UTC
++++ CMakeLists.txt
+@@ -114,7 +114,7 @@ endif()
+
+ set( MANDIR share/man CACHE PATH "Directory for man pages" )
+ set( DATADIR share CACHE PATH "Directory for shared data" )
+-set( SYSCONFDIR /etc CACHE PATH "Directory for configuration files" )
++set( SYSCONFDIR etc CACHE PATH "Directory for configuration files" )
+ set( DOCDIR share/doc/tint2 CACHE PATH "Directory for documentation files" )
+
+ add_custom_target( version ALL "${PROJECT_SOURCE_DIR}/get_version.sh" "\"${PROJECT_SOURCE_DIR}\"" )
diff --git a/x11/tint/files/patch-src-battery-battery.c b/x11/tint/files/patch-src-battery-battery.c
deleted file mode 100644
index 2d850bcd69e8..000000000000
--- a/x11/tint/files/patch-src-battery-battery.c
+++ /dev/null
@@ -1,144 +0,0 @@
-Index: src/battery/battery.c
-===================================================================
---- src/battery/battery.c (Revision 514)
-+++ src/battery/battery.c (Revision 515)
-@@ -24,13 +24,18 @@
- #include <cairo-xlib.h>
- #include <pango/pangocairo.h>
-
--#if defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__)
-+#if defined(__OpenBSD__) || defined(__NetBSD__)
- #include <machine/apmvar.h>
- #include <err.h>
- #include <sys/ioctl.h>
- #include <unistd.h>
- #endif
-
-+#if defined(__FreeBSD__)
-+#include <sys/types.h>
-+#include <sys/sysctl.h>
-+#endif
-+
- #include "window.h"
- #include "server.h"
- #include "area.h"
-@@ -59,11 +64,10 @@
- char *path_current_now;
- char *path_status;
-
--#if defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__)
-+#if defined(__OpenBSD__) || defined(__NetBSD__)
- int apm_fd;
- #endif
-
--
- void update_batterys(void* arg)
- {
- int i;
-@@ -103,7 +107,7 @@
- path_energy_full = 0;
- path_current_now = 0;
- path_status = 0;
--#if defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__)
-+#if defined(__OpenBSD__) || defined(__NetBSD__)
- apm_fd = -1;
- #endif
- }
-@@ -118,7 +122,7 @@
- if (path_status) g_free(path_status);
- if (battery_low_cmd) g_free(battery_low_cmd);
-
--#if defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__)
-+#if defined(__OpenBSD__) || defined(__NetBSD__)
- if ((apm_fd != -1) && (close(apm_fd) == -1))
- warn("cannot close /dev/apm");
- #endif
-@@ -129,7 +133,7 @@
- {
- if (!battery_enabled) return;
-
--#if defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__)
-+#if defined(__OpenBSD__) || defined(__NetBSD__)
- apm_fd = open("/dev/apm", O_RDONLY);
- if (apm_fd < 0) {
- warn("init_battery: failed to open /dev/apm.");
-@@ -137,7 +141,7 @@
- return;
- }
-
--#else
-+#elif !defined(__FreeBSD__)
- // check battery
- GDir *directory = 0;
- GError *error = NULL;
-@@ -258,17 +262,21 @@
-
-
- void update_battery() {
--#if !defined(__OpenBSD__) && !defined(__FreeBSD__) && !defined(__NetBSD__)
-+#if !defined(__OpenBSD__) && !defined(__NetBSD__) && !defined(__FreeBSD__)
- // unused on OpenBSD, silence compiler warnings
- FILE *fp;
- char tmp[25];
- int64_t current_now = 0;
- #endif
-+#if defined(__FreeBSD__)
-+ int sysctl_out = 0;
-+ size_t len = 0;
-+#endif
- int64_t energy_now = 0, energy_full = 0;
- int seconds = 0;
- int8_t new_percentage = 0;
-
--#if defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__)
-+#if defined(__OpenBSD__) || defined(__NetBSD__)
- struct apm_power_info info;
- if (ioctl(apm_fd, APM_IOC_GETPOWER, &(info)) < 0)
- warn("power update: APM_IOC_GETPOWER");
-@@ -298,6 +306,45 @@
-
- new_percentage = info.battery_life;
-
-+#elif defined(__FreeBSD__)
-+ len = sizeof(sysctl_out);
-+
-+ if (sysctlbyname("hw.acpi.battery.state", &sysctl_out, &len, NULL, 0) != 0)
-+ fprintf(stderr, "power update: no such sysctl");
-+
-+ // attemp to map the battery state to linux
-+ battery_state.state = BATTERY_UNKNOWN;
-+
-+ switch(sysctl_out) {
-+ case 1:
-+ battery_state.state = BATTERY_DISCHARGING;
-+ break;
-+ case 2:
-+ battery_state.state = BATTERY_CHARGING;
-+ break;
-+ default:
-+ battery_state.state = BATTERY_FULL;
-+ break;
-+ }
-+
-+ // no mapping for freebsd
-+ energy_full = 0;
-+ energy_now = 0;
-+
-+ if (sysctlbyname("hw.acpi.battery.time", &sysctl_out, &len, NULL, 0) != 0)
-+ seconds = -1;
-+ else
-+ seconds = sysctl_out * 60;
-+
-+ // charging or error
-+ if (seconds < 0)
-+ seconds = 0;
-+
-+ if (sysctlbyname("hw.acpi.battery.life", &sysctl_out, &len, NULL, 0) != 0)
-+ new_percentage = -1;
-+ else
-+ new_percentage = sysctl_out;
-+
- #else
- fp = fopen(path_status, "r");
- if(fp != NULL) {
-
diff --git a/x11/tint/pkg-descr b/x11/tint/pkg-descr
index 51ddf3278daf..968552ef6a1c 100644
--- a/x11/tint/pkg-descr
+++ b/x11/tint/pkg-descr
@@ -13,4 +13,4 @@ Tint panel features
* clock with font, color and transparency
* multi-monitor : panel position adjust to monitor, taskbar by monitor
-WWW: http://code.google.com/p/tint2/
+WWW: https://gitlab.com/o9000/tint2
diff --git a/x11/tint/pkg-plist b/x11/tint/pkg-plist
index a9c377139e88..f4eb1f0e2a90 100644
--- a/x11/tint/pkg-plist
+++ b/x11/tint/pkg-plist
@@ -1,8 +1,41 @@
bin/tint2
+bin/tint2conf
+etc/xdg/tint2/tint2rc
man/man1/tint2.1.gz
+share/applications/tint2.desktop
+share/applications/tint2conf.desktop
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/ChangeLog
+%%DOCSDIR%%/README.md
+share/icons/hicolor/scalable/apps/tint2.svg
+share/icons/hicolor/scalable/apps/tint2conf.svg
+share/locale/bs/LC_MESSAGES/tint2conf.mo
+share/locale/fr/LC_MESSAGES/tint2conf.mo
+share/locale/hr/LC_MESSAGES/tint2conf.mo
+share/locale/pl/LC_MESSAGES/tint2conf.mo
+share/locale/sr/LC_MESSAGES/tint2conf.mo
%%DATADIR%%/default_icon.png
-%%PYCONF%%bin/tint2conf
-%%PYCONF%%bin/tintwizard.py
-%%PYCONF%%share/applications/tint2conf.desktop
-%%PYCONF%%share/pixmaps/tint2conf.png
-%%PYCONF%%share/pixmaps/tint2conf.svg
+%%EXAMPLES%%%%DATADIR%%/horizontal-dark-opaque.tint2rc
+%%EXAMPLES%%%%DATADIR%%/horizontal-dark-transparent.tint2rc
+%%EXAMPLES%%%%DATADIR%%/horizontal-light-opaque.tint2rc
+%%EXAMPLES%%%%DATADIR%%/horizontal-light-transparent.tint2rc
+%%EXAMPLES%%%%DATADIR%%/icon_and_text_1.tint2rc
+%%EXAMPLES%%%%DATADIR%%/icon_and_text_2.tint2rc
+%%EXAMPLES%%%%DATADIR%%/icon_and_text_3.tint2rc
+%%EXAMPLES%%%%DATADIR%%/icon_and_text_4.tint2rc
+%%EXAMPLES%%%%DATADIR%%/icon_only_1.tint2rc
+%%EXAMPLES%%%%DATADIR%%/icon_only_2.tint2rc
+%%EXAMPLES%%%%DATADIR%%/icon_only_3.tint2rc
+%%EXAMPLES%%%%DATADIR%%/icon_only_4.tint2rc
+%%EXAMPLES%%%%DATADIR%%/icon_only_6.tint2rc
+%%EXAMPLES%%%%DATADIR%%/icon_only_7.tint2rc
+%%EXAMPLES%%%%DATADIR%%/text_only_1.tint2rc
+%%EXAMPLES%%%%DATADIR%%/text_only_2.tint2rc
+%%EXAMPLES%%%%DATADIR%%/text_only_3.tint2rc
+%%EXAMPLES%%%%DATADIR%%/text_only_4.tint2rc
+%%EXAMPLES%%%%DATADIR%%/text_only_5.tint2rc
+%%EXAMPLES%%%%DATADIR%%/text_only_6.tint2rc
+%%EXAMPLES%%%%DATADIR%%/vertical-dark-opaque.tint2rc
+%%EXAMPLES%%%%DATADIR%%/vertical-dark-transparent.tint2rc
+%%EXAMPLES%%%%DATADIR%%/vertical-light-opaque.tint2rc
+%%EXAMPLES%%%%DATADIR%%/vertical-light-transparent.tint2rc