aboutsummaryrefslogtreecommitdiff
path: root/x11/wayland-logout
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-12-27 04:36:16 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-12-27 04:36:16 +0000
commit29d39e6fa242e29411fc08ec2f93ae3ca709df4d (patch)
treefa37884f4b173333432bf227438f2de06a529e33 /x11/wayland-logout
parente38dd037bc1ebbb51e6169b02cf95ea117687204 (diff)
downloadports-29d39e6fa242e29411fc08ec2f93ae3ca709df4d.tar.gz
ports-29d39e6fa242e29411fc08ec2f93ae3ca709df4d.zip
Notes
Diffstat (limited to 'x11/wayland-logout')
-rw-r--r--x11/wayland-logout/Makefile18
-rw-r--r--x11/wayland-logout/distinfo10
-rw-r--r--x11/wayland-logout/files/patch-wayland-logout.sh21
3 files changed, 17 insertions, 32 deletions
diff --git a/x11/wayland-logout/Makefile b/x11/wayland-logout/Makefile
index e5e67b1c669d..ebfa34885128 100644
--- a/x11/wayland-logout/Makefile
+++ b/x11/wayland-logout/Makefile
@@ -2,22 +2,24 @@
PORTNAME= wayland-logout
DISTVERSIONPREFIX= v
-DISTVERSION= 1.0
+DISTVERSION= 1.1
CATEGORIES= x11
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 6e0c13c8b198.patch:-p1 # https://github.com/soreau/wayland-logout/pull/6
+PATCHFILES+= 64eb1c3c9a4d.patch:-p1 # https://github.com/soreau/wayland-logout/pull/6
+
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Simple logout on Wayland
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+USES= meson
USE_GITHUB= yes
GH_ACCOUNT= soreau
-NO_ARCH= yes
-NO_BUILD= yes
-PLIST_FILES= bin/${PORTNAME}
-
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.sh \
- ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+MESON_ARGS= ${${OPSYS} == FreeBSD && ${OSREL:R} >= 13:?-Dimplementation=c:}
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
.include <bsd.port.mk>
diff --git a/x11/wayland-logout/distinfo b/x11/wayland-logout/distinfo
index 2b972d0bba7f..b3ebfc2d6bdf 100644
--- a/x11/wayland-logout/distinfo
+++ b/x11/wayland-logout/distinfo
@@ -1,3 +1,7 @@
-TIMESTAMP = 1599853712
-SHA256 (soreau-wayland-logout-v1.0_GH0.tar.gz) = 445eb9a978481871dbc51ea0e9cde57ca9f778eda55ecd8a5aac205a71e7f0e6
-SIZE (soreau-wayland-logout-v1.0_GH0.tar.gz) = 16663
+TIMESTAMP = 1607050775
+SHA256 (soreau-wayland-logout-v1.1_GH0.tar.gz) = 814765492340d52c3371f46a37f0ebae1225f2db686ff0eab57c9464b80d756f
+SIZE (soreau-wayland-logout-v1.1_GH0.tar.gz) = 17731
+SHA256 (6e0c13c8b198.patch) = e22a33f9b4b99e3450b7527fc6124c7ee1bca93f95ae89fbb56b6b4a404ed98d
+SIZE (6e0c13c8b198.patch) = 1110
+SHA256 (64eb1c3c9a4d.patch) = df379f6e150417facd1973bb2dbc435bb3212d8a2edc09277481cfc0a0f32d36
+SIZE (64eb1c3c9a4d.patch) = 818
diff --git a/x11/wayland-logout/files/patch-wayland-logout.sh b/x11/wayland-logout/files/patch-wayland-logout.sh
deleted file mode 100644
index 2b4ad6303c90..000000000000
--- a/x11/wayland-logout/files/patch-wayland-logout.sh
+++ /dev/null
@@ -1,21 +0,0 @@
-lsof is slow and not supported on DragonFly
-
---- wayland-logout.sh.orig 2020-09-11 19:48:32 UTC
-+++ wayland-logout.sh
-@@ -1,7 +1,5 @@
- #!/bin/sh
-
--# REQUIREMENTS - lsof (not always present)
--
- if [ -z "${WAYLAND_DISPLAY}" ]; then
- printf '%s\n' 'Error: WAYLAND_DISPLAY not set'
- exit 1
-@@ -21,7 +19,7 @@ case "${WAYLAND_DISPLAY}" in
- ;;
- esac
-
--WAYLAND_PIDS="$(lsof -t -f -- ${SOCKET_PATH})"
-+WAYLAND_PIDS="$(sockstat -lu | awk "\$6 == \"${SOCKET_PATH}\" { print \$3 }" | uniq)"
- set -- $WAYLAND_PIDS
- if [ $# -gt 1 ]; then
- printf '%s\n' 'Error: More than one process has been bound to the socket'