aboutsummaryrefslogtreecommitdiff
path: root/x11/wezterm
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-02-11 19:21:10 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-02-11 19:21:10 +0000
commit7254f522b11f9fecc380ad74731bac67250bd1fa (patch)
tree64a5601016d1617785907e3e21be7c0fb70e5a0d /x11/wezterm
parent7b297684fadef92a7b4e1c4487a398f0c3a9d72c (diff)
downloadports-7254f522b11f9fecc380ad74731bac67250bd1fa.tar.gz
ports-7254f522b11f9fecc380ad74731bac67250bd1fa.zip
x11/wezterm: simplify install
Replace fragile/ugly install workaround with CARGO_INSTALL_PATH. Before the port adopted USES=ssl by disabling vendor_openssl CARGO_INSTALL_PATH failed because USES=cargo tried to build during install phase.
Notes
Notes: svn path=/head/; revision=564975
Diffstat (limited to 'x11/wezterm')
-rw-r--r--x11/wezterm/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/x11/wezterm/Makefile b/x11/wezterm/Makefile
index 09c9ce92715c..b98ce0e44a21 100644
--- a/x11/wezterm/Makefile
+++ b/x11/wezterm/Makefile
@@ -488,6 +488,8 @@ CARGO_CRATES= ab_glyph_rasterizer-0.1.4 \
zstd-safe-3.0.0+zstd.1.4.8 \
zstd-sys-1.4.19+zstd.1.4.8
CARGO_USE_GITHUB= yes
+# XXX https://github.com/rust-lang/cargo/issues/4101
+CARGO_INSTALL_PATH= ${PLIST_FILES:Mbin/*:T}
pre-patch:
# Adjust whitespace for CARGO_USE_GITHUB regex
@@ -505,11 +507,7 @@ post-patch:
@${REINPLACE_CMD} -e 's/"python3"/"${PYTHON_CMD:T}"/' \
${WRKSRC}/cargo-crates/xcb-*/build.rs
-do-install:
-# XXX https://github.com/rust-lang/cargo/issues/4101
- ${INSTALL_PROGRAM} ${PLIST_FILES:Mbin/*:T:S,^,${CARGO_TARGET_DIR}/${\
- "${CARGO_BUILD_ARGS:M--release}":?release:debug}/,} \
- ${STAGEDIR}${PREFIX}/bin
+post-install:
# Install assets similar to ci/deploy.sh
.for f in ${PORTNAME}.desktop ${PORTNAME}.appdata.xml \
icon/terminal.png icon/${PORTNAME}-icon.svg shell-integration/${PORTNAME}.sh