aboutsummaryrefslogtreecommitdiff
path: root/x11/wf-shell
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-07-28 00:48:48 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-07-28 00:48:48 +0000
commitbfb3d70bbfcf89ba06069301ebe0bb52edf18471 (patch)
tree4f3ab1d5ab8e4dc4b6129c8130657b7a75692b02 /x11/wf-shell
parent23358c0c2dc1d768f0289018e894c28ca66ac5ad (diff)
downloadports-bfb3d70bbfcf89ba06069301ebe0bb52edf18471.tar.gz
ports-bfb3d70bbfcf89ba06069301ebe0bb52edf18471.zip
x11-wm/wayfire: add new port
Wayfire is a wayland compositor based on wlroots. It aims to create a customizable, extendable and lightweight environment without sacrificing its appearance. https://wayfire.org/
Notes
Notes: svn path=/head/; revision=507480
Diffstat (limited to 'x11/wf-shell')
-rw-r--r--x11/wf-shell/Makefile25
-rw-r--r--x11/wf-shell/distinfo3
-rw-r--r--x11/wf-shell/pkg-descr5
-rw-r--r--x11/wf-shell/pkg-plist4
4 files changed, 37 insertions, 0 deletions
diff --git a/x11/wf-shell/Makefile b/x11/wf-shell/Makefile
new file mode 100644
index 000000000000..edbe223dad56
--- /dev/null
+++ b/x11/wf-shell/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= wf-shell
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1-13
+DISTVERSIONSUFFIX= -gefe1fd4
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= GTK3-based panel for wayfire
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>0:graphics/wayland-protocols
+LIB_DEPENDS= libinotify.so:devel/libinotify \
+ libwf-config.so:devel/wf-config \
+ libwayland-client.so:graphics/wayland
+
+USES= compiler:c++11-lib meson pkgconfig
+USE_GITHUB= yes
+USE_GNOME= gtkmm30
+GH_ACCOUNT= WayfireWM
+
+.include <bsd.port.mk>
diff --git a/x11/wf-shell/distinfo b/x11/wf-shell/distinfo
new file mode 100644
index 000000000000..f398a65c258e
--- /dev/null
+++ b/x11/wf-shell/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1563441350
+SHA256 (WayfireWM-wf-shell-v0.1-13-gefe1fd4_GH0.tar.gz) = 64bd5975372a78c1832e44607bd080945760b18caecc857d388172d8d72d2f53
+SIZE (WayfireWM-wf-shell-v0.1-13-gefe1fd4_GH0.tar.gz) = 2969618
diff --git a/x11/wf-shell/pkg-descr b/x11/wf-shell/pkg-descr
new file mode 100644
index 000000000000..de2637bc8afe
--- /dev/null
+++ b/x11/wf-shell/pkg-descr
@@ -0,0 +1,5 @@
+wf-shell is a repository which contains the various components needed
+to built a fully functional DE based around wayfire. Currently it has
+only a GTK-based panel and background client.
+
+WWW: https://wayfire.org/
diff --git a/x11/wf-shell/pkg-plist b/x11/wf-shell/pkg-plist
new file mode 100644
index 000000000000..5e1e524bedb6
--- /dev/null
+++ b/x11/wf-shell/pkg-plist
@@ -0,0 +1,4 @@
+bin/wf-background
+bin/wf-dock
+bin/wf-panel
+share/wayfire/icons/wayfire.png