aboutsummaryrefslogtreecommitdiff
path: root/x11/wmcliphist
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-27 20:02:32 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-27 20:02:32 +0000
commit339579afc6ab19ff8410b1b5bde6c6e5056f234d (patch)
tree459946063a8065e3e0497a3c189b6b54363d1190 /x11/wmcliphist
parent8742cc12757754478414752f83fd02f1599f64a8 (diff)
downloadports-339579afc6ab19ff8410b1b5bde6c6e5056f234d.tar.gz
ports-339579afc6ab19ff8410b1b5bde6c6e5056f234d.zip
New port wmcliphist version 0.2, Clipboard history management
dockapp for Window Maker PR: 28745 Submitted by: Patrick Li <pat@databits.net>
Notes
Notes: svn path=/head/; revision=45545
Diffstat (limited to 'x11/wmcliphist')
-rw-r--r--x11/wmcliphist/Makefile27
-rw-r--r--x11/wmcliphist/distinfo1
-rw-r--r--x11/wmcliphist/files/patch-Makefile20
-rw-r--r--x11/wmcliphist/pkg-comment1
-rw-r--r--x11/wmcliphist/pkg-descr9
-rw-r--r--x11/wmcliphist/pkg-plist3
6 files changed, 61 insertions, 0 deletions
diff --git a/x11/wmcliphist/Makefile b/x11/wmcliphist/Makefile
new file mode 100644
index 000000000000..844f23f9d59f
--- /dev/null
+++ b/x11/wmcliphist/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: wmcliphist
+# Date created: Thu Jul 5 14:43:55 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmcliphist
+PORTVERSION= 0.2
+CATEGORIES= x11 windowmaker
+MASTER_SITES= http://linux.nawebu.cz/wmcliphist/
+
+MAINTAINER= pat@databits.net
+
+USE_X_PREFIX= yes
+USE_XPM= yes
+USE_GTK= yes
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.ifndef(NOPORTDOCS)
+ @${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m ${SHAREMODE} \
+ ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/${PORTNAME}
+.endif #NOPORTDOCS
+
+.include <bsd.port.mk>
diff --git a/x11/wmcliphist/distinfo b/x11/wmcliphist/distinfo
new file mode 100644
index 000000000000..f1429a2d2cf5
--- /dev/null
+++ b/x11/wmcliphist/distinfo
@@ -0,0 +1 @@
+MD5 (wmcliphist-0.2.tar.gz) = d8d7d6ec26e958c95651c7dd9c7b5d07
diff --git a/x11/wmcliphist/files/patch-Makefile b/x11/wmcliphist/files/patch-Makefile
new file mode 100644
index 000000000000..e028e588cc59
--- /dev/null
+++ b/x11/wmcliphist/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Tue Mar 20 20:27:15 2001
++++ Makefile Fri Jul 27 16:59:05 2001
+@@ -1,13 +1,14 @@
+ CC = gcc
+-CFLAGS = -Wall -g -ansi `gtk-config --cflags` -I. -Ifoodock
+-LFLAGS = `gtk-config --libs`
++CFLAGS += -Wall `${GTK_CONFIG} --cflags` $(INCDIR)
++LFLAGS = `${GTK_CONFIG} --libs`
++INCDIR = -I. -Ifoodock -I${X11BASE}/include
+ OBJECTS = wmcliphist.o
+ TARGET = wmcliphist
+
+ all: $(TARGET)
+
+ wmcliphist: $(OBJECTS) foodock/foodock.o
+- $(CC) $(LFLAGS) -o $@ $(OBJECTS) foodock/foodock.o
++ $(CC) $(CFLAGS) $(LFLAGS) -o $@ $(OBJECTS) foodock.o
+
+ wmcliphist.o: wmcliphist.c icon.xpm foodock/foodock.h
+
diff --git a/x11/wmcliphist/pkg-comment b/x11/wmcliphist/pkg-comment
new file mode 100644
index 000000000000..a304f829f831
--- /dev/null
+++ b/x11/wmcliphist/pkg-comment
@@ -0,0 +1 @@
+Clipboard history management dockapp for Window Maker
diff --git a/x11/wmcliphist/pkg-descr b/x11/wmcliphist/pkg-descr
new file mode 100644
index 000000000000..76b49a6dd8e2
--- /dev/null
+++ b/x11/wmcliphist/pkg-descr
@@ -0,0 +1,9 @@
+wmcliphist is a clipboard history dockapp that
+keeps history of clipboard operations and allows
+you to put previously copied items back to the
+clipboard for pasting to other applications.
+
+WWW: http://linux.nawebu.cz/wmcliphist/
+Author: Michal Krause <michal@krause.cz>
+
+- Patrick Li <pat@databits.net>
diff --git a/x11/wmcliphist/pkg-plist b/x11/wmcliphist/pkg-plist
new file mode 100644
index 000000000000..2a08594cfcfa
--- /dev/null
+++ b/x11/wmcliphist/pkg-plist
@@ -0,0 +1,3 @@
+bin/wmcliphist
+%%PORTDOCS%%share/doc/wmcliphist/README
+%%PORTDOCS%%@dirrm share/doc/wmcliphist