aboutsummaryrefslogtreecommitdiff
path: root/x11/workrave
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-18 04:54:29 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-18 04:54:29 +0000
commit2b411b245bcab72be90bd9850a126acdec3ada14 (patch)
tree4512f2e5677b02a1e0c4b3e4f4c55301e5ab9aaf /x11/workrave
parent2a691efb8b8ad8115353f27fe1ac2bbc021ce52c (diff)
downloadports-2b411b245bcab72be90bd9850a126acdec3ada14.tar.gz
ports-2b411b245bcab72be90bd9850a126acdec3ada14.zip
Notes
Diffstat (limited to 'x11/workrave')
-rw-r--r--x11/workrave/Makefile28
-rw-r--r--x11/workrave/distinfo1
-rw-r--r--x11/workrave/files/patch-arch_debug.hh11
-rw-r--r--x11/workrave/files/patch-arch_unix_Mutex.hh14
-rw-r--r--x11/workrave/files/patch-arch_unix_Thread.hh10
-rw-r--r--x11/workrave/files/patch-src_X11InputMonitor.cc24
-rw-r--r--x11/workrave/pkg-descr10
-rw-r--r--x11/workrave/pkg-plist40
8 files changed, 138 insertions, 0 deletions
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
new file mode 100644
index 000000000000..ba1e7a17fd46
--- /dev/null
+++ b/x11/workrave/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Workrave
+# Date created: 15 Jul 2003
+# Whom: Koop Mast <einekoai@chello.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= workrave
+PORTVERSION= 1.2.2
+CATEGORIES= x11 gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= einekoai@chello.nl
+COMMENT= A Gnome RSI prevention tool
+
+LIB_DEPENDS= gtkmm-2.0.6:${PORTSDIR}/x11-toolkits/gtk--2
+BUILD_DEPENDS= intltool-extract:${PORTSDIR}/textproc/intltool
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack gnomepanel
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ARGS= --datadir=${PREFIX}/share/gnome/workrave
+
+.include <bsd.port.mk>
diff --git a/x11/workrave/distinfo b/x11/workrave/distinfo
new file mode 100644
index 000000000000..987aa12a32b3
--- /dev/null
+++ b/x11/workrave/distinfo
@@ -0,0 +1 @@
+MD5 (workrave-1.2.2.tar.gz) = 412e373059da6a31bdec5833ecbef878
diff --git a/x11/workrave/files/patch-arch_debug.hh b/x11/workrave/files/patch-arch_debug.hh
new file mode 100644
index 000000000000..1190bb4a7f46
--- /dev/null
+++ b/x11/workrave/files/patch-arch_debug.hh
@@ -0,0 +1,11 @@
+--- arch/debug.hh.orig Sun Jul 13 10:04:38 2003
++++ arch/debug.hh Sun Jul 13 10:04:55 2003
+@@ -21,6 +21,8 @@
+ #ifndef DEBUG_HH
+ #define DEBUG_HH
+
++#include <assert.h>
++
+ #ifndef CWDEBUG
+
+ #define AllocTag1(p)
diff --git a/x11/workrave/files/patch-arch_unix_Mutex.hh b/x11/workrave/files/patch-arch_unix_Mutex.hh
new file mode 100644
index 000000000000..ac836e9ded7c
--- /dev/null
+++ b/x11/workrave/files/patch-arch_unix_Mutex.hh
@@ -0,0 +1,14 @@
+--- arch/unix/Mutex.hh.orig Sun Jan 5 00:53:45 2003
++++ arch/unix/Mutex.hh Sat Jul 12 16:40:21 2003
+@@ -23,6 +23,11 @@
+
+ #include <pthread.h>
+
++// define this to something freebsd knows
++#ifdef __FreeBSD__
++#define PTHREAD_MUTEX_RECURSIVE_NP PTHREAD_MUTEX_RECURSIVE
++#endif
++
+ /*!
+ * A Mutex class.
+ */
diff --git a/x11/workrave/files/patch-arch_unix_Thread.hh b/x11/workrave/files/patch-arch_unix_Thread.hh
new file mode 100644
index 000000000000..bdcddcd2f595
--- /dev/null
+++ b/x11/workrave/files/patch-arch_unix_Thread.hh
@@ -0,0 +1,10 @@
+--- arch/unix/Thread.cc.orig Sun Jan 5 00:53:45 2003
++++ arch/unix/Thread.cc Sat Jul 5 13:58:39 2003
+@@ -20,6 +20,7 @@
+ #include "config.h"
+ #endif
+
++#include <time.h>
+ #include "Thread.hh"
+
+ void *
diff --git a/x11/workrave/files/patch-src_X11InputMonitor.cc b/x11/workrave/files/patch-src_X11InputMonitor.cc
new file mode 100644
index 000000000000..e4939d32f71e
--- /dev/null
+++ b/x11/workrave/files/patch-src_X11InputMonitor.cc
@@ -0,0 +1,24 @@
+--- src/X11InputMonitor.cc.orig Sat Mar 22 14:53:57 2003
++++ src/X11InputMonitor.cc Mon Jul 14 17:47:35 2003
+@@ -39,6 +39,7 @@
+ #if HAVE_UNISTD_H
+ # include <unistd.h>
+ #endif
++#include <sys/select.h>
+
+ #include <X11/X.h>
+ #include <X11/Xproto.h>
+@@ -174,11 +175,13 @@
+ TRACE_MSG("waiting");
+ abort = true;
+
++#ifdef HAVE_XRECORD
+ //FIXME: stop_xrecord does not seem to work.
+ if (use_xrecord)
+ {
+ monitor_thread->stop();
+ }
++#endif
+ // wait_for_terminated_signal.wait();
+ TRACE_EXIT();
+ }
diff --git a/x11/workrave/pkg-descr b/x11/workrave/pkg-descr
new file mode 100644
index 000000000000..bdec04f48b08
--- /dev/null
+++ b/x11/workrave/pkg-descr
@@ -0,0 +1,10 @@
+Workrave is a RSI prevention tool. It knows 2 types of breaks and
+had a day limit.
+
+The time of the breaks, the time between and the day limit are fully
+customizable.
+
+When not typing or moving the mouse the counter stops.
+So it will only count the time you use the computer.
+
+WWW: http://www.workrave.org/
diff --git a/x11/workrave/pkg-plist b/x11/workrave/pkg-plist
new file mode 100644
index 000000000000..00aa09e15f36
--- /dev/null
+++ b/x11/workrave/pkg-plist
@@ -0,0 +1,40 @@
+bin/workrave
+etc/sound/events/workrave.soundlist
+share/gnome/pixmaps/workrave/workrave-icon-small.png
+share/gnome/sounds/workrave/break-ignored.wav
+share/gnome/sounds/workrave/break-prelude.wav
+share/gnome/sounds/workrave/daily-limit.wav
+share/gnome/sounds/workrave/micropause-ended.wav
+share/gnome/sounds/workrave/micropause-started.wav
+share/gnome/sounds/workrave/restbreak-ended.wav
+share/gnome/sounds/workrave/restbreak-started.wav
+share/gnome/workrave/images/daily-limit.png
+share/gnome/workrave/images/display.png
+share/gnome/workrave/images/micropause.png
+share/gnome/workrave/images/monitoring.png
+share/gnome/workrave/images/network.png
+share/gnome/workrave/images/prelude-hint-sad.png
+share/gnome/workrave/images/prelude-hint.png
+share/gnome/workrave/images/restbreak.png
+share/gnome/workrave/images/time.png
+share/gnome/workrave/images/timer-daily.png
+share/gnome/workrave/images/timer-micropause.png
+share/gnome/workrave/images/timer-restbreak.png
+share/gnome/workrave/images/workrave-icon-large.png
+share/gnome/workrave/images/workrave-icon-medium.png
+share/gnome/workrave/images/workrave-icon-small.png
+share/gnome/workrave/images/workrave.ico
+share/gnome/workrave/images/workrave.png
+share/locale/de/LC_MESSAGES/workrave.mo
+share/locale/eo/LC_MESSAGES/workrave.mo
+share/locale/nl/LC_MESSAGES/workrave.mo
+@unexec rmdir share/locale/nl/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir share/locale/nl 2>/dev/null || true
+@unexec rmdir share/locale/eo/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir share/locale/eo 2>/dev/null || true
+@unexec rmdir share/locale/de/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir share/locale/de 2>/dev/null || true
+@dirrm share/gnome/workrave/images
+@dirrm share/gnome/workrave
+@dirrm share/gnome/pixmaps/workrave
+@dirrm share/gnome/sounds/workrave